Skip navigation

No sound on the iPhone 4s

29512 Views 27 Replies Latest reply: Feb 3, 2014 5:50 PM by pharmdoc51 RSS
  • 25Paul86 Calculating status...
    Currently Being Moderated
    Mar 11, 2012 10:00 AM (in response to jeweles311)

    I'm also having this problem, the 4s has been brilliant, up until I updated the software to ios 5.1

    Since then I have had no sound bar on the music player or any other media player,

    The buttons on the side dont do anything, and the click sounds when typing, unlocking the phone

    or taking photos has gone, the music player will work through headphones sometimes but it has

    been a bit tempermental.. Apple need to get on top of this, and quick!!

  • rahul fromchennai Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2012 7:11 PM (in response to rosswillsimpson)

    Try resetting your device by holding down both the home and lock buttons for ~10 seconds or until the device restarts, ignore the power slider.

  • cinmas Calculating status...
    Currently Being Moderated
    Mar 17, 2012 1:15 PM (in response to rahul fromchennai)

    I have restared NUMEROUS times and it works for about a minute then the sound is gone again !  What's the deal ?

  • miket3447 Calculating status...
    Currently Being Moderated
    Mar 25, 2012 11:49 AM (in response to rosswillsimpson)

    I too have this problem and I've tried every single fix several times,still nothing however if I plug my dock cable in and turn my amp to iPod it comes back but only for a limited time,if I just plug it in the dock and don't put my amp on iPod setting it does nothing,this seems very odd that most people got this problem after update and I'm sure it can't be a coincidence,I'm really p off with apple for this.RELEASE A PATCH NOW apple!!!!

  • BrownsBoas Calculating status...
    Currently Being Moderated
    May 21, 2012 8:12 AM (in response to kadec)

    I'm having the same problem no sounds, does ring for a call, but no other sounds! Just updated the software and this happens! Full sound when headphones are plugged in... have done 3 or 4 hard resets and reset all settings and that didn't fix it. Obviously a software bug that needs to get fixed! Way to expensive of a device for this type of crap in my opinion!

  • wvisbeen Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 21, 2012 9:48 AM (in response to BrownsBoas)

    Hi, this may sound strange but try cleaning your charger connection with a toothbrush.

    It worked for me!!!

    Cheers!

  • Efilleven Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2012 1:00 AM (in response to rosswillsimpson)

    I have an iPhone 4 and have been experiencing sound problems. Usually when I am trying to play audio for a video or music on the phone speakers, headphones, or via Bluetooth. It affects the phone whether the headphones are connected or not and does not affect sounds for ringtones, phone calls, etc. I turned off wifi and the that fixed the problem. Turned it back on and instantly lost audio again. The problem is somewhat intermittent although occurs more frequently over time...not sure why. I should point out that I thought it might be a headphone jack issue and have tried disconnecting and reconnecting headphones repeatedly to resolve the issue. Sometimes I get audio back after doing this several times, but inevitabley it will randomly drop again. Sounds like an iOS problem to me. It's lame I have to use data to resolve the issue. I hope apple will address this.

  • demon007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2012 5:26 AM (in response to rosswillsimpson)

    people i have same problem with my new 4s from 2 months and the solve for this problem is:  use program IEXPLORER from internet and connect iphone then ,go to system , library and then "launch daemon" and delete com.apple.iapd.plist and problem are 100% solved after phone restart.tank'you and I hope I was helpful

  • Cehezu Calculating status...
    Currently Being Moderated
    Dec 5, 2012 8:53 PM (in response to scousky)

    Thanks for the tip, i went a little further I vacuum the docking area on the iphone, cleaned it with the thoothbrush 3 to 4 times making sure the tips of the toothbrush touch the uppper and lower contacts of the docking area, finally I blew several times pretty hard in it and suddenly there it was all sounds working.

  • Cehezu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2012 6:58 PM (in response to Cehezu)

    Sorry guys unfortunatley it only work for one night, today morning the sound was gone again, took the iphone back for a warranty replacement to my phone service provider they say I should have it with in 5 days.

  • stuartloh Calculating status...
    Currently Being Moderated
    Feb 8, 2013 6:01 PM (in response to demon007)

    Millions thanks. it really work. luckily i dont have to do the big procces to restore the hand set.

  • Fukui123 Calculating status...
    Currently Being Moderated
    Dec 29, 2013 5:14 PM (in response to rosswillsimpson)

    Hi all,

     

    recently i've had issue of not being able to play any sound via the speaker on my 4s (be it ring, speakerphone, music etc).  I've combed through all the forums and in the end figured it out.  Here is a summary:

     

    there are several possible causes.

     

    1) Phone is on mute from the switch on the side:  Simple but there were still some peeps out there who had this problem.

     

    2) Phone is stuck in headphone mode due to debris: the solution being inserting and taking out the headset in hopes of cleaning the hole.

     

    3) Phone is stuck in dock mode: once again due to debris accumulating in the dock/charge connector area.  Clean/blow the area fixed it for a lot of people.  By far the most common prob on the forums,

     

    4) Bad circuit board connection: fixed by pressing down on bottom right of the phone.  This only rarely worked for some ppl.

     

    5) Phone messed up due to bluetooth.  This was a rare problem but it was what happened to me.  I recently got a new car and have been using bluetooth to place calls in the car.  My speaker only stopped working after several days of pairing it with the car so it was weird.  In any case, I fixed my problem by placing a call in the car, and during the call, changing the audio source to phone speaker (the phone gives you like 3 options, just look at the screen when talking). everything worked afterwards.  I no longer use bluetooth in the car just in case.

     

    6) other solutions that didnt seem to work at all for people was doing restart, hard reset, slamming phone (lol)

  • pharmdoc51 Calculating status...
    Currently Being Moderated
    Feb 3, 2014 5:50 PM (in response to rosswillsimpson)

    I just started having a similar problem after owning the phone for about 4 months. Tried everything I could think of with no results. Finally my step-son said try resetting it to original factory settings. I tried it. Now I get the notification sound of a text coming in if I have my phone set on desktop. If my phone is in messages and another comes in, it will not alert me. Works better than nothing. I just have to remember to click out of messages after reading each one. we'll see how long that works.

     

    John

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.