Skip navigation

Mac Pro Constantly Losing Wireless Connectivity

18630 Views 24 Replies Latest reply: Apr 29, 2013 8:01 AM by akuAtaja RSS
1 2 Previous Next
quinndagit Calculating status...
Currently Being Moderated
Mar 13, 2012 1:49 PM

Hi Guys,

 

I've read the exact same symptoms to my problem on this thread on the MacBook Pro Forum https://discussions.apple.com/thread/1352518 but my problem is with my Mac Pro. I cant find any information on that thread that works for me. I'll briefly describe the problem below if you cant be bothered reading "ffredburger"s post.

 

I have my house set up with the wireless modem/router in the kitchen and use wireless to my Mac Pro upstairs.

I have a PC laptop which also uses the wireless and has never had a problem.

My Mac Pro loses access to the net every few minutes or so. I usually follow a sequence of "Turn AirPort Off" / "Turn Airport On" to cycle the connection, and this works but only for a temporary solution until it drops out a few minutes later.

wifi.png

also link to pic here.. http://i.imgur.com/k1oTi.png

It always shows full bars even though in the activity monitor it just flatlines or flutters near 0kB/sec.

 

Like many others, my connection drops although the wireless signal icon remains full.

 

I've noticed that as long as my system doesn't idle (ie - if I'm downloading something, or on a webpage which is always sending or recieving data) the wireless connection seems alright. But if I am on a webpage (for instance, this Apple website which is idle and not sending or recieving data) for a few minutes or am away from the computer for 5 minutes, the connectivity dies and I cant access the net. I then follow a sequence of "Turn AirPort Off" / "Turn Airport On" to cycle the connection, and this works but only for a temporary solution until it drops out a few minutes later.

 

My PC Laptop has never had any issues.

My wireless modem/router has been checked and troubleshooted but no solution.

My ISP have came and checked my phone line but no solution.

I recently upgraded to Leopard, hoping that would fix this issue but no solution.

Tried all the updates but no solution.

 

If anyone can help me it would be much appreciated as I cant find anything to work.

Also, can I ask that NO ONE suggest that I hook my computer up via the ethernet cable as there is no access points upstairs and I'm not going to pay a tonne of money to get one installed when I paid a tonne of money for my "AirPort Extreme" so I didnt have to (which was just over 2 years ago).

 

Its been a constant problem for the last 12 months and the short-fix of "Turn AirPort Off" / "Turn Airport On" to cycle the connection has driven me to madness (especially when I write a lot of information into a site for example this, and after 15 minutes I click the next button or send and dont realise the net is no longer connected and I LOOSE EVERYTHING I'VE JUST TYPED. It's happened 1000's of times. Also because I used to work from home and I was getting paid by how many questions/solutions I did in an hour and my pay was half of what everyone else was getting due to all the drop outs and loosing data I'd spent 5 minutes typing)

 

Yours sincerely,

Peter

 

ps - here's my system info below

About this Mac.png

also link to pic here... http://i.imgur.com/QOVBB.png

 

Also here's some info about my wifi in my "System Information"

----------------------------------------------------------------

  Software Versions:

  CoreWLAN:    2.1.2 (212.1)

  CoreWLANKit:    1.0.2 (102.2)

  Menu Extra:    7.0.2 (702.1)

  configd plug-in:    7.1.2 (712.1)

  System Profiler:    7.0 (700.3)

  IO80211 Family:    4.1.2 (412.2)

  WiFi Diagnostics:    1.0.1 (101.1)

  AirPort Utility:    6.0 (600.92)

  Interfaces:

en2:

  Card Type:    AirPort Extreme  (0x14E4, 0x88)

  Firmware Version:    Broadcom BCM43xx 1.0 (5.10.131.36.11)

  MAC Address:    00:1d:4f:fe:c7:f6

  Locale:    APAC

  Country Code:    US

  Supported PHY Modes:    802.11 a/b/g/n

  Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165

  Status:    Connected

  Current Network Information:

Quinn:

  PHY Mode:    802.11n

  BSSID:    00:1c:df:e3:87:f9

  Channel:    6

  Country Code:    US

  Network Type:    Infrastructure

  Security:    WPA2 Personal

  Signal / Noise:    -87 dBm / -87 dBm

  Transmit Rate:    52

  MCS Index:    5

----------------------------------------------------------------

 

Message was edited by: quinndagit PLEASE HELP!

Mac Pro, Mac OS X (10.7.3), AirPort Extreme
  • Carolyn Samit Level 10 Level 10 (84,070 points)
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Mar 16, 2012 8:25 AM (in response to quinndagit)

    Have you tried running a stumbler program to take a look at the use of the WiFi channels around you? Maybe there is something hogging the airwaves nearby. iStumbler seems to work, and there are others as well.

     

    If you are not using any older 802.11b (11 Mbits/sec) devices, you might want to try turning that compatibility off at the Base Station. The theory is that the Base Station is momentarily dropping high-speed transfers to "sniff" for low speed transfers, and maybe your computer's sampling is eventually lining up with the "dead times" when it is on the other speed. "It seems to disappear".

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Mar 18, 2012 9:12 AM (in response to quinndagit)

    Your fundamental problem is pretty clear from the iStumbler data.

     

    30 percent signal strength would give you a good signal, except that two other stations are talking on that channel at the same time.

     

    The first chart show that there are THREE Base Stations in range on channel 6 (the one you are using), and they have signal strength within 5 or ten percent of  your Base Station. This is giving you interference and will eventually lead to your connection dropping out.

     

    And channel 1, the next choice, is also already pretty busy.

     

    If your Base Station is set to Automatic channel selection, cycling its power (one of the first-recommended steps in problem solving) is supposed to move it to a channel that is less busy. Channel 6 is the default choice, then it may choose 1, then 11. If your Base Station is not capable of Automatic channel selection, or makes a bad choice, you can manually set it to a less-busy channel, but you will have to re-check from time-to-time.

     

    Based on the data at your location, channel 11 is currently the clearest.

     

    While you have it open for re-configuring, if you are not using ANY 802.11b (11 Mbits/sec) devices you should turn OFF that compatibility.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Mar 18, 2012 9:18 AM (in response to quinndagit)

    The keep-alive "fix" is for a different problem than the one you are experiencing. I would not expect it to do anything useful for you.

     

    You need to get off the busiest channels in your neighborhood and reduce interference from other base stations nearby.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Mar 18, 2012 10:25 AM (in response to quinndagit)

    Link not working.

     

    30 percent strength is good enough for many purposes. Are you still having trouble?

     

    My house has thick plaster over wire lath, and the old armored electrical cables ground it out in many place. I get horrible signal strength almost everywhere. The solid masonry chimneys are very thick, and block the signal even more.

     

    I did some experimenting with the Base Station by putting its power cord on a long extension cord, using extra long Ethernet cables, and placing it in different locations until i got the best possible signal at the computer.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)
    Currently Being Moderated
    Mar 21, 2012 9:17 AM (in response to quinndagit)

    The other signals are from my neighbours where live in houses about 15-25 metres away

    That means your neighbors' routers can give you the same signal strength from 15-25 meters farther away.

     

    If this were mine to do, I would invest in a better Router.

    Mac Pro (Early 2009), Mac OS X (10.6.8), & Server, PPC, & AppleTalk Printers
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.