Skip navigation

Ibook Author audio (AAC) media widget rejected in validation??

8156 Views 78 Replies Latest reply: Feb 7, 2014 6:40 AM by BellaGolfer RSS
  • Corsicansailor Calculating status...

    Hi Providence.

    thanks for the info. i'll try and let the community know if it works for me too. Cross fingers

     

    @Richo tell me more about the Artic book

     

    Best regards to all

  • Corsicansailor Level 1 Level 1 (0 points)

    No way for me Guys ...

     

    ERROR ITMS-9000: "Files of type audio/x-m4a are not allowed outside of widgets: assets/media/5bells5Gongs4Blast.m4p" at Book (MZItmspBookPackage)

     

    same problem.

     

    just to let you know another thing i've tried yesterday :  

    1 / Unzip the ibook package

    2 / => OPS => assets => media => replacement of all audio files m4p by the same audiofiles m4a format

    3 / Ziping and adding .ibooks extension

    4 / Ready to deliver

    5 / =>   ERROR ITMS-9000: "Unable to parse opf file: container.xml" at Book (MZItmspBookPackage)

    6 /

  • MrBlobby1970 Calculating status...

    Regarding DRM Free, Apple states in their documentation that even if you select DRM Free, audio and video files are not protected. So it doesn't seem like you are losing much by going DRM Free, as you can't protect your audio and video files anyway.

  • providence elearning Calculating status...

    That's a good point. Apple finally got back to me regarding the issue.

     

    Here it is:

     

    ERROR ITMS-9000: "Files of type audio/x-m4a are not allowed outside of

    widgets: assets/media/MacPage99.m4p" at Book (MZItmspBookPackage)

     

    Thank you for contacting iBookstore Publisher Support.  We apologize for the delay in our response.  We suggest the following:


    1- Remove the audio files from the widget

    2- Save your file

    3- Put the audio files back in the widget

    4- Save again.


    Redeliver the title again.  Please let us know how this goes. 


    Best Regards,

  • Corsicansailor Level 1 Level 1 (0 points)

    Hi Guys. I just test the Apple solution......and.........   No way.

     

    Same message again..  not allowed outside etc etc m4p...

     

    but something sound strange in their answer :

     


    1- Remove the audio files from the widget :

              But we can't remove the audio file, i have to remove the whole widget

    2- Save your file


    3- Put the audio files back in the widget

              Same thing, i have to insert a new widget and add the sound file

    4- Save again.

     

    or am I doing wrong something ??


    @RICHO Thanks forthe link. As a sailor myself i'm really impressed. We stay in touch

    all the best

     


  • johnb47 Calculating status...

    Many, many thanks, providence elearning. I've been discussing this with Apple tech support for a week. I've redone my sound files 3 times, loaded and reloaded them into the widgets, shortened the names, stripped them of the Garageband loops and nothing worked. I checked the "DRM Free" box as you suggested and it loaded without a problem. I want to buy your book when it's available! Please email me the title!

  • purdyboy Calculating status...

    Thanks everyone for all the suggestions; very helpful. We am still in the process of building our first book and knowing some of these issues helps us plan ahead.

     

    One clarification: Are you all getting this error for audio only in the Media widget or does this apply to audio called by the HTML widget?

     

    I'm planning to use HTML for most of my audio playback. All the best...

  • providence elearning Level 1 Level 1 (10 points)

    It's too bad the "DRM Free" checkbox didn't work for everyone. One thing that we tried in our endless number of failed workarounds was an earlier suggestion from this post.

     

    corsicansailor, try removing the first piece of audio that appears in your book, then take the raw MP3 of that file and open it with QuickTime, AND ONLY WITH QUICKTIME NOT ITUNES. Then export as an audio file, and don't bring it into iTunes. Take and drag the M4A file from your finder window and drop it back in your book.

     

    One thing we started noticing is that if the first piece of audio in a book is brought in this way most of the subsequent audio files don't appear in the error log.

     

    Also check your iTunes producer package file to make sure Your old iba files are not still in there. We started over with a new package and that's when I noticed the DRM checkbox.

  • Corsicansailor Level 1 Level 1 (0 points)

    Thanks for the info Providence......but NO WAY again !

     

    I did everything i know.

     

    1 / I followed the first step given by Apple in your previuos post... no way

     

    Then i tride another way:

     

    2 / I made a new audio file with audacity and export directly in AAC with it. No way to drag in IBA. I open it with QT and register in M4A. I drag directly to IBA. Saving. Delivering.... ERROR

     

    3 / Same thing until draging : this time i insert a widget and drag the file sound in the widget again....etc..ERROR

     

    I tried to deliver without that sound file and ERROR again on another file...

    Just to let you know :

    Free DRM is checked. This sound file is not the first one. Is one of the last of the book..

     

    Still trying and thanks for the help. Stay in touch

  • Corsicansailor Level 1 Level 1 (0 points)

    Hi Guys.

     

    i tried this solution :

    I unzip the ibooks to change the m4p audio files format to m4a

     

    Open the Terminal and use this code line supposed to zip all the files without the DS_Store, in the right order  :

     

    zip -X0 book.epub mimetype || zip -Xur9D book.epub META-INF OPS -x *.DS_Store and draging the unzip folder

     

    Hit return and i have on my desktop an epub file... named : book.epub

    Changing name and extension => myibook.ibooks

     

    Opening package with ITProducers = > Assets=> loading the "Brand new Homemade ibooks file => Deliver

     

    Everything goes well.....until this :

     

    ERROR ITMS-9000: "resource OPS/assets/media/5bells5Gongs4Blast.m4p is missing" at Book (MZItmspBookPackage)

     

    BUT : the sound file is really in the assets folder.. ??

    i kept the terminal lines if this help... and trying fighting again !

    Cheers guys

1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.