1 2 3 Previous Next 38 Replies Latest reply: Dec 27, 2013 9:04 AM by lhuima
pyaros Level 1 Level 1 (0 points)

I'm running iOS 5.0.1 on both my iPad 2 and iPhone 4 and recently the 'No Limit' option under mail Days to Sync has disappeared the only options are 1 Day, 3 Days, 1 Week and 2 Weeks.

 

This is obviously limiting my ability to access emails older than two weeks.  I can't find information regarding the loss of this feature - does anyone know what happened to it?


iPhone 4, iOS 5.0.1
  • 1. Re: 'No Limit' option under Mail Days to Sync disappeared
    Justin Witz Level 1 Level 1 (0 points)

    Same issue, this su.cks does anyone know?

  • 2. Re: 'No Limit' option under Mail Days to Sync disappeared
    jeffreyfromnaples Level 1 Level 1 (0 points)

    I have the same issue. Have either of you figured out the problem yet

  • 3. Re: 'No Limit' option under Mail Days to Sync disappeared
    AtomicVariable Level 1 Level 1 (0 points)

    My first post. I could not help but set up my user account and reply as this has been driving me nuts.

     

    iPhone 4S and iPad 2 both now with 5.1 iOS.

     

    Same thing, where did the Mail Days To Sync No Limit option go.

     

    Through much painstaking dead end research, I think ai have a conclusion on my end.

     

    I use GoDaddy exchange email and I believe they have pushed a server restriction out on the users. I have not got them to admit this as their support in exchange dept says they have had other calls on this but get no answers from the engineers or devs.

     

    This appears to be the source as this option still exists with other accounts so it cannot be an iOS thing.

     

    I have found a workaround, at least for the moment my entire mailbox, subfolders and all, appears to be operating under the no limit rule, which is a necessity for my business. How could anyone think restricting this option without reporting such to the customer is a good idea?

     

    I'm not sure which one did the trick but here are the steps I used to get it back functioning. It was a little more stubborn on the iPad because every time I wold recreate the account, it defaulted to 3 Days.

     

    Step 1: toggle off SSL in account settings. It warns you that you may not be ale to send or receive email after it fails to verify your account (at last with GoDaddy Exchange). Save in this state anyhow. You will notice your mailbox disappears. Go back into options and turn SSL back on. Check Mal Days To Sync. On iPhone it defaulted to no option selected. Leave like this! It is the equivalent of No Limit. As soon as you select a limiting option it can not be undone, unless in theory you repeat these steps.

     

    Step 2: On iPad this did not do the trick because it kept defaulting to 3 Days option. Do not delete your exchange account, but rather de-select Mail option from syncing. This blows out your mailbox but the option for no limit returns. Select No Limit. Turn mail back on.

     

    Step 3: forget this ever happened and go back to enjoying your older email messages on your mobile devices.

     

    Please post feedback if this worked for you. I could not find anything on this anywhere so felt obligated to share. I'd like to see if it helps anyone with the same issue.

     

    Also please state in reply who hosts our exchange server. It would be interesting to see if it is GoDaddy across the board.

     

    Thanks for reading!

  • 4. Re: 'No Limit' option under Mail Days to Sync disappeared
    Do a better job Level 1 Level 1 (0 points)

    You are a god!  I was ready to bail on go daddy!!

  • 5. Re: 'No Limit' option under Mail Days to Sync disappeared
    AtomicVariable Level 1 Level 1 (0 points)

    Glad it worked.  It is interesting to see you are a GoDaddy customer also.

     

    It has to be forced from the exchange server side because the option reappears until it connects to their server.

     

    I see there are other threads on this now. Perhaps an admin or moderator can combine the threads or redirect members posting to the other threads to my solution?

  • 6. Re: 'No Limit' option under Mail Days to Sync disappeared
    Justin Witz Level 1 Level 1 (0 points)

    Yes just worked for me as well, but I got to see the "No Limit" option. I use GoDaddy Hosted Exchange as well, glad to see you find a working workaround, if not a perfect fix!

  • 7. Re: 'No Limit' option under Mail Days to Sync disappeared
    ChrisJ4203 Level 7 Level 7 (28,180 points)

    While I am not a moderator, here is a link to the other thread. https://discussions.apple.com/message/17760574#17760574 The only reason I know is because I answered the OP regarding settings. From what the other post states, it seems to be a GoDaddy thing. I have a regular Exchange account on my iPhone 4S from the college I work at and I am on iOS 5.1. it still has the No Limit option, so it appears it is a setting from GoDaddy.

  • 8. Re: 'No Limit' option under Mail Days to Sync disappeared
    AtomicVariable Level 1 Level 1 (0 points)

    @Justin Witz: The phrase No Limit appeared for a short period of time after I fixed it on the iPad, but never on the iPhone. After a little syncing with the server the option disappeared and left it blank - unselected.

     

    @ChrisJ4203: Thanks.

  • 9. Re: 'No Limit' option under Mail Days to Sync disappeared
    mikewww Level 1 Level 1 (0 points)

    I am a barnd new convert from BB and am having the same go daddy/iphone issue in that I cant "no limit" option to appear. I tried as suggested above to no avail. To be clear i went inot setting, exchange, account , turned off "use SSL", saved it, then when back in and turned "Use SSL" back on. I dont see where it defaults to a no option selected - the one month is still checked off. Am I missing a step? Thanks!        

  • 10. Re: 'No Limit' option under Mail Days to Sync disappeared
    AtomicVariable Level 1 Level 1 (0 points)

    Try the subsequent step listed above that I had to take for my iPad.

     

    -  disable Mail syncing and save. No Limit should reappear. Select it. Turn your mail sync back on. Go to Mail app and sync your folder and see if your older messages are there. Leave the Mail Days To Sync field alone as it will immediately or at some point appear blank. The moment you select one of the limiting options it is saved and cannot go back without (in theory) redoing these workarounds. I am not going to be messing with mine - unless I have to reinstall the exchange account (which I have to do from time to time) becasue it gets real quirky.

     

    Curse you GoDaddy! I cannot believe they would push this 1 month max mail sync limit out to their users without ddsclosure or admission.

  • 11. Re: 'No Limit' option under Mail Days to Sync disappeared
    AtomicVariable Level 1 Level 1 (0 points)

    Post back your results please.

  • 12. Re: 'No Limit' option under Mail Days to Sync disappeared
    mikewww Level 1 Level 1 (0 points)

    that worked - Thanks!!!!!!!

  • 13. Re: 'No Limit' option under Mail Days to Sync disappeared
    AtomicVariable Level 1 Level 1 (0 points)

    You're welcome Mike. I know how frustrated I was on this issue, so I am happy to help others with it. Hopefully, those affected will find this and this fix won't stop working!

  • 14. Re: 'No Limit' option under Mail Days to Sync disappeared
    yorchi Level 1 Level 1 (0 points)

    GoDaddy exchange hosting it is. I called them on it after i added my jobs exchange account and saw that "No Limit" was avaialble but of course they denied any changes to their systems. Their only answer was they don't support iOS. I've been struggling when trying to reference older messages but now thanks to this post I'm getting all messages. Thanks!

1 2 3 Previous Next