1 17 18 19 20 21 Previous Next 366 Replies Latest reply: Jan 31, 2014 2:45 PM by polgriz Go to original post Branched to a new discussion.
  • 270. Re: Unable to purchase.
    Emiliano Severoni Level 1 Level 1 (0 points)

    As I said before, the iExplorer thing didn't work for me.

    THEN I tried deleting the manifest.plist file and I put again in the folder where it was.

     

    I wrote in this topic because the apps stuck in "waiting" issue seems to be present is a lot of cases I read in these 18 pages. The iExplore procedure is listed elsewhere in resolving this issue also (make a google search and you'll see that everybody say to EMPTY the "downloads" folder, so deleting manifest.plist also), so the two things must be connected in some way.

     

    The fact that you didn't see any issue where apps would "remain stuck on 'waiting' does not mean that no one has this issue. If you make another google search you'll find that a lot of people have this problem and that there is not only one way to solve it. And not all solutions seem to work for everybody. For me, none of them. iExplorer is one of them. Worked for a lot of people, not for me.

     

    I never metioned the activity spinner. I know that its presence means that the device is downloading but, see the point, it's not my case: the apps remain on "waiting" and there is NO activity spinner on the upper left corner. And they remain on "waiting" even if I double tap them. These are basic things about iOS that I already new and I already tried.

  • 271. Re: Unable to purchase.
    ikemarrus Level 1 Level 1 (0 points)

    Really wish Apple would just include an option in the Settings to clear out the Downloads folder.  (Although I'm good to go having restored from a backup - the problem never returned - over a week -  thankfully)

  • 272. Re: Unable to purchase.
    VesperDEM Level 1 Level 1 (0 points)

    @ikemarrus: Normal operation does clear out the Downloads folder as I have stated above. My downloads folder is clear of any other files/folders other than the manifest.plist and downloads.28.sqlitedb files. I have downloaded several apps since clearing it out manually. The reason it needs to be cleared manually is that the downloads.28.sqlitedb file is getting corrupt somehow.

  • 273. Re: Unable to purchase.
    Emiliano Severoni Level 1 Level 1 (0 points)

    The fact is that, In my case, the file downloads.28.sqlitedb is corrupted and continues to be corrupted even if I delete it manually.

  • 274. Re: Unable to purchase.
    VesperDEM Level 1 Level 1 (0 points)

    @Emiliano: I read your post clearly. What I am saying is that what you are seeing is not related to the "Unable to Purchase" issue that the thread is talking about.

     

    I never stated that the iExplorer fix should have worked for you. I'm trying to say that the problem you are experiencing is not the one that others in this thread are experiencing.

     

    I also never stated that no one else is seeing your issue. I keep trying to tell you that the issues reported in this thread are not the same as the one you are experiencing. The iExplorer fix solves the problem stated by this threads title: "Unable to Purchase".

     

    As to your downloads.28.sqlitedb file... Do you know for a fact that the file is corrupt? Have you taken the file into a tool that can display data in that sqlitedb file?

     

    I can't say that when I was experiencing the "Unable to Purchase" issue, that the sqlitedb file was in fact corrupt. All I can say for a fact is that after deleting the file (it was over 770KB's), my "Unable to Purchase" issue went away and the new sqlitedb file that was created by iOS was 28KB's and is now 100KB's.

     

    I'm sorry if I suggested something that you have already tried. I'm afraid that I can't read your mind or know what you have tried in the past (unless you actually posted every thing you have tried in this thread and I didn't read that post.

     

    Really man, you need to relax. I realize that your issue is annoying and frustrating. However, is it really necessary to jump down my throat just because I am trying to help you?

  • 275. Re: Unable to purchase.
    Emiliano Severoni Level 1 Level 1 (0 points)

    I'm perfectly relaxed and no one is jumping on your throat.

    I wrote on this topic because the issues "unable to purchase" and "apps stuck on 'waiting'" seem to be related (if you read all the 18 pages as I did, it will become obvious to you). If you make that google search I suggested, you'll see it by yourself that in a lot of cases the two things happen together. So this thread should talk also about this.

    That's why I posted here, I'm not off-topic as you think I am.

     

    What I think is that these issues have something in common, given that the suggested solution (iExplorer) is the same for both. Sure, this is not proven by anything and that's why I'm here: to search and understand if the two things are connected, not for screw-up an entire thread.

     

    My downloads.28.sqlitedb file (the new one) is not 28kb but 80kb. The "corrupt" one (and what I wonder is why this file got corrupted) was about 100kb. That's the reason why I'm saying that the iExplore solution doesn't work the same for everyone.

  • 276. Re: Unable to purchase.
    VesperDEM Level 1 Level 1 (0 points)

    Sorry, the tone of one of your comments to one of mine "appeared" to be angered. If I miss-interpreted that tone, I'm truly sorry.

     

    I do feel the two issues you mention are related, just not in the way you do. Or at least I get the impression you do. I have read all 18 pages of comments in this thread. I came into this thread looking for a solution to the problem I was experiencing; freezing, greying icons, and the "Unable to Purchase" seemably random pop-ups. The thead solved my issue, for that I am immensely greatful!

     

    Let me ask you, when you see this "apps stuck on 'waiting'" issue, what do you do next? Do you turn-off (not put to sleep), then turn back on your device? Do you force a reboot (Hold the power and home buttons down until the Apple logo appears), or is there a different set of steps you take to get past the issue?

     

    I ask, because I feel that the sqlitedb file gets corrupt when an app stalls in download and the user gives up and either reboots the device or does something that iOS doesn't like to stop the download (working or not).

     

    I'm wondering if there is a "safe" way to stop the download if the user feels it's not progressing. Does, deleting it (via tap-holding the icon, then tapping the delete glyph) cleanly stop the download? Does turning the device off, then back on cleanly stop it?

     

    I have seen the issue you described as "apps stuck on 'waiting'". When I saw it, I was impatient and tried turning off, then back on my device. I'm wondering if that is what corrupted my sqlitedb file. I also got so impatient that I force rebooted my device. I have to assume that one of those two ways or both corrupted my sqlitedb file.

     

    I haven't seen a download stall since deleting the sqlitedb file, so I can't say for certain that doing those things corrupted it. I haven't had any issues with downloads for quite some time. Even during my freezing/greying icons/Unable to Purchase issue. I only saw the "stuck on 'waiting'" issue a couple of times back in February.

     

    If I ever see a download stall, I'll report it here.

     

    Oh, one big question... Is the app that is not downloading correctly a large app or smaller one? The ones that stalled for me were on the order of a CD in size. 650+MB's. I have never had a smaller app stall.

  • 277. Re: Unable to purchase.
    Emiliano Severoni Level 1 Level 1 (0 points)

    No need to apologize.

     

    What i did after seeing apps stuck on "waiting" is use iExplorer and delete the downloads.28.sqlitedb.

    Then I turn off and on again the iPad or force reboot it holding both the power and home buttons until the Apple logo appears.

     

    There is a "safe" way to stop the download. You have to wait some time and you can delete the app as any other else, holding your finger on it and pressing the X on the upper left corner. If you turn off and on the device, the app stuck simply disappears.

     

    I try to download only light sized apps.

  • 278. Re: Unable to purchase.
    icewing Level 1 Level 1 (0 points)

    Used iExplorer to delete the downloads.28.sqlitedb file, rebooted my iphone, and it appears to have been fixed. 

     

    Thanks, everyone!

  • 279. Re: Unable to purchase.
    Morac Level 1 Level 1 (70 points)

    Having applied the iExplore fix on my iPad 2 and wiping out everything in the download directory except the Manifest file and seeing that it worked fine for two weeks, I decided to do the same thing on my iPhone 4S last weekend.  I did the same thing, deleting everything in the download directory.  Strangely the iPhone 4S didn't have a Manifest file, which makes me think that file isn't used in iOS 5 or higher and it's just a leftover file from iOS 4. 

     

    I had tried everything to fix this problem (updating credit card info; turning off background download; signing out of app store, rebooting and signing in, removing app and redownloading, etc) and none of that worked long term.  The only thing that worked was the iExplore fix.

     

    From what I can tell from looking at the downloads.28.sqlitedb on my iPad 2 two weeks after applying the fix, that file should be more or less "empty".  It has stuff in it such as what apps have tried to access the app store (i.e. in app purchases), but nothing about recent downloads in it.  Also the downloads directory has no folder in it.  So my guess is that something got screwed up with the file.  Why it happened on both my iPhone 4S and iPad 2 is a mystery though.  I haven't tried recreating the circumstances that caused the problem to first occur (causing a download to fail by either typing the password wrong or trying to download an app that's too large for 3G), so I don't know if the "fix" is a permanent one or temporary.

     

     

    On a side note, I had filed a bug report with Apple about this problem and it was closed as a duplicate of an existing bug report.  That means the Apple has a bug report on file for this problem.

  • 280. Re: Unable to purchase.
    icewing Level 1 Level 1 (0 points)

    Interesting - my iPhone 4 download folder has over 160 subfolders, except for a few they all contain similar items:  a file with a long numeric name (I assume this is an app), a file named iTunesMetadatalplist, and one named thumbnail.   Some of the folders have multiple "apps", a few only contain a "thumbnail".

     

    The download folder did NOT contain a Manifest file.  iPhone 4 with 5.1.

  • 281. Re: Unable to purchase.
    VesperDEM Level 1 Level 1 (0 points)

    It's interesting, someone mentioned earlier that they thought the Manifest file was iOS 4.x. I'm beginning to think that this is the case. I wonder if the sqlitedb file was also there.

  • 282. Re: Unable to purchase.
    salt0516 Level 1 Level 1 (0 points)

    I have the same message on my iPad 2 but with a slight difference. After the message comes up it tries to download the apps it says it couldn't download and I have to go back and redelete them if I don't want them. Then the next time the message appears it redownloads all apps that are on the list no longer on my iPad. It's become quite annoying and inconvenient.

  • 283. Re: Unable to purchase.
    Zsoldier Level 1 Level 1 (0 points)

    I just noticed something.  I'm wondering if this is a reference bug w/ iCloud.  I was having this exact same issue w/ a game called 'Warp Dash' and 30 other applications according to the error.  When searching to try someone's idea of redownloading the apps, I found that the game was renamed to 'Warp Rush'.  Anyway, I'm going to keep trying this method until I get down to the last one causing problems.  Hoping Apple looks @ this and some light bulb goes off in an engineers head.

  • 284. Re: Unable to purchase.
    chasmandocharles Level 1 Level 1 (5 points)

    Just did the iExplorer fix and it worked like a charm

1 17 18 19 20 21 Previous Next