Skip navigation

iTunes 10 add to library not working

271968 Views 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew RSS
  • Guardian_Knight_1983 Calculating status...
    Currently Being Moderated
    Mar 6, 2012 11:09 PM (in response to Boudjtastic)

    I tried a few of the suggestions on here... Always loved MP3 format, so that was a good switch to do... For anyone using PC - right click the program and run as an administrator...  This should fix the issue... I had a crash after changing some of the settings, but I can now successfully import cd's without any issues.

     

    Hope this helped!

  • TJW2008 Calculating status...
    Currently Being Moderated
    Mar 8, 2012 10:58 AM (in response to Captinsmooth)

    This absolutely worked for me as well - thanks for the tip - quick and easy!

  • sixpantsmaloney Calculating status...
    Currently Being Moderated
    Mar 10, 2012 10:11 AM (in response to Boudjtastic)

    Another option: Search disks for other instances of the folder.  In my case I moved the music library to a 2nd HDD.  Turns out it created a new, active "Auto add to" folder and disabled the one in user/music/itunes/...

  • MacDaddy2361 Calculating status...
    Currently Being Moderated
    Mar 11, 2012 10:08 AM (in response to xih228)

    Agreed this is clearly attributable to the 10.6 upgrade.  My symptoms are:

     

    1) Unable to add files through any means to iTunes

    2) Previous Playlists show but no song content within them

    3) Some mp3 files I am trying to add appear to be locked on my hard drive, i unlock them but then as soon as i close the finder they are locked again...I assume that may be a Lion issue...related or not.

     

    Apple, time for a rapid update to fix 10.6 and keep your loyal customers happy.

     

    Please and Thx!

  • ncalliari Calculating status...
    Currently Being Moderated
    Mar 14, 2012 6:38 PM (in response to Boudjtastic)

    Yep, add me to the list. I too am unable to add songs to my iTunes library since the update to 10.6.

    This is quite an unbelievable bug to have gotten through Apple testing.

  • ncalliari Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2012 6:50 PM (in response to xih228)

    This worked for me too. Sign out and everything you had added instantly 'appears'. Sign back in, and then sign back in to iTunes match if you use it, and you're set!

  • Inane Geek Calculating status...
    Currently Being Moderated
    Mar 15, 2012 6:06 AM (in response to Boudjtastic)

    I was struggling too to drag some songs id had on an old hard drive i used for an old MP3 player into itunes.

     

    However by luck i went into my itunes folder and found a folder called "Automatically Add to itunes".  I dragged my files into here, opened itunes and they were there

     

    Dont know if that helps

  • spitfire411 Calculating status...
    Currently Being Moderated
    Mar 15, 2012 7:40 AM (in response to Inane Geek)

    Wow! This worked! I had tried adding an mp4 video as well as a bunch of songs. None showed up in the Library but were in the "Recently Added" playlist. I dragged the video file into the "Automatically Add to iTunes" folder and ALL the missing files showed up. I would start here people.

  • Inane Geek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 15, 2012 9:03 AM (in response to spitfire411)

    No problem.

     

    Sometimes the simplist answer is the best

  • Oakster Calculating status...
    Currently Being Moderated
    Mar 17, 2012 6:23 PM (in response to ncalliari)

    Same problem, just noticed, may well have happened with upgrade to iTunes 10.6 (Mac OS Lion). Ripped a CD and did not show up, noticed that the last few singles purchased also did not show up, even though they have been synched to cloud and are on my iPhone listed as in iCloud. Finally fixed by suggestion I read here: double-click the file in Finder that is the last single added before went nuts, plays in iTunes and suddenly it and all the stuff since shows up.

     

    Very strange.

  • T3chsupport Calculating status...
    Currently Being Moderated
    Mar 20, 2012 2:31 PM (in response to Oakster)

    FIXED!   Windows PC, iTunes 10. ( newest verison as of 3/20/2012

    some how its fixed and this is excatly what I did..

     

    Open Preferences

    Click Advanced tab

    Default folder was still the same as its always been. So I copy and pasted the folder address to my a window. Opened the podcast folder and tried to drag one of those files over. The little cuved arrow showed up to allow me to link it.

    So I went to where I store my MP3s, since Im weird and dont have that folder linked to iTunes, and started copying my new Mp3s

     

    I have no explaination as to way it started working after I did the above...

  • cGuth Calculating status...
    Currently Being Moderated
    Mar 22, 2012 9:24 PM (in response to T3chsupport)

    No not fixed, I make my own videos and like to share them with the family. The format is M4v but, I've tried other formats by converting them. Nothing works, NOTHING! To add insult to injury, I uninstalled 10.6 and after uninstalling tried to reinstall a lower version. A script was placed in my system registry so now I can't install a lower version without debugging my registry. THIS IS REDICULAS, and nothing from Apple! What a joke, the billions of dollars they have and they can't even or ever respond to help forums!.

  • Glockie Calculating status...
    Currently Being Moderated
    Apr 1, 2012 1:40 AM (in response to Boudjtastic)

    Yep mine's not working either, on the iPhone 4

     

    I tried adding an mp.3 track, a single track from an album and it would not import.

     

    I've tried importing the file, dragging and dropping and I've even re-synched my itunes library which is held on an external device, to no avail.

     

    So even re-synching plus installing the latest version of iTunes hoping it would fix it, is no good.

     

    I hope they fix this soon, as because I re-synched and I can't drag n drop or import files, my iPhone is now without music as I've no way of importing any of it!!

  • Paradoxx Calculating status...
    Currently Being Moderated
    Apr 1, 2012 2:59 AM (in response to Boudjtastic)

    Same issue here... I try to add a file (mkv in this case) and it copies into my itunes music folder correctly, which is held on an external drive, but it does not show up in the main grid, and I cannot access from within itunes.

     

    I've tried, logging in and out of itunes, playing the last added track, I even recreated my entire library (before I found this thread), but none of it has resolved the issue.

  • jekmine Calculating status...
    Currently Being Moderated
    Apr 3, 2012 4:55 AM (in response to Paradoxx)

    I  have the same issue.  Can't add any video files (m4v) to the library.  Have tried all the suggestions here.

     

    More suggestions - and BUG FIX needed!

1 ... 5 6 7 8 9 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.