Skip navigation

3 of my preference panes don't work.

8025 Views 23 Replies Latest reply: Apr 14, 2014 7:26 PM by blackknife RSS
1 2 Previous Next
captainloozer Calculating status...
Currently Being Moderated
Mar 19, 2012 4:59 PM

I just install Lion 10.7 from scratch using a bootable DVD I made from the Install Mac OS X Install ESD Dmg found within the app.  After restoring my accounts and data from a time machine backup, everything seems to work fine except for 3 preference panes within the System Preferences, (Desktop & Screen Saver, Energy Saver, and Spotlight.)  I've tried reinstalling Lion over the current installation, I've tried reinstalling the latest combo update, I've trying repairing disk permissions, I've tried installing System Preferences app as well as each individual .prefpane, none of which worked.  I've also tried going into ~/Library/Preferences and deleting com.apple.systempreferences.plist, which also didn't work.

 

When trying to run the preference pane I get:

 

"Preferences Error.  Could not load Desktop & Screen Saver preference pane."  Replace Desktop & Screensaver part with Energy Saver and Spotlight respectively for each pane.

 

When I run the preference pane, here is the output from the console:

 

3/19/12 6:13:04.765 PM System Preferences: [NSPrefPaneBundle instantiatePrefPaneObject] (/System/Library/PreferencePanes/DesktopScreenEffectsPref.prefPane): principalClass is nil.

 

All three give the same error, again replacing DesktopScreenEffectsPref.prefpane with the corresponding pane.

 

 

 

 

I've read through tons of forums about similar errors and none of their fixes are working and I'm just not ready to reformat and install from scratch again.  Any help?

 

Thanks in advance.

iMac, Mac OS X (10.7.3)
  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    Mar 19, 2012 6:01 PM (in response to captainloozer)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    Note: If you’ve activated FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Be sure your Mac is shut down.
    • Press the power button.
    • Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    • Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem(s)?

     

    After testing, reboot as usual (i.e., not in safe mode.) Post the results of steps 1 and 2.

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    Mar 19, 2012 7:29 PM (in response to captainloozer)

    While logged in as Guest in Lion, you cannot do anything except use Safari or reboot.

     

    The Find My Mac guest pseudo-account is not the same as the guest account you activate in System Preferences. If Find My Mac prevents you from activating the true guest account, either disable it temporarily, or use the alternative provided in step 1.

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    Mar 19, 2012 8:06 PM (in response to captainloozer)

    Are you the person who posted this?

     

    OS X LION 10.7.3 System Preferences - MacRumors Forums

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    Mar 19, 2012 8:34 PM (in response to captainloozer)

    Your log messages aren't quite the same, unless you've left something out.

     

    Have you reinstalled Lion only from your DVD? If so, reinstall from Recovery -- don't use the DVD. Something may be wrong with it.

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    Mar 20, 2012 1:41 PM (in response to captainloozer)

    Launch the Console application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Console in the page that opens.

     

    Click the Clear Display icon in the toolbar. Try the actions again. Post any messages that appear in the Console window – the text, please, not a screenshot.

  • Linc Davis Level 10 Level 10 (107,685 points)
    Currently Being Moderated
    Mar 20, 2012 2:25 PM (in response to captainloozer)

    It looks like you're restoring an older version of iLife from backup and overwriting some system files with incompatible ones. Reinstall again, then do a fresh installation of the iLife applications from the App Store.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.