Skip navigation

Internet connection not working after computer wakes up from sleep. OSX Lion

38017 Views 108 Replies Latest reply: Oct 8, 2012 1:55 AM by mailjeh RSS
  • techtim89 Calculating status...

    I too have never enabled my firewall, but went to check just in case and it was already off.  I'm connecting to an Apple AirPort Express V.7.6 at my home but I'm just using it as my access point.  I also have a older linksys wireless router "which the wireless is disabled" it is handing out my IP addresses.  I have a feeling it could be that router not communicating well with my MacBook Pro "with Lion".  I have several of the same AirPort Express's at my office and a SonicWall router that hands out the IP addresses, and I never have had one issue getting connected there.

     

    My solution so far has been to turn off my Wi-Fi connection give it a couple seconds then turn it back on.  Then it connects just fine.  My MacBook Pro "running Lion" is the only system having connection issues.  All my other iOS devices and my white MacBook have no problem connecting.

  • trigrou Calculating status...

    I think we are not talking about the same bug. I am able to ping and ssh from a terminal. Even firefox works, but safari, mail, chrome, adium, irc dont. It means there is something weird in the network dns or something like that. Why firefox works ? I dont know but I think it's a good question and maybe support could have a look how firefox manage dns or network.

  • kyen99 Level 1 Level 1 (0 points)

    @trigrou,  You're definitely correct that a lot of people are talking about different bugs.  The bug you're talking about is with mDNSResponder.  Terminal apps (ping, ssh, etc...) use the resolver libraries to look up IP addresses.  It seems that most GUI apps use the mDNSResponder daemon to look up IP addresses.  This is why some apps can work while some don't.

     

    When you see the problem, try going to terminal and doing this:

     

    sudo killall mDNSResponder

     

    After that, GUI apps should work again.  I'm not sure why Firefox doesn't have the same problem (except that it must use the resolver libraries instead of mDNSResponder).

     

    BTW: I created an app to do the above command that I can run from the dock.  If it helps, you can get it here:  http://goo.gl/T7zle

     

    -kai

  • skorman222 Calculating status...

    Yeah I am having the same problem.  When I start my iMac everything is fine.  But when i wake it from sleep it does not auto connect to my Wifi.  I sure hope that apple fixes this problem soon

  • HACKINT0SH Level 5 Level 5 (5,750 points)

    Can't say when it will be fixed. But engineering is currently WORKING on it.

  • skorman222 Level 1 Level 1 (0 points)

    what computers does it effect because it effected my 27 inch imac.  do you work for apple?  also thanks again

  • Y_NO Level 1 Level 1 (10 points)

    I too am having the same problem.  I stumbled upon the following solution from a blog.  It worked for me:

     

    Just UNCHECK that "Re-open windows when logging back in" button when you log out or shut down and then restart.

     

    http://macnerd-presents.blogspot.com/2011/08/os-x-lion-wifi-no-hardware-installe d.html

  • AB5000 Calculating status...

    For what its worth, I have been having this problem with my 2011 MBA with Lion since I bought it.  I upgraded to Mountain Lion Developer Preview and the problem is largely gone.  Still see it once in a while but WIFI works much better.  Also my airport with wireless N+G now works well with my laptop in my office.  Before ML I had to have a second WIFI in my office due to the position of walls and size of the place. 

     

    I believe these issues are software, not hardware

     

    FYI...

    -  ML does not support VMware fusion software (as host) or virtualbox

    -  I haven't found a way to reinstall Lion back on my MBA after upgrading to ML...the recovery USB launches a ML restore, NOT Lion.    My fault for upgrading of course...

     

    (edited for clarity)

  • HappyFatty Calculating status...

    If you want to autoconnect to a WiFi network after sleep you have to use no better encryption than WEP.

     

    If you try anything higher in the securuty chain i.e. WPA, it will not connect automatically and you will have to manually connect.

     

    I have tested this on a unibody 2010 MacBook Pro running 10.7.3. This was fine on the same hardware before Lion.

     

    Before you go formatting, resetting and all the other tasks above, just try changing your router to WEP authentication (sometimes also called Shared Key or Legacy 802.1X) because that may well save you a lot of trouble.

     

    As a result, this confirms this is a software issue and I can't for the life of me understand why Apple still don't have a fix for it when using WPA.

     

    HTH!

  • Shootist007 Level 6 Level 6 (16,640 points)

    Please stop posting this Miss Information. It is TOTALLY Incorrect, WRONG.

    Thanks.

    HappyFatty wrote:

     

    If you want to autoconnect to a WiFi network after sleep you have to use no better encryption than WEP.

     

    If you try anything higher in the securuty chain i.e. WPA, it will not connect automatically and you will have to manually connect.

     

    I have tested this on a unibody 2010 MacBook Pro running 10.7.3. This was fine on the same hardware before Lion.

     

    Before you go formatting, resetting and all the other tasks above, just try changing your router to WEP authentication (sometimes also called Shared Key or Legacy 802.1X) because that may well save you a lot of trouble.

     

    As a result, this confirms this is a software issue and I can't for the life of me understand why Apple still don't have a fix for it when using WPA.

     

    HTH!

  • HappyFatty Level 1 Level 1 (0 points)

    Please stop posting this Miss Information. It is TOTALLY Incorrect, WRONG.

    Thanks.

     

     

    Based on what?

     

    I did the above and it worked.

     

    Unless someone is planting images in my eyes and casting spells on my fingers I just presented facts - the result of physically testing on an actual device.

     

    You however have presented nothing other than a bad attitude.

     

    And my name isn't Miss Information.

  • HappyFatty Level 1 Level 1 (0 points)

    To clarify:

     

    This experience is across six different WiFi routers (Sky, Netgear (two models), Linksys, MiFi and Cisco) and five different machines (MacBook Pro Unibody, 2009 MacBook, Mini, iMac 21" and 27" in various chip configurations) so that is a pretty good sample IMHO.

     

    I have not tried it with any Apple WiFi products.

     

    So, if you are having issues reconnecting to WiFi after sleep, try what I say. It is not destructive and takes a couple of minutes. It may not work, but will save you hours based on other suggestions.

  • Stephen Dawson1 Level 1 Level 1 (5 points)

    Thought I'd post my experiences with this problem, and what fixed it for me. My symptoms:

     

    After every wake from sleep the network was unavailable to Safari, Mail etc, even though it looked like the network was up according to iStat Menus, Network Prefs etc. Using wired LAN.

     

    After a couple of minutes, according to Hardware Growler, my IP address was released and re-acquired. After that, everything worked.

     

    Killing mDNSResponder during the initial period got things working, although the IP address was still re-acquired after 2 or 3 minutes.

     

    This problem started happening suddenly for me. Then I realised that I had been testing my Epson flatbed scanner with Lion and it was still turned on. It's connected via Firewire through a Firewire hub. Believe it or not, turning off the scanner cured the problem! This is 100% repeatable. Scanner on, no network after sleep. Scanner off, everything's fine.

     

    Go figure!

  • dizm Calculating status...

    I think I've found an easy workaround to "sometimes won't re-connect wifi after sleep".

     

    I wake up by pressing the power button.

     

    Previously I was waking up by hitting spacebar.

     

    I have a 2010 iMac with the latest Lion and all updates.  Don't use time-machine.  Don't have wired connection.  Do use a bluetooth mouse.

     

    Apple, I hope you're listening, as this might be a clue.  I also have a 2011 Air, which does not have this problem -unless I have bluetooth enabled.

  • Shootist007 Level 6 Level 6 (16,640 points)

    dizm wrote:

     

    I think I've found an easy workaround to "sometimes won't re-connect wifi after sleep".

     

    I wake up by pressing the power button.

     

    Previously I was waking up by hitting spacebar.

     

    I have a 2010 iMac with the latest Lion and all updates.  Don't use time-machine.  Don't have wired connection.  Do use a bluetooth mouse.

     

    Apple, I hope you're listening, as this might be a clue.  I also have a 2011 Air, which does not have this problem -unless I have bluetooth enabled.

    Mac's They just work, Sometimes and sometimes Not.

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.