Skip navigation

Issues connecting my PS3 controller to my Macbook pro

33286 Views 12 Replies Latest reply: Jul 5, 2013 1:05 PM by Nightlife RSS
aquantumsingularity Calculating status...
Currently Being Moderated
Mar 12, 2012 8:13 AM

Hi all,

 

I've been trying to conntect my Playstation 3 controller to my macbook pro (15" early 2011 i7 8gb RAM blah blah blah) via bluetooth.

 

This issue is the actual pairing of the device. My mac will see the controller and attempts to connect but requires a pairing passcode to allow the two to connect to each other. I have found older forum discussions that go through a simple pairing process on older versions of OSX 10.5 and 6 that require no passcode pairing process at all, they simply connect. This is not the case in 10.7

 

Reading through the forums highlinghts to me that my Macbook has a newer Bluetooth 4.0 chip inside and that this might be part of the issue. The other problem is knowing which keys entered on the Mac are the same as the ones on the playstation controller, i.e. 1 = X or 2 = (triangle) which are pressed in order to complete the pairing process.

 

I am at a loss as to what to do to solve this and some help will be much appreciated.Pairing Request from PLAYSTATION(R)3 Controller.jpg

MacBook Pro, Mac OS X (10.7.3), issues connecting ps3 controller
  • vino17 Calculating status...

    Same issue here, with exact same Macbook as OP.

     

    Connect via USB, disconnect, get the above pairing request.  I've been scouring forums and Google searching until my eyes cross and I can't find a solution.  Tried deleting preference files and that didn't help.

     

    Would love to avoid buying a Windows 360 controller and wireless receiver, and was just about to call off the search when I saw this post, saw it had no replies, and figured I'd try giving it a bump.

     

    Anyone have a solution?  Anyone...?  Bueller...?

  • vino17 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2012 11:39 PM (in response to vino17)

    No sooner than I post do I find an answer.  Worked like a charm and I'm playing Abobo's Big Adventure right now (well not right now... right now I'm typing).

     

    Found the answer right here:

     

    http://forums.macrumors.com/showthread.php?t=335581&page=4

     

    Post #80 in the thread.  Will post the instructions here for convenience, but credit goes to macrumors user aruseman for the solution / workaround.

     

     

    Per aruseman:

     

    1) plug the pad using the usb cable, unplug it.
    2) don't care about the pairing request
    3)Open Bluetooth Preferences (you have ~15 sec)
    4)select the ("connected" and "configured" but not "paired") "Playstation3 controller"
    5)add it to favorites

     

    6) disconnect the controller from Bluetooth menu bar

     


    7) push the PSX button on the controller, it will connect and you are ready to play.

     

    Two notes though... I came across another post that I can no longer find, but it had an additional few steps that I had to do in order to get it to work.

     

    After Step 5 above:

     

    Step 5.1) Under the gear icon where you add it to favorites, you then have to select 'Update Services"

     

    Step 5.2) Turn off bluetooth on your mac and wait for the PS3 Controller's 4 lights to stop flashing

     

    Step 5.3) Turn bluetooth back on, then reconnect the PS3 controller via USB.  The lights on the controller should now be flashing again, but more slowly.

     

    Then follow steps 6 & 7 as listed above.  When I did this, no lights on the controller were on at all, but GamePad Companion recognized the controller and responded to input all the same, so I knew I was good to go.

     

     

     

    I can't take credit for Steps 5.1 - 5.3 above.  I've been looking for the post, but I've been to so many forums looking that it would take me quite some time to find it again.  Nevertheless, this worked like a charm for me.

     

    Downloaded the GamePad companion app and haven't stopped smiling for the last hour.

     

    http://itunes.apple.com/us/app/gamepad-companion/id428799479?mt=12

     

     

    Hope it works for you like it did for me...!!  

     

    Message was edited by: vino17

  • kochmc Calculating status...
    Currently Being Moderated
    Apr 22, 2012 12:33 PM (in response to vino17)

    Much thanks vino17, the extra steps you added solved my issue using that workaround, same model and version of lion, and using a sixaxis ps3 controller.  If you do not, I found that the controller kept "resetting" so to speak every time I disconnected.  I also highly recommend the gamepad companion he is referring to.  Don't be afraid of the negative reviews, once you get it (worth the 7.99), not only can you use it as a mouse (still prefer trackpad for normal stuff) but you can save multiple mapping configurations for gaming, so I have a "Rage" configuration and a "Starcraft" configuration, etc, so I can make it work for any game.  If the game has a "controller" configuration, I ignore it or uncheck it so that it thinks you are using keyboard/mouse combo, I found for instance "Rage" it does not work very well if you say you have a controller, but it is as fluid as a ps3 game if I configure the game as keyboard and mouse and then just use the controller.

     

    FYI, I think you have to have some sort of gamepad driver or mapper to make the controller work at all, I could not make it do anything until I did. 

     

    One note, the controller seems to drain a bit faster, the four lights flash continuously while in use, FYI.

  • IdialisticCrusader Calculating status...

    I have done this exactly, word for word, as fast as I can 10 times now, and yet nothing,  after I go through all the steps exactly,  and in the right order it again asks me for the password,  I have already turned off the ask for password setting, so imagine my chagrine. 

     

    Step 5.2 says wait for red lights to stop flashing,  the red lights stop flashing the moment I unplug the controller in step 1,  why on earth does this controller work for some people and not for others,  what is going on here?

     

    And follow up,  can I use the controller plugged in and forgoe the Blue tooth, I just want to play Deus Ex on my 27" iMac, and I'm used to controllers.

     

    Thanks.

  • kochmc Level 1 Level 1 (0 points)

    Hi IdialisticCrusader,

     

    I do not understand what is going on under the covers, but I have a suspicion.  I have two different sixaxis dualshock controllers, one when I got my ps3, and another a few years later as a gift.  Might be the controllers behave a bit differently as fair as the pairing is concerned.  Not sure which one I paired originally, but this is another way you can try it.  I had accidentally deleted it from the bluetooth preferences menu (thinking I was disconnecting, duh), and then a couple days later I grabbed one and realized what I did.  I tried to hook it up again, but I ran into your problem.  Grr.  So I did it a slightly different way that worked as well.  Go through the steps to the point to where you get through 5.2, and stop.  Instead of hooking it back into the USB port, just wait a while to make sure the controller has really stopped being in pairing mode (I gave it about 3 minutes).  I think once you have it as a favorite it stays in the bluetooth preferences (reason for that step) without having to enter a pairing code.  Instead of hooking it back up with the USB in 5.3, simply power on the controller WITHOUT hooking it up to the USB cable. That worked as well, no more prompting for pairing, you should see it go green but not paired, and the 4 lights will flash on the controller.  Remember to get the GamePad companion so you can actually use it :-)

     

    BTW, I have found different games behave differently with the Gamepad companion but it has worked with everything so far, for instance Starcraft 2 I have to make sure Steam mode is unchecked, but for Rage it has to be checked.  Hope this help you.

  • chancefromal Calculating status...

    i had the same problem today until i found this video on youtube http://www.youtube.com/watch?v=5tEiiveuhRA&feature=related it works for me on gta san andreas now. give it a try

  • johnnyq12 Calculating status...
    Currently Being Moderated
    Aug 18, 2012 12:44 PM (in response to vino17)

    Hi there,

     

    I used to have a Mac mini running Snow Leopard and this solution worked fine. I've since upgraded to Mountain Lion and upped the RAM on a new Mac Mini from 2010. After I enter the code for the first time, the PS3 controller disappears from the Bluetooth list, thus not letting me add it to Favorites or Update Services. It then comes back on the list asking for a new pairing code. So I've basically lost the smal time break I used to get on Snow Leopard to turn the Bluetooth off and keep the controller to the Favorites list. Any ideas?\

     

    Many thanks!

  • kochmc Level 1 Level 1 (0 points)

    Hi,

     

    Ignore the pairing code (step 2).  Then try any of the alternatives listed above. I do not know why but it seems to me there is different behavior depending on your controller or patch level of your OS (in my case I had one controller when the ps3 first came out, then another one years later, but same OS version) and I had to try a different way to get it to work for each one.  I just started experimenting and came up with another way.

     

    Good luck!

  • N.Rots Calculating status...

    Hi,

     

    I'm running the newest OS software.

     

    At this point I've got my PS3 controller Connected and configured. It's been set  as a favorite and the services have been updated. (not that it showed any changes) Also I'm not being prompted anymore for a pairing password. I've achieved this state a couple of time's through the multiple steps described on this forum, and sometimes right on the bat, without following any steps. (I call these the lucky attempts)

     

     

    Allthough they're not that lucky, as every time I've tried and gotten to this state of connection my mac simply does not respond to the controller.
    Which means Gamepad companion gives me "no gamepads found" and bombsquad (a PS3 controller enabled game) doesn't at all respond to it.

     

    At this point I've ran out of things to try. Does anyone have any advise that might help me out?

     

     

    here's a screenshot:

     

    Screen Shot 2012-08-23 at 18.16.35.png

  • meggoddess Calculating status...
    Currently Being Moderated
    Feb 12, 2013 11:39 PM (in response to N.Rots)

    I have the same problem as N.Rots except that mine says "Services: None"

     

    Gamepad Companion shows "No gamepads found" when Bluetooth prefs say the controller is connected.

     

    The controller shows up when plugged in by USB but still doesn't work after configuration.

     

    Controller model is: CECHZC2U

     

    Also, during pairing, it asked me to type in an 8 digit passkey on the controller which of course wasn't possible. I ignored this step and it still showed connected and favorite, but not paired.

     

    Has anyone found a solution to this? I'm running 10.7.5

     

    Thanks in advance!

  • phelgo Calculating status...

    My Sequence that resulted in success:

    1 plug in USB

    2 open blue tooth prefs

    3 add to favorites

    4 update services - should show

    --- paired: no

    --- configured: yes

    --- favorited: yes

    --- connected: no

    5 turn BT off

    6 unplug usb

    7 turn BT on

    8 press PS3 center button

    9 BT prefs should look like N.Rots screen shot now and be working

    10 success

    11 ???

    12 Profit!

  • Nightlife Calculating status...

    Just FYI, these steps worked for me by combining all of the info on this thread and using it with two Sixaxis controllers (first generation):

     

    1) Plug the pad using the usb cable, unplug it.

    2) Don't care about the pairing request

    3) Open Bluetooth Preferences (you have ~15 sec)

    4) Select the ("connected" and "configured" but not "paired") "Playstation3 controller"

    5) Add it to favorites

    6) Under the gear icon where you add it to favorites, you then have to select 'Update Services"

    7) Turn off bluetooth on your mac and wait for the PS3 Controller's 4 lights to stop flashing

    8) Turn bluetooth back on, then wait 3 minutes.

    9) Push the PSX button on the controller, it will connect and you are ready to play.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.