Skip navigation

Where has the 32 bit Audio Unit bridge gone in Lion?

1932 Views 13 Replies Latest reply: Apr 13, 2012 7:58 AM by inactionman RSS
inactionman Calculating status...
Currently Being Moderated
Jul 21, 2011 3:05 AM

Just upgraded to Lion, maybe stupidly. I have Logic 9.1.4 and used to run it in 64 bit mode with all my 32 AU plugins running through the 32 Bit Audio Unit bridge. This has now disappeared and i am back to using Logic in 32 bit mode. So, Apple, where did the bridge go?

MacPro, Mac OS X (10.6.3)
  • Muzicman Level 2 Level 2 (250 points)

    I think this is Apple's way of saying to developers they had better get off the pot and make their plug-ins 64bit, because Apple isn't going to build a 32bit bridge for them anymore.

     

    Odd, that Apple would even allow Logic to run in 32bit mode, since the whole point of Lion is to move their OS into 64bit mode.

     

    Are your plug-ins working as advertised in Logic Pro with 32bit mode?

     

    If so, that's actually pretty good news.

  • SFX Machine Calculating status...

    This developer (SFX Machine Pro, Spectral Machine, Backwards Machine) may not get off the pot and make our plug-ins 64-bit. We've jumped through hoops every time Apple's changes have broken our stuff in the past, but this time the hurdle may be too high. Between the economy, piracy, and the time and money required to reprogram everything, it may simply be more trouble than it's worth.

     

    Our first plug-in was Mac-only, and more than one customer told me they bought a Mac specifically so they could run our software. So it will be with great sadness if our plug-ins become Windows-only, but so be it.

  • Mike Connelly Level 4 Level 4 (1,785 points)

    At this point I won't buy any plugin that doesn't have a 64 bit version.  I know it's work for developers but there is always going to be work required for compatibiliy on any operating system.  And it's not like 64 bit is a surprise, apple has made it obvious things are going that way for years now.

  • DRC Music Calculating status...

    From what I understand... Windows 7 will be the LAST version of a 32 bit OS from Microsoft as well

     

    On the subject of DAW's.... is there one that is NOT 64 bit at this point other than Pro Tools? (check Avid stock for the last 5 years and see how well that has worked for them...)

     

    I agree with Mr. Connelly... So many other developers have already made the switch to 64 bit that I wont even bother with much in the 32 bit world anymore. 64 bit not NEW... its been "coming" for at least 8 years... and both major OS's will be 64 bit ONLY from here on out

  • Mike Connelly Level 4 Level 4 (1,785 points)

    Digital Performer is also still 32 bit, although it's rumored that the update is getting closer.  I don't know on the PC side, there may be others.  But you're right, at some point everything will probably have to be 64 bit, OSX and windows.

  • nepsound Calculating status...

    incase you're still wondering: get info (logic icon) and uncheck the "32bit mode" and you're back to 64-bit with 32-bit bridge. my advice to you dough is get a move on, 32-bit is dead.

  • CCTM Level 6 Level 6 (8,510 points)

    Hi

     

    Running Logic 9.1.6 in 64bit on OSX.7.2 here and the 32bit bridge is both present and correct (well, as correct as it can be ;-) )

     

    Are you still running v9.1.4 of Logic? If so, you probably need to update.

     

     

    CCT

  • Mike Connelly Level 4 Level 4 (1,785 points)
    Currently Being Moderated
    Mar 21, 2012 7:33 AM (in response to CCTM)

    Same here, 32 bit bridge works as well under 10.7 for me as it did for 10.6.  Make sure you're running the latest version of Logic, otherwise something may be broken on your system.

  • Eriksimon Level 6 Level 6 (10,395 points)

    Joining in: same here, bridge present. Take note: the bridge will not appear if no 32-bit plugs are used in project though.

  • NathanS26 Calculating status...

    I had the same problem when updating to Lion. 

     

    I had to close Logic and reopen in 32 bit mode, the rescan the AU's.  All the 32 bit plugins were not selected.

     

    After selecting all the plugins and hitting done I closed Logic and reopned again in 64 bit mode and the 32 bit plugins are there ready to use and when you open one up the bridge opens too

    Hope this helps

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.