Skip navigation

Keyboard stops working in Snow Leopard when using Spaces

113421 Views 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000 RSS
  • swanksalot Calculating status...

    Another data point: I have not had this problem since Lion 10.7.3, so maybe it is fixed, finally.

  • sycer Calculating status...

    I've read in an german forum, that their seems to be a problem with the dock.plist file which seems to be corrupted. So a solution seems to be

     

    http://www.macuser.de/forum/f21/spaces-problem-tastatur-571954/

     

    Translated the solution is:

    Just delete the file com.apple.Dock.plist located in ~/Library/Preferences/ and restart.

     

    But warning: your dock will be reseted (so your have to assembly your icons in the dock again) and also all related configurations you can make in the system preference dock dialog.

  • 7seconds Calculating status...

    I am afraid that deleting the dock.plist file does not help. All it does is resetting your dock and spaces preferences, but the problem with unresponsive keyboard after spaces switching doesn't disappear.

     

    10.6.8

  • the_linguist Calculating status...

    I had similar problems for about 18 months on my first generation Intel iMac until about a year ago - in my case it didn't seem to matter if spaces was on or off. However, I would recommend disabling it. Also the general stability of my machine also improved when I removed virus scanners and any non-essential software on boot up. I know these are general tips but I nearly gave up and bought a Windows PC but not everything works without any problem.

  • sycer Level 1 Level 1 (0 points)

    yes your are right. It's didn't work for me anymore... so I took the workaround:

     

    1.) go to Preference Exposé & Space and disable the shortcut-option for direct changing to another space (normally made with something like CMD+1, CMD+2 ...)

    2.) Download and install the App "HyperSpaces" (free version is enough)

    3.) Go into the Preferences of HyperSpacpes, to "Shortcuts" and bind your desired shortcuts to every spaces.

     

    Done.

     

    I've done this some months ago and had no longer problems with a spaces hangup anymore.

  • SebastianAD Calculating status...

    Interesting enough

     

    I have had the problem with spaces freezing - not accepting keyboard input - with the icon on screen.

     

    BUT:

     

    1) It DOES actually accept the change space keystroke (I use cmd + alt + arrow)

     

    2) If I put my machine to sleep and wake it up again, the problem's gone (for at while)

     

    3) If I change space by cmd-tabbing between my open applications, it won't freeze.

     

    4) THe freezes just began for my within the last couple of weeks - and I've been using 10.6 for a really long time ,-) Might be some other softwre interfering I guess.

     

    I have not yet envestigated, if it will freeze, if I change space using keyboard shortcut for going to a specifik space (using cmd alt number).

     

    In a few times, it unfroze itself after  lot of cmd alt arrow-changing.

  • SebastianAD Level 1 Level 1 (0 points)

    Update

     

    I've changed the keystroke in spaces to something else, still resulting in hangs -(

     

    Anyone knows if it's possible to get a list of current keybindings?    

  • kwxr2000 Level 1 Level 1 (0 points)

    I've been having this problem.  Switching Users seems to reset it for me.

     

    10.6.8

1 ... 16 17 18 19 20 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.