Skip navigation

I have ipod classic (about 3 yrs old) and when recharging, everything on it is gone.  When I tried copying the saved/backup items, itunes and ipod were stuck...doing nothing/frozen.  Help!

253 Views 2 Replies Latest reply: Mar 24, 2012 6:55 AM by Bilbo_cheshire RSS
Meili1 Calculating status...
Currently Being Moderated
Mar 18, 2012 11:55 PM

I have an ipod classic which I had bought about 3 years ago.  I plugged it into my computer this past weekend to charge and it showed me that there were nothing on it...no music, no movies, no photos, nada.  I had updated the program on my computer and when I tried to reload all the stuff that I had saved, it locks up my itunes and ipod.  It doesn't do anything!  I don't know what is going on....Help!?  Anyone!?  Any clues? 

iPod classic, Windows Vista

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.