Skip navigation

How to fix iTunes 10.6 iPhone's USB Personal Hotspot problem

48533 Views 47 Replies Latest reply: Dec 13, 2013 2:36 PM by jamesfrompleasanton RSS
  • Frederic Jacobs Calculating status...

    In what package of the installation package is the AppleUSBEthernetHost.kext ?

  • Axel Luttgens Calculating status...

    In AppleMobileDeviceSupport.pkg

     

    Axel

  • Frederic Jacobs Level 1 Level 1 (0 points)

    Could you describe how to get it out of the package ? I tried "pkgutil -- expand" but apprently there's no AppleUSBEthernetHost.kext in there.

  • David Empson Level 1 Level 1 (90 points)

    Thanks to Axel's hint, I've solved it. I now have USB tethering working with iTunes 10.6 and iOS 5.1, when it wasn't working for me earlier.

     

    There seems to be a problem with the iTunes 10.6 installer: it is not correctly installing AppleUSBEthernetHost.kext.

     

    I got tethering working by moving /System/Library/Extensions/AppleUSBEthernetHost.kext to trash, running the iTunes 10.6 installer again, then restarting to ensure the old extension wasn't still loaded.

     

    I had originally installed iTunes 10.6 using the manually downloaded installer disk image, and when I had the problem, my AppleUSBEthernetHost.kext was version 2.3.0 with a file size of 60892 bytes and only had i386 code (as described by Alex based on what he got from Software Update). My MacBook Pro is running with a 32-bit kernel under Snow Leopard, so the 32-bit kernel extension shouldn't have been a problem.

     

    After deleting the kext and running the installer again, I now have a Universal kext which is version 2.3.0 and has a file size of 189645 bytes. This one works.

     

    The mystery is where the smaller version of the kext is coming from. Digging inside it, the bad Contents/MacOS/AppleUSBEthernetHost file within the kext (the executable) is dated 3 Feb, whereas the good one is dated 21 Jan. I can't see any such file dated 3 Feb in the iTunes 10.6 installer package, and the same file in the iTunes 10.5.3 installer package is dated 15 Nov 2011.

  • Frederic Jacobs Level 1 Level 1 (0 points)

    Yeah.

     

    This worked for me too.

     

    Conclusion :

     

    It's not an iOS 5.1 related issue. Apple probably changed the AppleUSBEthernetHost.kext to support the iPad tethering. It is required to have iTunes 10.6 to tether iOS 5.1 devices.

    If you're experiencing trouble with the tethering. Delete /System/Library/Extensions/AppleUSBEthernetHost.kext and run the installer of iTunes 10.6 again. Restart and that should fix it.

     

    Thanks to everyone who contributed to this discussion.

  • Axel Luttgens Level 2 Level 2 (180 points)

    Something like this, assuming the disk image with the installer is already mounted:

     

    $ cd ~/Desktop/

    $ pkgutil --expand /Volumes/iTunes\ 10.6/Install\ iTunes.pkg itunes

    $ ditto -x itunes/AppleMobileDeviceSupport.pkg/Payload amds

     

    The extension is now available somewhere inside folder amds (still needs to be given correct persmissions).

     

    HTH,

    Axel

  • maclucassen Calculating status...

    @Frederic

    you're right - it's not an iOS issue it's an iTunes 10.6 installer issue - why it's working with my Apple 3GS (iOS 5.0.1) I don't know and it doesn't matter anymore.

     

    Thanks to everyone who contributed to this discussion, as well.

    Deleting the kext, rebooting and reinstalling using the full installer worked for me, too 

     

    @all - have a nice weekend & thanks for the quick and skilled support

    Markus

  • david.pathfinder Calculating status...

    Thanks. This solution worked for me too.

  • David Empson Level 1 Level 1 (90 points)

    Further information for those who are still following this thread: I have now worked out the rest of the mystery.

     

    The problem is not with the iTunes 10.6 installer.

     

    It turns out that I happened to install iTunes 10.6 and iPhone Configuration Utility 3.5 at the same time, with iTunes being installed first. Both of these installers include AppleUSBEthernetHost.kext, and the one included with iTunes Configuration Utility does not work properly.

     

    Therefore, if you have this problem with USB tethering (personal hotspot) not working, the reason is that you have installed iPhone Configuration Utility. The solution is the same as my earlier instructions: move /System/Library/Extensions/AppleUSBEthernetHost.kext to trash, run the iTunes 10.6 installer again, then restart to ensure the old extension isn't still loaded. (After you start up again, you can empty trash.)

     

    The driver has to be deleted manually because both iTunes 10.6 and iPhone Configuration Utility 3.5 install a nominal version 2.3.0 of this driver, with the iPhone Configuration Utility one having a higher internal build number, and the iTunes installer skips installing the driver if it finds the same or a newer version installed.

     

    What we need now is to get Apple to fix the driver included with iPhone Configuration Utility so that this problem doesn't bite too many other people.

     

    maclucassen - can you please update your bug report accordingly?

     

    In addition, there appears to be no problem with USB tethering between iOS 5.1 and older versions of the kext (I succeeded in getting tethering working with kext version 2.2.0, which came with iTunes 10.5.3). My previous test on another computer running iTunes 10.5.3 must have failed for some other reason.

  • ewaegeman Calculating status...

    You're exactly right David, This is what I did too ... so now I deleted the AppleUSBEthernetHost.kext , reinstalled itunes and it works .... I stay away from configuration utility now .... (I have deleted it)

    Thanks.

    Erik

  • nicky11 Calculating status...

    Thanks, this problem has been happened long ago before Lion. Now this has been solved for me. Thanks.

  • Reclusive46 Level 1 Level 1 (5 points)

    This worked for me. Thanks guys. Been trying to get this fixed for ages.

  • Jclib Calculating status...

    Had the same problem. Lost the ability to connect to my iPhone hotspot over USB after the 10.6 iTunes update & couldn't re-add the iPhone as a network service. Seems like a bad AppleUSBEthernetHost.kext was the culprit. It's working again. Thanks for the detail.

  • heenfeen Calculating status...

    Hi guys,

     

    I have this poblem with both my Mac and on my desktop with Windows 7.  The above way to solve the problem worked for my mac, but I have no idea how to do it on Windows 7 as kext files do not exist on Windows 7.  Anyone got any suggestions on how to solve this for Windows 7 as I dont have a wireless connection in my desktop and connecting through USB is the only way I can use the internet on it at home.

     

    Any help would be appreciated!

     

    Cheers

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.