Skip navigation

Time Machine could not complete the backup.

22572 Views 45 Replies Latest reply: Jan 17, 2014 11:34 AM by TinMass RSS
1 2 3 4 Previous Next
G4Dualie (Michael) Calculating status...
Currently Being Moderated
Mar 24, 2012 3:48 PM

Files can’t be copied onto the backup disk because it appears to be read-only.

 

You may need to repair or reformat the disk using Disk Utility. If the disk can’t be repaired, you must use a different disk for backups. Open Time Machine preferences to select a different backup disk.

 

Why is Time Machine insisting my drive is Read-only, when in fact it isn't?
This is becoming a routine occurrence. What's troubling is the problem is easy enough to resolve by simply unmounting/mounting the Time Machine drive and selecting Back Up Now from the menu and it purrs like a kitten.

 

After performing the step outlined above, my latest Time Machine backup is tucked neatly away and everything is fine once more.

24-inch iMac 2.8GHz (early 2007), Mac OS X (10.7.2)
  • Linc Davis Level 10 Level 10 (107,630 points)

    What kind of drive is it?

  • Linc Davis Level 10 Level 10 (107,630 points)

    Run Repair Disk on the backup volume in Disk Utility, if you haven't already done so. It will take a long time, maybe hours.

  • Pondini Level 8 Level 8 (38,710 points)

    G4Dualie (Michael) wrote:

    . . .

    I created this comment to add one more voice to the discussion regarding Time Machines inability to recognize whether a drive is read/writeable.

    Time Machine may have set it to read-only because it found a problem. 

     

    Sounds like there's a problem with the drive, perhaps beginning to fail.    If Disk Utility fixes it, but later on it turns up suspect.

  • Pondini Level 8 Level 8 (38,710 points)

    You may see it in the system.log.

     

    There are some similar threads in this forum.

     

    Or, you could just try what two experienced users have suggested.

  • Linc Davis Level 10 Level 10 (107,630 points)

    Perhaps ZFS is the answer to my problem?

     

    Why didn't I think of that? Port ZFS to the Mac, then reverse-engineer Time Machine to work with it. Problem solved. Be sure to let us know when you're ready to release your code.

     

    While we're waiting, others finding this discussion might want to peruse the Apple documentation that pertains to the issue:

     

    If Time Machine is unable to complete a backup, make note of any alert message that appears. You can also open System Preferences and in Time Machine preferences click the red "i" icon for more information.

     

    Messages you may see after clicking the red "i" include:

     

    "The backup volume is read only."

    Attempt to repair your Time Machine's backup:

    1. Choose System Preferences from the Apple menu.
    2. From the View menu, choose Time Machine.
    3. Move the slider bar to "Off" to disable Time Machine backups.
    4. Open Disk Utility located in/Applications/Utilities

    1. Mount your external hard drive.
    2. In Disk Utility, locate your external backup drive. Your backup drive should mount in the Disk Utility sidebar when attached to your Mac.
    3. Select your external backup drive.
    4. Click Repair.

    Time Machine: Troubleshooting backup issues

     

    The fact is that under some circumstances, diskarbitrationd(8) can update the 'rw' (read-write) mountflag of an HFS volume to 'ro' (read-only) if the filesystem fails an assertion. That's not Time Machine; it's the Disk Arbitration framework. Such failures occur because the device hosting the volume has thrown an error. If it happens once, the correct response is to repair the volume directory, assuming it needs repair and can be repaired. If it happens repeatedly, the correct response is to suspect a hardware fault and test with another drive.

  • Pondini Level 8 Level 8 (38,710 points)

    G4Dualie (Michael) wrote:

    . . .

    TM isn't resetting my drive to read-only, you made that up.

    No.  I don't know (and didn't say) that's necessarily what's happened in this case, but that it does happen, and might well be what's causing the problem here.   Your system.log may clarify what's going on.

     

    But, I want help from the person a Level 7 goes to, Pondini. Nothing personal, nor am I challenging you or your knowledge but quite frankly your TM advice is fundamentally basic common Apple-sense.

    Then you have some choices:

     

    Call AppleCare.  See the blue box in  Reporting a Problem to Apple.

     

    Use Apple's BugReporter.  See the green box in Reporting a Problem to Apple.

     

    Get a Developer's membership ($99/year), so you can download and test beta software, and file bug reports.  That would let you test "point" upgrades to Lion, and/or Mountain Lion.

  • Pondini Level 8 Level 8 (38,710 points)

    G4Dualie (Michael) wrote:

    . . .

    You said it MAY have happened, followed by your proclamation that perhaps the drive is about to fail and you based that on what I wrote! You didn't ask for logs, or press for further information, like you have done with evey other thread in this forum.

    Correct.  I recommended starting with Repair Disk, as Linc did, because that usually fixes it, and you'd answered that recommendation with the rather snippy "It's easier to unmount and mount the drive."  If you'd made it clear you'd already done that, with a clean result, I would have gone further.

     

    I'm done here.

    As you wish.  Be sure to post back when you solve it.

  • Steve Johgart Calculating status...
    Currently Being Moderated
    Sep 1, 2012 7:57 PM (in response to Pondini)

    Yes, I know this is a very old thread, but I wanted to reply with my experience with the advice in the preceding question. I used Repair Disk, which didn't solve the problem. I then tried unmounting and remounting the drive, which did solve the problem. For a week or two - then the drive is again declared read-only until I unmount and remount it. While still in what TM claims is "read-only" mode, "Get Info" shows the disk read and write for me and for admin, but read-only for everyone; it will not allow me to unlock and change the permissions. This is under Mountain Lion - I don't recall it happening pre-Mountain Lion.

     

    Mountain Lion seems in general to have done something weird to the disk directories, since after upgrading to ML, SuperDuper! was so completely fouled up about which disks were mounted and which weren't, and which disks it should be using, that I had to fully delete (using MacCleanse) and reinstall SD - now it works just fine. Hopefully that will continue, and not periodically get fouled again up like TM seems to do. Of course, I do realize that the SD problem may be totally unrelated to the TM problem (possibly SD plist or something got corrupted in the Mountain Lion update), but the symptoms have enough in common to be somewhat suspicious.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.