1 2 Previous Next 16 Replies Latest reply: May 5, 2014 2:46 PM by phygal Go to original post
  • 15. Re: Proxy authentication isn't working in 4.3.2
    mkolodziej Level 1 Level 1 (0 points)

    I also have this issue. This happens on my iPhone 4 now with iOS 5.1. I insalled a profile on it using iPhone configuration utility, where I set up my corporate WiFi network and proxy server, including proxy user and password. It keeps asking for user/password and it does it several times. This also repeats every few hours, even if I don't leave the WiFi range.

     

    Interestingly I have the same issue when I use iTunes on my Win XP laptop, with a wired LAN connection, but the same proxy server. There it also tells me my credentials are incorrect (even though I'm sure they are) and it finally always works, after I type it 4-5 times.

  • 16. Re: Proxy authentication isn't working in 4.3.2
    phygal Level 1 Level 1 (0 points)

    Heya,

     

    If the iPad OS has a keychain utility then you can try this solution. I had the exact same problem with my MB Air and it solved it. The original post is here https://discussions.apple.com/message/23848959#23848959. Hope it works.

     

     

    This post provides the correct solution.


    Usually a proxy authentication dialog allows the user the option to 'allow once' or 'always' etc, and to save the proxy login details to the user's login keychain.


    But under both 10.8 and in particular 10.9 whenever a proxy is in use, the user gets bombarded with multiple recurrent proxy authentication dialogs without any save options and without any identifier.


    Using the terminal command nettop, I discovered that the offending dialogs come from system processes, most notably syncdefaultsd.  (How to do this at the end of the post)


    The problem is that syncdefaultsd is not keychain aware. It needs access to the user's proxy settings at regular intervals, but can't get them from the user's login keychain. It's proxy request dialog does not have the option to save the details to the user's keychain, and worse still does not identify syncdefaultsd as the requesting process. Even if you open your login keychain to allow any application access to your proxy, syncdefaultsd will still keep asking for your proxy details.


    The solution is to ensure that you have working proxy settings saved in the *system* keychain, not just your personal login keychain.


    So when you next get one of these dialogs:


    1. Note the server name that is requesting authentication, the port (usually 8080) and if it is an http or https request. Typically it will be something in the form https://someproxyserver.someorganization.com:8080


    2. See if you already have an entry for that server in your login keychain. If not, make one manually, (being sure to enter the whole thing as per the example above with the :8080 at the end). Typically that there needs to be two separate keychain entries per proxy server, one for http and a second for https, though syncdefaultsd only uses https.


    3. Once you have login keychain entries for the proxy server, double-click them and ensure that under Access all applications are allowed, and that your user name is saved.


    4. Now for the fun bit. Option-drag and drop these entries into your system keychain. Click on the system keychain, and confirm that they are there, and that all the settings are exactly right.


    For good measure, do a shift-restart then a normal restart.


    You should now get no more annoying dialogs for that particular proxy server. If your proxy server has more than one alias, or if you have several, then whenever you get a new unidentified dialog, repeat the above.


    I discovered it using the terminal command nettop, typing into the terminal:


    nettop -m tcp


    This lists all active network processes. If you quit all apps you should still see quite a few network processes. If you see syncdefaultsd, wait for it to go away, or kill it via the Activity Monitor. If you haven't done the fix as above, and you open Safari, you'll see syncdefaultsd open shortly after Safari, and the annoying dialog immediately appears. After the fix is implemented, the dialogs don't appear when syncdefaultsd tries to start up.


    Hope this helps someone, and that Apple fixes it in 10.9.1


    Cheers


    Chris.

1 2 Previous Next