1 2 3 Previous Next 101 Replies Latest reply: May 6, 2014 8:02 AM by alfredo1
Beardy man Level 1 Level 1 (35 points)

I've been using iRig/Garageband on an iPad 2 for almost a year now and it works well enough for my needs.

 

I've recently got an iPad3 but the noise levels are way over what I get with the iPad2. Any form of distortion pre-set seems to generate a massive amount of background noise. The only way I can lessen it is to be brutal with the noise gate to the point wher ethe sustain/delay level is hacked back to almost nothing.

 

I think it's a Garageband problem because when I use the Amplitude software I get no appreciable noise at all.

 

Anyone else finding this? Perhaps I should try re-installing Garageband on the iPad3?

 

Any suggestions, similar experiences?

 

(I know the iRig isn't exactly 'state of the art' but I'm not comparing it to, say, Apogee Jam. I'm comparing Gargeband on the iPad2 with Garageband on the iPad3 using iRig)


Mac OS X (10.6.8)
  • 1. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    TheReen Level 1 Level 1 (0 points)

    im having this problem with the ipad 2. i think it has something to do with the update because i didnt have the problem before i updated. its pretty annoying because i used to have an awesome clear tone, and now i have to do the same thing youre doing with the whole noise gate thing, which *****. i think apple needs to address this. 

  • 2. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Beardy man Level 1 Level 1 (35 points)

    Not so sure. I've been able to play with the iPad2 and the 3 side by side (both with the latest version of GB).

    My iPad 3 is a lot worse than my 2 but, I agree, this latest build of GB is noiser than the old version.

     

    I can live with the noise on the iPad2 but if I only had the 3 I'd be very unhappy. Across the whole experience, one issue with GB (which may be software related) isn't enough to go through the hassle of returning it so I'll use the iPad 2 for GB and hope the next upgrade fixes it. I won't expect it though as there doesn't seem to enough people who have an issue. Perhaps I'll post something on the iRig site.

     

    I'm almost tempted to spring for an Apogee connector but it's more than I want to pay and there's no guarantee that would be any better. Weird that the Amplitude software is 'clean' though - suggests a GB prob to me.

     

    Thanks for your feedback TheReen - appreciated.

  • 3. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Peterco Level 1 Level 1 (0 points)

    Having the same problem - just got an iPad3 & the noise is unacceptable - is anyone working on this??

  • 4. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Beardy man Level 1 Level 1 (35 points)

    I don't think so. I've just downloaded the latest GB update and tried it out last night. Just as bad.

     

    For anyone else out there looking at this problem (GB, iRig and guitar) try using virtually any combination of amp with a Fuzz stomp box. The noise (over and above the expected effect) is overwhelming, feedback etc even without touching the strings of the guitar. This simply wasn't the case on the original GB for iPad with an iPad 2.

     

    The app store is now prompting me to upgrade my version of GB on my (wife's) iPad 2. Not going to risk that!

     

    As I've said before, I think this is such a niche problem I can't see anything being done about it.

     

    Would love to hear about anyone who's using an iPad 3, GB, guitar and an Apogee connector.

  • 5. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    mhsmitty Level 1 Level 1 (5 points)

    I have the first iPad and the new iPad (3).  The first iPad has GarageBand 1.2 which I use with iRig and have no issues.  The new iPad has GarageBand 1.2.1 and I used it with iRig last night for the first time since it arrived. The unwanted noise on the new iPad with 1.2.1 build is so poor it's unusable.  If I use Amplitude on the new iPad it sounds great.

     

    I called Apple last night and spend almost an hour waiting and talking to the support people.  They suggested I contact IK (iRig makers) and tell them to fix the software patch for GarageBand.  They had no other solution for the problem. I don't think it's an iRig problem. Out of desperation I sent IK an email to their support personnel.

     

    I've frustrated since part of the reason I bought the iPads were to use GarageBand to record guitar tracks and mix music when I'm away from home. Now I'm afraid to update my older iPad.

     

    I hope someone fixes the software soon. 

  • 6. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Beardy man Level 1 Level 1 (35 points)

    You're in the same situation as me! Handing you off to IK isn't what the Apple experience should be all about - if I'd wanted one supplier blaming another and feeling like I'm caught in the middle, I'd have gone to Android

     

    Seriously, I'm also afraid to update my iPad 2 GarageBand. As you say, the iPad3 works fine with Amplitude so it's not an IK problem, its only the GarageBand current release that's poor.

     

    Unfortunately I think we're such a small audience that Apple won't do anything about this one  - unless IK put some pressure on - after all, it makes the iRig almost redundant for anyone with a new setup. Hopefully your IK e-mail may get them to give Apple a kick?

  • 7. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    TheReen Level 1 Level 1 (0 points)

    What I've been doing lately(I have the same noise problem but with iPad 2, only since the update), is use iCloud and load songs onto there and record guitars on my iPods GarageBand. It's kind of a nuisance to switch around but I notice there's no noise on the iPod at all. Crystal clear sound. So I do all the drums and bass and electronic/synth/strings on the iPad, then do the guitars on the iPod, and back to iPad for vocals.  It has to be an iPad problem.  Like I said, irig is fine with iPod, was with my iPad 2 until the software update, so Apple's got to find a fix here.

  • 8. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Jeremiasz Level 1 Level 1 (0 points)

    The same problem here. IRig is working fine with Amplitube and a couple other apps but not with GB. Waiting for solution now...

  • 9. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Beardy man Level 1 Level 1 (35 points)

    I don't think there will be a solution as such. Maybe the next time GB gets an update a fix may be included but that's about the best we can hope for.

     

    I had thought that IK would put pressure on Apple (or just ask nicely) to fix this as it blows a bit of a hole in the iRig - I certainly wouldn't buy one under current circumstances - and that's nothing against the iRig except that I consider the iPad/GB to be 'incompatible' with it as it stands.

     

    I'm going to look into the possibility of reverting back to a previous version of GB but I think it might be a messy process.

  • 10. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    cbarrere Level 1 Level 1 (5 points)

    I've got the same issue here.  Newest version of GarageBand and iPad 3.  Total bummer.

     

    I can't add much, but I did buy an Apogee Jam and I can verify things work flawlessly there..  Better tone than the iRig too (but twice the price) :|

  • 11. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Beardy man Level 1 Level 1 (35 points)

    Thanks for the info on the Apogee Jam - I was hoping someone could confirm that it was a viable alternative.

    I don't really want to buy one as it would mean the money I spent on  the iRig is wasted but I can't see Apple doing anything here and iRig are in their hands I suspect (iRig works okay on iPad2 with the previous version of GarageBand - if you have this combo, DON"T UPGRADE GARAGEBAND on your iPad!!)

  • 12. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Hillzie Level 1 Level 1 (0 points)

    I'm having just the same noise issue with my iPad 3 + iRig + Garageband combination. The noise doesn't exist when I play on Amplitube. Also when using iRig and Garageband on my iPhone there's no such noise. I was quite frustrated about that - until last night I found by an accident a kind of first aid "solution":

     

    When I have Garageband running and play guitar through iRig, I double tap on the home button (or swipe up the screen with four fingers) to reveal the multitasking bar. As the multitasking bar comes visible the most annoying hum is away. Also I noticed that I have to quit some of the applications running background to avoid latency. This way I can have as "noiseless" guitar playing experience as I have with my iPhone. Not a perfect solution but works for my purposes - now I can record guitar without that overwhelming hum.

     

    So supposedly this has to be a Garageband problem.... waiting for Apple to fix it soon.

  • 13. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    Beardy man Level 1 Level 1 (35 points)

    Good find Hillzie!

    Works for me also. Okay, so it limits the functionality of the app a bit (and it's really irritating to hear how bad the noise is when you go back into 'full screen') but it will have to do until some bright Apple engineer works out what's causing the problem!

     

    As you say, I think this nails it as a GB problem rather than an iPad2 or 3 issue.

     

    Now we have a reproducible effect/solution I think it's time for another bug report.

    I'm not going to flag this as solved until we have a 'real' solution.

  • 14. Re: Anyone else having "Noise" problems with iRig/Garageband/iPad "3"?
    mikeb39a Level 1 Level 1 (0 points)

    I also did what Hillzie said and it made a bit of difference. I thing that a lot of the problems

    are with devices that connect to the headphone rather than the docking port. It's like analog

    thru headphone, but the Apogee and others that connect via docking port are true analog to

    digital converters.

1 2 3 Previous Next