6 Replies Latest reply: Apr 13, 2012 8:59 PM by b noir
PC Utah Level 1 Level 1 (0 points)

When I try to play some of my recent video purchases, which have worked until recently, I get an error stating This movie requires QuickTime, which is not supported by this version of iTunes. Nor will they play on my apple TV. Any ideas?