Skip navigation

I can't insert a disk.

699 Views 7 Replies Latest reply: Jan 14, 2013 8:17 PM by M-Ego RSS
tthone Calculating status...
Currently Being Moderated
Mar 30, 2012 10:25 AM

I am trying to insert a disk. When I put it in, it usually just nicely goes in. Now, there seems to be something blocking it as I push it in. There isn't anything in there that I know of. I've tried ejecting and even tried looking under disk utilities. Any help would be great!

Thanks

iMac
  • MGW Level 7 Level 7 (26,940 points)
    Currently Being Moderated
    Mar 30, 2012 10:57 AM (in response to tthone)

    Try running Apple Hardware Test, which will be on one of your install discs, to see if anything is wrong with your optical drive.

     

    Let us know what you find, please.

     

     

     

     

    excellentsig2.png

  • MGW Level 7 Level 7 (26,940 points)
    Currently Being Moderated
    Mar 31, 2012 7:16 AM (in response to tthone)

    Use Target Disk Mode

     

     

     

     

    excellentsig2.png

  • Allan Jones Level 7 Level 7 (29,570 points)
    Currently Being Moderated
    Mar 31, 2012 7:17 AM (in response to tthone)

    You may have an iMac newer than the pre-2006 models this forum covers. Apparently the very recent models have an optical drive with a "safety bar" that blocks insertion of any disk if the drive fails.

     

    If the iMac is fairly new and you have warranty coverage, you need to get to an Apple Store or AASP for service.

     

    As this symptom raises the question of which of many iMac models you have, please do "About this Mac" from your Apple menu and report what the resulting window says about your processor type.

     

    If that info says the processor is Intel, you have a much newer iMac that gets a  separate forum here:

     

    iMac (Intel)

     

    If the processor type is G3, G4, or G5, you are in the proper forum. However, then we'll need that detail to offer further help.

  • stwshaw Calculating status...
    Currently Being Moderated
    May 19, 2012 2:30 AM (in response to tthone)

    Hi, I had the same problem and just found (in a different forum) the easy solution.

     

    Open Terminal (in Utilities) and type the words drutil eject

     

    Apple told me they would need the computer for 4 days to fix, this fixed it in 10 seconds! Hope it workds for you too!

  • Allan Jones Level 7 Level 7 (29,570 points)
    Currently Being Moderated
    May 19, 2012 2:30 PM (in response to tthone)

    I think you are in wrong forum. That system points to an intel iMac. They have a bar that blocks the sllot when the optical drive fails. It is likely something that will require professional help.

  • M-Ego Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 14, 2013 8:17 PM (in response to tthone)

         1. Go into Spotlight from the top of your MacBook on the menue bar.

         2. And search for "CDs & DVDs" (It's also in the System Preferences)

    Click on it and a small CDs & DVDs window will pop up with options of what happens when you insert a disk into the drive

         3. By then, try inserting a disk in (while that window is open. This kinda wakes up your drive to accept the disk). It should accept it.

         4. If nothing happens, then manually open the program that should be opening when you insert the disk or go to Finder (Eg. if it's an audio disk, then open iTunes)

         5. If opening the program still does not activate the drive to start spinning the disk, then close the programs and windows you opened, and repeat step 1-4 and the disk should be spinning and automatically opening the proper program.

     

     

    Hope that helps!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.