Skip navigation

TOC disappeared

669 Views 10 Replies Latest reply: Mar 30, 2012 8:48 PM by jJHay RSS
limtc Level 1 Level 1 (65 points)
Currently Being Moderated
Mar 23, 2012 7:30 PM

Something happened that I have not seen before. To build a new book, I duplicate an old book with similar structure, then remove all chapters.

 

Once I recreate the chapters, found that TOC is not there when previewed!

 

This is what is shown in iBooks Author:

 

TOC1.png

 

But this is what shown on my iPad 3 when previewed:

 

TOC2.PNG

 

I am using the latest iBooks and iBooks Author.

 

Any idea? Thanks!

iBooks Author, Mac OS X (10.7.2)
  • jJHay Calculating status...
    Currently Being Moderated
    Mar 30, 2012 10:47 AM (in response to limtc)

    I'm having the same problem! Except in iPad 2! I've tried everything I can think of to get it back. It was working at one point...the only thing I can associate with when it disappeared was I dragged and dropped an image in to the placeholder on the TOC master. When I realized this image showed up on all pages, I removed it, and found a way to put different images in on different chapters. But now the content doesn't show up on any of the TOC pages in preview. Short of starting a whole new book and pasting the entire book content in again, I don't know what to do.

  • jJHay Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 30, 2012 8:09 PM (in response to limtc)

    Thanks limtc!

    That did it! Phew.

    I had not known about killing apps until now.

    It seems it is a memory issue.

    I was really getting baffled when the problem resurfaced after trying to preview other iba files that I had not touched in a long time.

    Not obvious. It would certainly not be obvious to a buyer of the book.

    I guess I really should reduce the size of the book.

    Nice to finally have an answer - after two days of pulling my hair out!

    Thanks again.

  • jJHay Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 30, 2012 8:36 PM (in response to limtc)

    That's funny, that's just what I tried to do, as I was so happy to have it resolved...but then found out you can only do that if you are the creator of the issue. The options for "This solved my question" and "This helped me" don't appear if you are just replying to the thread.

    see: https://discussions.apple.com/thread/3818509?start=0&tstart=0

    I would think it would be useful for everyone checking the thread.

    Anyway, you can do it!

    And then perhaps we can save others from days of hair-pulling.

  • jJHay Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 30, 2012 8:38 PM (in response to limtc)

    yeah, wacky system!

    well, thank you

    I would give you the points if I could.

  • jJHay Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 30, 2012 8:48 PM (in response to limtc)

    Indeed! I will keep an eye out.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.