1 2 Previous Next 15 Replies Latest reply: Jul 27, 2013 12:47 PM by jukka_c
U-96 Level 1 Level 1 (20 points)

Am I missing a solution posted somewhere? Has this seriously gone on and on this long without a fix or have I just missed it?

 

I cannot take it anymore. I've dealt with it for a long time now and through many OS "updates" from Apple, which are nothing more than "make iTunes more advanced so people spend money in the iTunes store" updates.

 

READ CAREFULLY: IT DOES NOT MATTER WHAT SURFACE THE MOUSE IS ON. So just save your keystrokes. All I would like to know is if anyone has a remedy for this horribly irritating bug. We are trying to design on these machines, after all. Kind of hard to draw or edit a path, or layout, do intricate retouching, OR JUST ANYTHING when the mouse cursor just flies around randomly.


Mac Pro, Mac OS X (10.7.3), 2 x 2.66 GHz (12-core), 32 GB RAM
  • 1. Re: Jumping mouse has to stop!
    Linc Davis Level 10 Level 10 (117,680 points)

    Has this seriously gone on and on this long without a fix or have I just missed it?

     

    What you've missed is the fact that just because you're having a problem, that doesn't mean everyone else has it. They don't. Something is wrong with your setup.

     

    You've also missed the fact that taking an antagonistic attitude while asking for help from strangers who don't owe you anything is the wrong approach.

     

    What kind of mouse are you using, and is this happening with more than one machine?

  • 2. Re: Jumping mouse has to stop!
    Shootist007 Level 6 Level 6 (16,640 points)

    I don't have these mouse problems with any of the Logitech wireless mice I have or the MS wired mice I have connected to my late 2011 Macbook Pro.

     

    Since you are on a Mac Pro it isn't the battery causing the trackpad to do funny things. So the only other option is the mouse itself, the wire from the mouse to the computers USB port, the USB reciever for a wireless mouse or the wireless mouse itself, the bluetooth system in your computer or bluetooth mouse (if Mac Pro's use BT and you have a BT mouse, the computer USB port or an internal hardware problem, IE Logic board.

     

    Does this happen with every mouse you have tried? What mice are you using? Is it wired or wireless or wireless bluetooth.

     

     

    Sorry If I've waisted your time and keystrokes. But until you run all types of tests with different mice and the way they connect to the computer there is little anyone can do to help you.

    If this was a wide spread problem there would be multiple threads about it and all of those threads would be pages long. So since there isn't multiple threads about this your problem is specific to your computer and the mice you are using.

  • 3. Re: Jumping mouse has to stop!
    U-96 Level 1 Level 1 (20 points)

    All mice are Apple mice; wireless and USB. Yes, USB ports have been changed, brand new mice have been used, the sensor has been blown clean time and time again, different surfaces have been tried, different color surfaces have been tried. Nothing helps, nothing matters, there's no pattern, no rhyme or reason to it.

     

    At this point I don't even care if there's a solution from Apple or some script or if I have to wear a banana on my head every Tuesday at 4:00 to get to stop.

    If someone can just please, please, please tell me a mouse that won't do this, that's all I really care about at this point. I'll go buy as many as we need at whatever cost to rid us of this.

  • 4. Re: Jumping mouse has to stop!
    Shootist007 Level 6 Level 6 (16,640 points)

    Well get a generic Wired mouse and try it in different USB ports. I suggest a wired Microsoft mouse, any model will do.

     

    I have never used any of the wired or wireless Apple mice, over priced and lacking in buttons and features, so I would suspect it is the mouse itself.

     

    There is a rhyme and or reason. All mice are Apple.

  • 5. Re: Jumping mouse has to stop!
    U-96 Level 1 Level 1 (20 points)

    Linc Davis wrote:

     

    Has this seriously gone on and on this long without a fix or have I just missed it?

     

    What you've missed is the fact that just because you're having a problem, that doesn't mean everyone else has it. They don't. Something is wrong with your setup.

     

    You've also missed the fact that taking an antagonistic attitude while asking for help from strangers who don't owe you anything is the wrong approach.

     

    What kind of mouse are you using, and is this happening with more than one machine?

    And just because you've not heard of it doesn't mean it's not a common issue. Or did you just feel compelled to act as the de facto Apple forum sentinel?

     

    The forums are full of this complaint as well as any number of Mac sites.

  • 6. Re: Jumping mouse has to stop!
    Shootist007 Level 6 Level 6 (16,640 points)

    U-96 wrote:

     

    And just because you've not heard of it doesn't mean it's not a common issue. Or did you just feel compelled to act as the de facto Apple forum sentinel?

     

    The forums are full of this complaint as well as any number of Mac sites.

    I have not seen report of this type of thing. Although I am fairly new to Mac but go to many Mac forums on a regular basis and have never seen any recent posts on this subject. The only time I see post about jumping, moving, random clicking of the cursor is on older Mac notebooks where the battery has swelled and put pressure on the trackpad.

  • 7. Re: Jumping mouse has to stop!
    Daniel Ebeck Level 4 Level 4 (1,650 points)

    Does it occur in all user accounts, or just yours?

    Specifically, which apple mice are you using; Magic, standard, hockeypuck or clear unibody?

    Have you deleted the com.apple.driver.AppleHIDMouse.plist?

    Are the mice plugged directly into the Mac, or are you using a keyboard or monitor hub?

     

    And Linc is quite right, stop acting like a prat.

  • 8. Re: Jumping mouse has to stop!
    Sam Beaver Level 1 Level 1 (120 points)

    I frequently have the same issues with the magic mouse in lion.

    make sure magic preferences are not turned on, or just uninstall that.

    Note also, that the mouse battery indicator is all wonky with lion. even if you have fresh batteries that show up as full, rebooting into an old OS may show a different life indicator.

    might try going to very basic prefs in the mouse pref panes.

    the human interface with the latest OS is quite terrible. I tried swapping into a trackpad, wacom, and a cintiq touch screen, no luck on my side making it as good as it used to be.

  • 9. Re: Jumping mouse has to stop!
    Barney-15E Level 8 Level 8 (35,260 points)

    Good work, being even more antagonistic to the one person on these forums who knows just about everything about the Mac, and when he doesn't, he can ususally work you through the troubleshooting steps that might identify the problem. You apparently can't take a hint.

     

    Try booting into Safe Mode and see if it still happens.

     

    When you say, "We are trying to design on these machines, after all," does that mean you have more than one machine doing the same thing, or do you just have a mouse in your pocket? If you have more than one machine with the same symptoms, it might be some third-party program causing the issue.

     

    As with others, I've never heard of this problem and I've been here a long time.

  • 10. Re: Jumping mouse has to stop!
    Topher Kessler Level 6 Level 6 (9,340 points)

    The only times I've had jittery and jumping mouse issues has been when the mouse is broken. Replacing the mouse should result in smoother cursor movement.

  • 11. Re: Jumping mouse has to stop!
    HarHag Level 1 Level 1 (0 points)

    I have the same problem with basically any USB mouse. The annoying thing is that this behaviour occurs only with 10.7.3. All earlier versions were fine.

    I found out that the problem occurs if I attach a second monitor. Since it is only depend on the version of mac os, it should be fixed with a software update.

     

    I already sent a bug report but...well, I hope it gets fixed in ML.

  • 12. Re: Jumping mouse has to stop!
    petersamuels Level 1 Level 1 (0 points)

    I just found this solution and so far (fingers crossed) it's working. Go to Aplications>Utilities>Logitech Unifying Software > Advanced and un-pair the device. Then re-pair the mouse.

     

    Like I said, so far so good. This has been happening for me with an older (2009) MacPro with 16 Gigs of ram running 10.7.4. The cursor jumps around mostly (or most notably) in photoshop CS5 making intricate selections a brutal game of cat and, uh.. mouse..

     

    Good luck!

    .peter

  • 13. Re: Jumping mouse has to stop!
    FilmEditing Level 1 Level 1 (0 points)

    Thanks for the tip. Works for me as well. Unfortunately the problem came back after two days and I had to repeat the procedure. I have to wait and see how long it will last this time.

    The problem only occurs on my 5,1 Mac Pro (2012), whereas my old 1,1 Mac Pro works fine. I tested both machines with the same boot drive with OS 10.6.8 on it. Problem definitely not the OS and also not the mouse.

    It is really frustrating to buy a 3000€ machine, that is rendered useless via a mysterious problem like that.

     

    I had problems with slow and/or jittery usb-connections on my macbook pro on other occasions and my guess is, that in my case the usb-connection with the logitech-dongle is the problem.

  • 14. Re: Jumping mouse has to stop!
    Sam Beaver Level 1 Level 1 (120 points)

    i think you will want a new mouse.

    the apple flat, no button mouse and trackpad are very jittery. they simple shift quite often.

    i have to use an old wired mouse with a trackball to do any work. the newer generation apple human input devices, while not fully correspondent to vacuum cleaners, do perform the same sucking action.

1 2 Previous Next