Skip navigation

turn on in app purchases

27745 Views 11 Replies Latest reply: Jan 26, 2014 7:56 AM by cjkrissy RSS
barker456 Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 3, 2012 5:35 PM

I am trying to enable in app purchases on my ipad.  After I turn on the restrictions, the In app purchases option is greyed out.  Why is this?  I am trying to make some in app purchases.  Does anyone have any suggestions?

iPad 2, iOS 5.1
  • Demo Level 9 Level 9 (73,730 points)
    Currently Being Moderated
    Apr 3, 2012 5:41 PM (in response to barker456)

    You can disable in app purchases when you enable restrictions. Turn the restrictions off until you are done making your in app purchases or enable the in app purchases and then turn on restrictions.

  • Demo Level 9 Level 9 (73,730 points)
    Currently Being Moderated
    Apr 4, 2012 5:46 AM (in response to barker456)

    I don't use restrictions at all since only I have access to my iPad at all times so I'm just suggesting ideas based on my reading from the user guide.

     

    However, when something does not work as expected on the iPad, the first thing that I do is go back to the basics.

    Have you restarted the iPad to see if that will allow the setting to work again. Sometimes that's all it takes.

     

    Restart the iPad by holding down on the sleep button until the red slider appears and then slide to shut off. To power up hold the sleep button until the Apple logo appears and let go of the button.

     

    One other thought - do you have the Password Required feature enabled for in app purchases? Could that be what is causing the inability to rentable the setting?

  • paulcb Level 6 Level 6 (18,675 points)
    Currently Being Moderated
    Apr 4, 2012 9:17 AM (in response to barker456)

    I turned on Restrictions and I can change any option except the in app purchase one.  It remains grey out even with restrictions turned on.

    I suspect you have a profile on there disabling that feature.  Is this a corporate iPad or do you have a corporate Exchange account on it for email, contacts, calendar, etc.?

  • Demo Level 9 Level 9 (73,730 points)
    Currently Being Moderated
    Apr 4, 2012 9:18 AM (in response to barker456)

    No. Like I said I don't use restrictions and I'm merely working from the user guide. I copied this from the user guide book available for free in the iBookstore.

     

    In-app Purchases

     

     

    Turn off In-App Purchases. When enabled, this feature allows you to purchase additional content or functionality within apps downloaded from the App Store.

     

    Require Password

     

     

    Requires you to enter your Apple ID for in-app purchases after the time period you specify

     

    I just can't think of why the feature does not come back if you turn off restrictions.

  • James Ward4 Level 7 Level 7 (23,125 points)
    Currently Being Moderated
    Apr 4, 2012 9:20 AM (in response to barker456)

    barker456 wrote:

     

    I tried the restart and that didn't work.  I'm not sure where the password required feature is.  I've never set a password for my ipad.  Any idea where that option is?

    Setting > General > Restrictions

     

    Setting > General > Passcode Lock

  • Spide123 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2013 10:28 AM (in response to barker456)

    I also can't turn on my in app purchases.....in restrictions it asks for 4 digit pass code and I HAVE TRIED everything....I NEVER put one in. Is there any other way to enable IN APP Purchases??? I have called Apple Support and ITUNES support and no good answer. HELP

  • rickyroyal Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2013 7:39 AM (in response to barker456)

    Go to Settings->General->Restrictions

     

    To enable in-app purchases you need to first enable restrictions and enter a 4-digit code.

     

    So, do this now. Click "Enable Restrictions"

     

    If you have never entered a 4-=digit code before then make one up, but do remember it.

     

    Once you have enabled restrictions you can then slide the "in-app purchases" over to show green (slide the slider to the right), thus enabling it.

     

    Once you have done this, go back up to the top of the screen and click "disable restrictions" to set things back how they were at the start.

     

    Job done !

  • jagreeson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 1, 2014 9:41 AM (in response to rickyroyal)

    You've made my kiddos New Year a little brigher! 

    We've tried to purchase things in apps for months and couldn't figure out how to enable them.  Thanks a million!!!

  • cjkrissy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2014 7:56 AM (in response to rickyroyal)

    Thanks alot. I hope this helps. My 4 year old has constantly been making purchases and they have all gone through without a password! I hope this helps.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.