Skip navigation

Passwords not saving in Safari / Keychain

6452 Views 21 Replies Latest reply: Apr 16, 2012 1:22 AM by Joel Delane RSS
1 2 Previous Next
Joel Delane Calculating status...
Currently Being Moderated
Apr 5, 2012 2:19 AM

Hi,

 

I use Safari and have done so since owning macs for years. Never had a problem with keychain and safari remembering passwords and usernames. Since updating to the latest verison of Safari 5.1. I've encountered a problem where it won't remember the password for my websites. I have turned on autofill / user names and passwords. Even tried deleting the partciular sites from my Keychain, then removing the site and username from the autofill list in safari. But when i do this and go back to the site i want to save details on Keychain won't save any of my details. I have tried repairing keychain, restoring from an old keychain folder from my time machine. But nothing!

 

I have thousands on passwords and usernames, would be great if someone has a solution!!

 

cheers

 

Joel

iMac Intel Core Duo 2.16 Ghz, Mac OS X (10.5.5)
  • Linc Davis Level 10 Level 10 (107,660 points)
    Currently Being Moderated
    Apr 5, 2012 5:42 AM (in response to Joel Delane)

    Do you get the prompt to save the password in the Keychain? What is your Mac OS version?

  • Linc Davis Level 10 Level 10 (107,660 points)
    Currently Being Moderated
    Apr 5, 2012 7:14 AM (in response to Joel Delane)

    So you delete the password for a site from the keychain in Keychain Access. You then visit that site and log in. You're prompted by Safari to save the login credentials in the keychain. You confirm. There's no error message. You log out of the site and log back in. You get the "save in keychain" prompt again. Nothing is saved in the keychain when you open Keychain Access. Correct?

     

    If so, does it happen with all sites, or only some? If only some, please give an example.

  • Linc Davis Level 10 Level 10 (107,660 points)
    Currently Being Moderated
    Apr 5, 2012 7:25 AM (in response to Joel Delane)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    Note: If you’ve activated “Find My Mac” or FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Be sure your Mac is shut down.
    • Press the power button.
    • Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    • Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem(s)?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • RainyWeather Calculating status...
    Currently Being Moderated
    Apr 5, 2012 8:30 AM (in response to Joel Delane)

    Hi Joel,

    I have either an identical or very similar problem.  I have a new iMac (purchased in December), using Lion 10.7.3.  Safari is my only browser.  I updated to Safari 5.1.5 on March 27th; I also went from Mobile Me to iCloud on March 27, and the problem started after that (I first noticed it 3/30, but I think it started immediately after I made those two changes).  I talked to AppleCare 3/30; they tried a few things then transferred me to a senior advisor and he couldn't figure it out either.  He was going to check with Apple engineers and get back to me; I'm hoping to hear from him soon.  I've been inclined to think it was the switch to iCloud, but after reading your post I'm wondering.  HAVE YOU BY ANY CHANCE SWITCHED TO iCLOUD VERY RECENTLY?  I'd really appreciate knowing.

     

    If I go to a website where my user id and password have autofilled immediately for the past 6 years, now ONLY the user ID fills in.  When I fill in my password and log in, the prompt is NOT "Would you like to save this password," but rather "This password is different.  Would you like to remove the old password and save this one?"  (Not an exact quote, but that's the gist.)

     

    When I was working with AppleCare, they had me delete one of the webform passwords for a site I use very frequently and then log in to the site, and of course that time the prompt was "Would you like to save this password?"  I clicked to save the password and it looked like it was saving, but now every time I go to that site, the user ID is filled in but the password is not.  When I enter the password manually, I now get the "Would you like to save this password" prompt every time.  Meanwhile, all other websites with saved passwords continue to give me the "this password is different" prompt.

     

    If I don't hear back from AppleCare soon, I will call them.  I would really appreciate knowing whether you recently made the change to iCloud.  It will help me figure out whether it's the Safari 5.1.5 change or the iCloud change.  In the meantime, maybe it's a little comforting to know that it's not just you! 

  • RainyWeather Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 5, 2012 10:57 AM (in response to Joel Delane)

    Hey, Joel,

    I'm very glad to hear from you, and of course I will let you know what I find out from AppleCare.  It may take awhile, but as soon as I find out I will get back to you.  Can you give me any more information about when you switched to iCoud and when you upgraded to Safari 5.1.5?  The more I can pinpoint it for AppleCare, the faster we'll get a response.  I've had good experiences with AppleCare in that the people have always been pleasant and done their best to help me.  With simple issues they usually resolve it pretty fast, but with a software update problem, they're sometimes just learning about it too.  For instance, with the upgrade to Lion 10.7.3, Applecare couldn't help me and had me take it to the Genuis Bar (big job - I live upstairs and it's nerveracking transporting this expensive and heavy computer), where they completely erased my disc and then reloaded it from my backup - only to have it turn out there was nothing wrong with the computer at all, it was a problem with the update (my wifi wasn't connecting after waking the computer from sleep).  So if you know even approximately when you did each thing (the Safari upgrade, the switch to iCloud) and which is more likely to have caused the problem, that will help AppleCare and end up helping you and me.  Also, did you switch to iCloud from Mobile Me?  I had a problem with my Mail this past weekend and it turned out it was only affecting people who had switched to iCloud from Mobile Me.

     

    As soon as I get your response, so I have a better idea which thing was more likely to have caused the problem, I'm going to file a bug report with Apple - as you may know, you can do that at http://www.apple.com/feedback/imac.html - I think the more they get reports about it, the faster they will get working on it and get it fixed, and I'm sure this is something they'll want to get fixed.  If I don't hear from AppleCare in the next day or so, I'll call them, and I'll definitely keep you updated.  This is likely affecting other folks as well.

  • zhangchi1991 Calculating status...
    Currently Being Moderated
    Apr 5, 2012 11:33 AM (in response to RainyWeather)

    Ok I'm here. So yes, I have exactly the same problem as you guys do. I don't think I have recently messed with iCloud, and I don't quite remember if this started to happend after the Safari updates. But this problem did just happen recently. The version of my Safari is 5.1.5 (7534.55.3). Hope it helps.

     

    Thank you guys for helping, I really appreciate it.

  • jzfinca Calculating status...
    Currently Being Moderated
    Apr 5, 2012 11:42 AM (in response to Joel Delane)

    I am also experiencing this issue, as well as a few other issues since updating my Safari.  Keychain/password issue; email issue (kinda related to the password thing because it keeps asking for my yahoo password & won't access my email); and my MBP now fails to download web page images all the time - sometimes yes and sometimes no.  It's unpredictable and random, and began after the update.

  • RainyWeather Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 5, 2012 11:51 AM (in response to jzfinca)

    So it's sounding more and more like it's the Safari 5.1.5 update (not iCloud).  I really think it might help if we all file bug reports:

     

    http://www.apple.com/feedback/imac.html


    And again, if I don't hear from AppleCare in a day or two, I'll call them (I'd rather wait for the call, because it would be helpful to speak with the same person).  Once I talk to them, I'll post here and let you know what they say.  If it's a problem with the update, then we'll just have to wait for Apple to fix it (I had a problem with the 10.7.3 Lion update, as did many other people, and they found a solution and issued a new update a month or so later that fixed it).  That's why I think we should file bug reports; the more information and the more reports/polite complaints they get, the faster they're likely to fix it.

  • RainyWeather Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2012 7:21 AM (in response to Joel Delane)

    Hi Joel,

    Thank you so much for getting this information and letting us know.  I did look at the site you found, but I'm so computer ignorant that I don't even how to run a command in terminal.  (i.e., do I type it on the line where the cursor is and then hit return; do I go down to the next line first; is there a space after the word "read" and before the forward slash - you don't need to answer these questions; I'm just explaining how much I don't know).  That's why I spent the money for AppleCare when I bought the computer.  After I read your post, I left a voicemail message for the AppleCare senior advisor.  I'm hoping that they will walk me through checking to see if I I'm infected and  then fixing it if I do.  Since your and my problems sounded identical, it does seem likely.

     

    I'm hoping to work with AppleCare this morning or sometime tomorrow (can't be home this afternoon), and I will post and let you guys know what happened.

     

    Thanks again for finding and posting the information about Mac Trojan Flashback. 

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.