12 Replies Latest reply: Oct 11, 2012 5:01 AM by 1kickerfish
zhangchi1991 Level 1 Level 1 (0 points)

The autofill of my safari is not working! It does not let me remove any remembered username or password, neither will it remember any new ones I typed in. It keeps poping up the dialog asking me if I want to remember the username and password or not, but it won't remember them even though I clicked yes. Please help guys!


MacBook Pro, Mac OS X (10.7.3)
  • 1. Re: Safari Autofill not working!
    Linc Davis Level 10 Level 10 (118,305 points)

    If iCloud is enabled, disable it and try again.

  • 2. Re: Safari Autofill not working!
    zhangchi1991 Level 1 Level 1 (0 points)

    Still not working man =(

  • 3. Re: Safari Autofill not working!
    Linc Davis Level 10 Level 10 (118,305 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    Note: If you’ve activated “Find My Mac” or FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Be sure your Mac is shut down.
    • Press the power button.
    • Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    • Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem(s)?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • 4. Re: Safari Autofill not working!
    zhangchi1991 Level 1 Level 1 (0 points)

    Ok. I tried both steps.

    It works when I logged in as a Guest.

    It still does not work even if I run it with safe mode.

  • 5. Re: Safari Autofill not working!
    RainyWeather Level 1 Level 1 (0 points)

    Hi Zhangchi1991,

    There is another discussion and I think your issue may be the same as the one being discussed there (Linc is in that discussion too).  It's under the Mac OS & System Software heading, then under Safari, and the reference/question is "Passwords not saving in Safari / Keychain."  We're thinking it might be related either to the Safari 5.1.5 update OR to switching to iCloud.  Did you by any chance do either of those things just before this problem started?  If so, which one?  I'm talking to AppleCare about it, and the more information I can give them, the better.  You can get more information if you check out that other discussion.

  • 6. Re: Safari Autofill not working!
    Linc Davis Level 10 Level 10 (118,305 points)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.

     

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    Open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy — do not type — the following line into the Terminal window, then press return:

     

    chmod -R -N ~

     

    The command will take a noticeable amount of time to run. When a new line ending in a dollar sign ($) appears below what you entered, it’s done. You may see a few error messages about an “invalid argument” while the command is running. You can ignore those. If you get an error message with the words “Permission denied,” enter this:

     

    sudo !!

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.

     

    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

     

    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

     

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens.

     

    Select your boot volume if not already selected.

     

    Select your username from the menu labeled Select the user account if not already selected.

     

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

     

    Select ▹ Restart from the menu bar.

  • 7. Re: Safari Autofill not working!
    zhangchi1991 Level 1 Level 1 (0 points)

    It didnt prompt me to enter my login password though after I run the "chmod -R -N ~" command on terminal.

  • 8. Re: Safari Autofill not working!
    zhangchi1991 Level 1 Level 1 (0 points)

    Never mind lol.

  • 9. Re: Safari Autofill not working!
    zhangchi1991 Level 1 Level 1 (0 points)

    It's still not working... =(

  • 10. Re: Safari Autofill not working!
    Linc Davis Level 10 Level 10 (118,305 points)

    First, back up all data if you haven't already done so. No matter what happens, you should be able to restore your system to the state it was in at the time of that backup.

     

    Open the Library folder in your home folder as follows:

     

    If running Mac OS X 10.7 or later, hold down the option key and select Go ▹ Library from the Finder menu bar.

     

    If running an older version of Mac OS X, select Go ▹ Go to Folder… from the Finder menu bar and enter “~/Library” (without the quotes) in the text box that opens.

     

    From the Library folder, move the entire contents of the subfolder Caches (not the folder itself) to the Trash, then log out and log back in. Empty the Trash. Test.

     

    If the problem is not solved, open the Library folder again in the same way and move the entire contents of the subfolder Preferences (not the folder itself) to a new folder on the Desktop (not to the Trash.) Log out and log back in. The account will then be pretty much in a clean state. Test. If you can still reproduce the problem, then put the Preferences folder contents back, replacing any that were created in their place, log out, and log in again.

     

    If you can't reproduce the problem in the clean state, then start putting things back in the Preferences folder piecemeal, starting with items that seem unrelated to the issue. I can’t be more specific. After each group of items, repeat the log out/log in cycle and test. At some point, the problem may reappear, in which case you know that something in the last batch of files you restored is at fault. If it never reappears, the problem is solved.

     

    This may be a very time-consuming process, but it’s the best I can suggest in the circumstances.

  • 11. Re: Safari Autofill not working!
    12y4nt Level 1 Level 1 (0 points)

    Are you still having trouble? I recently had this same issue and got it to work. First I deleted my iCloud account from mac. Then i unsynched bookmarks from iDevices. Then I went to Launchpad->Utilities->Keychain Access and deleted everything in the entire keychain. Then I went to Safari->Reset Safari. Re synched icloud to Mac, then checked the autofill passwords. Everything was deleted from there and it prompted me to save passwords again. Seems to be working fine now....

  • 12. Re: Safari Autofill not working!
    1kickerfish Level 1 Level 1 (0 points)

    Fixed it.  Installed Firefox and uninstalled Safari.  Works perfectly and no more time wasted on the never ending Safari bugs.