Skip navigation

iPad 3 Why 3G does not work after being on WiFi

156652 Views 405 Replies Latest reply: Nov 20, 2013 10:33 AM by flytooth RSS Branched to a new discussion.
  • yom207 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 5, 2012 11:38 PM (in response to guitartabman)

    I am in Australia and have the same concern. Apple replaced the iPad3 and after one day it happened again. It is a 64GB iPad 3 on Vodafone.I am back to apple after Easter.

  • davidm_uk Level 1 Level 1 (0 points)

    I have the same problem with my iPad 3 4G 32GB with both an O2 SIM card and a GiffGaff SIM card (admittedly also using the O2 network). When I travel with my iPad, e.g. taking it on a train, it loses its mobile data connection despite showing a strong signal. Toggling settings does not fix it (turning mobile data and/or wifi on or off, or even temporarily enabling airplane mode). The only way I have found to re-establish mobile data is to turn the iPad off the on again (powering it off fully by holding down the power button then swiping).


    This is a very irritating problem on an otherwise excellent product. I really hope this can be solved soon with a software update.


    Incidentally this is my first iPad, so this is not a 'restore from backup'-related issue.

  • davidm_uk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2012 1:03 AM (in response to davidm_uk)

    I forgot to add: I'm in the UK.

  • Coppertiger Level 2 Level 2 (490 points)
    Currently Being Moderated
    Apr 6, 2012 1:33 AM (in response to davidm_uk)

    Had the same issue 3 days ago following a settings reset and resync (Data not showing in Settings\About).  I was on home wifi at the time.  The About section found no number listed or carrier information with Data switched on.

    A check through my Settings found that Location Services, though on, had turned off the Cell Network search Option.  Once back on, I turned off using the hold button in slide red slider method, switched on again and everything was fine.

    As a footnote, I have seen some solutions to other problems being given to reboot by this method but to then press and hold the Home button until the screen flicks to the home screen before bringing the Apple logo up.  tried this to solve something else and found that this method works to track last settings saved.  So if you make changes without resyncing and then reboot with this method, the changes are discarded for a last saved state.  Just something to keep in mind if rebooting. Total switch off, wait, switch on and resynch with your connection active seems to be the way to commit the settings.  This has worked for me.  I am in the uk and have not experienced anymore problems for the last 3 days.  I am on 3 netwrork, and Virgin Media Home broadband via a Linksys WRT54GS (EU-LA) model. 2.4Ghz 802.11g with built in speedbooster. Ipad2

    Another thing I sometimes notice is that if i do not turn cellular off in Settings the 3g icon stays active on the top bar instead of indicating my home wireless,.  However with iTunes open on my PC the device shows up and syncs normally, and any downloads i make to the iad sends my modem lights racing, so i know it is using home wifi.


    One other thing I do do though is to keep Data Roaing switched off, as I dont need it.  I left it on once and it used to drop my 3g regurlarly as it tried to lock onto signals from other masts.  Since I have kept it off I have had no further problems when out and about.

  • Kasti Level 1 Level 1 (0 points)

    Got the same problem in Austria, Provider A1.


    2 ways to recover:





         Remove Sim, wait 10s, put it back in

  • adbayaras Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2012 10:01 AM (in response to Kasti)

    Got the same problem 64GB with Singtel 3G in Singapore

  • Martin1984 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2012 10:07 AM (in response to adbayaras)

    Exact same problem. 2 iPad third gen wifi+4g at home. Both having the same problem. From Singapore

  • jmgg0025 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2012 11:07 AM (in response to guitartabman)

    I'm going to wait a couple of weeks and if not get an update that solves the problem I will call to apple to ask for a replacement.

  • gecko20 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2012 12:08 PM (in response to jmgg0025)

    Is it possible to get a replacement rignt now?

  • Torqen Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 6, 2012 12:12 PM (in response to gecko20)

    Sure, or at least, where I purchased it (Norway) you have by law at least 2 weeks regret the purchase and return the product. 

  • elliatedm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2012 12:12 PM (in response to guitartabman)

    Same problem in Czech Republic - O2 3G, 16GB.

  • Geraintj Level 1 Level 1 (0 points)

    Same problem


    Uk based. Tmobile, sim from an ipad1 3g, never had this problem. Now i have to hard reset my ipad almost every day to get the 3g working again.

  • zwolle1 Level 1 Level 1 (0 points)

    Wel in the netherlands i have the same problem with an 4g 32gb.  my ipad 1 has no problems at all, and after my account was reset by vodafone it worked like h... for a few hours and after that the same problem.  It is indeed switching to Edge.  Wich is strange because before on the same locations is was 3g or gprs  but never edge.  Hope a new ios release solves the problem because i love my ipad (but not today i don't)

  • Kangur Level 1 Level 1 (0 points)

    Same problem here in Catalonia with a 32GB. Never had a single problem with ipad1 or ipad2. Can't believe that we have descended to android crapware inferno.

  • Coppertiger Level 2 Level 2 (490 points)
    Currently Being Moderated
    Apr 6, 2012 4:08 PM (in response to Kangur)

    Everyone please try this,  Settings\Carrier  Turn automatic OFF.  Wait unti the available networks are listed, then tap yours to select - note those with 3 network should select the 3G option if it shows up.

    My conclusion is that when on auto and it drops wifi, it _roams_ but cannot fix due to interference from competing signals.

    With it set manually it can lock to your provider and ignores others.

    Thats my theory.  Please try it, as I would like some feedback to try and isolate possible causes.

    Similarly when setting up wifi, use the Other option and enter your network manually.  I have a theory about how the iPad seeks signals on auto, I think they are using a setting that in windows at least was well known to cause problems.  My theory is based on them using a similar setting to connect automatically when in range, but this can be problematic when trying to lock in aginst a band crowded with other subscribers.  This may have something to do with the channel separation abilities of the built in antennae and associated circuitry.

    Those with a working theory of radio and notch filters will recognise where I am coming from on this.  Its only a guess but I would like to try and experiment a bit with help from others with similar problems.  Best regards, Ct.

1 ... 3 4 5 6 7 ... 28 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (22)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.