Skip navigation

Cannot download iTunes 10.6 on Windows 7. Apple Application Support problem (Error 2)

6741 Views 15 Replies Latest reply: Sep 3, 2013 12:39 PM by Puvanthodi Basheer RSS
1 2 Previous Next
bdbst2 Calculating status...
Currently Being Moderated
Mar 31, 2012 12:56 PM

The installation will not continue because of Apple Mobile Device Service failing to run, and clicking retry just makes the message come back. but if i choose the abort option iTunes will download. Trying to open itunes after, I receive the following message:

 

"Apple Application Support was not found.

Apple Application Support is required to run iTunes, please uninstall iTunes, then install iTunes again.

Error 2 (Windows Error 2)"

 

I've been trying everything possible to download iTunes, including downloading a freeware uninstaller to clear all files, but nothing is changing this.

Windows 7
  • b noir Level 9 Level 9 (71,990 points)

    Let's try a standalone Apple Application Support install. It still might not install, but fingers crossed any error messages will give us a better idea of the underlying cause of the issue.

     

    Download and save a copy of the iTunesSetup.exe (or iTunes64setup.exe) installer file to your hard drive:

     

    http://www.apple.com/itunes/download/

     

    Download and install the free trial version of WinRAR:

     

    http://www.rarlab.com/

     

    Right-click the iTunesSetup.exe (or iTunes64Setup.exe), and select "Extract to iTunesSetup" (or "Extract to iTunes64Setup"). WinRAR will expand the contents of the file into a folder called "iTunesSetup" (or "iTunes64Setup").

     

    Go into the folder and doubleclick the AppleApplicationSupport.msi to do a standalone AAS install.

     

    Does it install properly for you? If so, does iTunes launch properly now?

     

    If instead you get an error message during the install, let us know what it says. (Precise text, please.)

  • b noir Level 9 Level 9 (71,990 points)

    "The procedure entry point

    AVCFAssetCreateWithByteStreamAndOptions could not be located in

    the dynamic link library AVFoundationCF.dll"

     

    Still consistent with AAS trouble. (AVFoundationCF.dll is an AAS file.)

     

    Let's try getting .NET framework problems off the table (they would be consistent with the 2 as well):

     

    iTunes for Windows: "Error 7" message when opening iTunes

  • b noir Level 9 Level 9 (71,990 points)

    I am still having problems getting the Mobile Device Services to run

     

    Is that still during the install? Or is iTunes installed, but AMDS is refusing to start?

  • b noir Level 9 Level 9 (71,990 points)

    More underlying troubles with AAS indicated by that newest one.

     

    "An error occured during the installation of assembly

    'Microsoft.VC80.CRT,type="Win32",version="8.0.50727.

    6195",publicKeyToken="1fc8b3b9a1e18e3b",processo

    rArchitecture="x86"'. Please refer to Help and Support

    for more information. HRESULT: 0x800763FD"

     

    These ones are typically caused by underlying problems on the PC that also often cause Windows Updates to fail to install. If we can fix the Windows Update trouble, we can usually get the iTunes trouble cleaned up en passant.

     

    Go into your Windows update and try to check for new updates. If updates install, stock up on the ones you're behind on, restarting the PC if requested to do so. After the restart, try installing iTunes again. Does it go through this time for you?

     

    If windows updates fail to install, go into your Update History and doubleclick the failures. What alphanumeric codes appear for you? Are they also 800763FD, or some other number? (If they're another number, what number are you getting?)

  • GrahameE Level 1 Level 1 (20 points)

    I have had this problem with Windows 7 and iTunes updates for some time. Each time it takes hours to solve but with the over the air upgrade to IOS6 on my iPhone and iPad, I was determined to solve and remember what I did, So here it is:

     

    http://www.care4pcs.co.uk/2012/09/pear-shaped-apple-ios-6-for-iphone-ipad.html

     

    I hope this helps you and any other users.

  • ofwgktadgaf Calculating status...

    b noir when i did the thing you informed it did not download properly what do i do

  • iteese Level 1 Level 1 (0 points)

    iTunes "Apple Application Support is required... Error 2" and possible fix.

     

    I know this is a bit late but I came accross this thread trying to resolve this same problem and came up with a solution that worked for me, so thought I would share it here too. I hope it helps someone else.

     

    I just resolved this on Win Vista (should apply equally for Win7 too). Please uninstall iTunes before proceeding though. I'll walk you through the process I followed, if you like you can jump straight to the Solution section.

     

     

    Problems:

    The initial error during the installation of iTunes was:

    An error occurred during the installation of assembly 'Microsoft.VC80.CRT,version="8.0.50727.4053",type="win32",publicKeyToken='1fc8b 3b9a1e18e3b",processorarchitecture="x86". Please refer to Help and Support for more information. HRESULT:0x8007054F

     

    The error (after installing iTunes) when trying to run iTunes was:

    Apple Application Support is required to run iTunes. Please uninstall iTunes, then install iTunes again. Error 2 (Windows error 2).

     

    After trying various fixes around the forums I came across this MSKB article, which relates to the first installation error:

    http://support.microsoft.com/kb/2688946

     

    This lead me to trying to install MS Visual C++ but I received the following error trying to install that:

    Error 1935.An error occurred during the installation of assembly ‘Microsoft.VC80.ATL,type=”win32”,version=”8.0.50727.762”,publicKeyToken=”1fc8b3 b9a1e18e3b”,processorArchitecture=”amd64”’. Please refer to Help and Support for more information. HRESULT: 0x80070BC9. Assembly interface: IassemblyCacheItem, function: Commit, component: {837BF1EB-D770-94EB-A01F-C8B3B9A1E18E}

     

    Note: The installation of VC++ rolls back when it fails.

     

     

    Solution:

    Through this error I found this MSKB article:

    http://support.microsoft.com/kb/946414

     

    The Automated MS "Fix It" msi package didn’t work.

     

    Note: Please backup your registry first (see the above MSKB article for instructions).

     

    I opened the registry and (as instructed in the MSKB article) deleted the following keys:

    HKEY_LOCAL_MACHINE\COMPONENTS\

    • PendingXmlIdentifier
    • NextQueueEntryIndex
    • AdvancedInstallersNeedResolving

     

    Reboot and reinstall iTunes.

     

    If it helps you please like this so others can find it.

  • liltech101 Calculating status...

    hi to b noir

     

    no error messages - it looks like it installed but it does not run

  • iteese Level 1 Level 1 (0 points)

    Hi liltech101,

    That sounds like a totally different problem to what the OP posted.

     

    You might want to check this thread: https://discussions.apple.com/thread/4418107

    Make sure you update Quicktime and try again.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.