Skip navigation

My iMessage still says "Waiting for activation..."

967044 Views 518 Replies Latest reply: Mar 19, 2014 9:23 AM by iscast RSS Branched to a new discussion.
  • ailyoc Calculating status...

    I have just read all 15 pages, it took me the whole night and I tried literally every single one of your solutions and nothing worked.

     

    I ported my number from O2 to Vodafone and changed from my 3GS to a 4. iMessage was working perfectly on the 3GS with my old carrier and now it's not working anymore. Total pain in the backside. I want to send iMessages from my own number, not my email address.

     

    Please, please someone else?

  • TankerKC Calculating status...

    Good luck...I wen through the same thing two months ago...lost all of my calendar items and music in the process.  Guess what?  it doesn't last.  A few weeks ago Facetime and IMessage weren't activated any longer.

     

    Fix this, Apple!

  • lavandero Calculating status...
    Currently Being Moderated
    Mar 13, 2012 10:47 AM (in response to TankerKC)

    Hello,

     

    I just noticed this started happening to me since the weekend.  It so happens that in Chile there was supposed to be a daylight savings time change, but it got postponed.  So, I swithed the "automatic time settings" so that the timezone and the time were how they would have been if there had been a daylight savings time change.

     

    After doing this I tried activating iMessage and Facetime and it appears as though that solved the problem.  At least I didin't get an error message about activation, but my phone is still waiting for the phone number verification on both.

     

    Hope this helps.

  • Fingwyon Calculating status...
    Currently Being Moderated
    Mar 13, 2012 7:49 PM (in response to Ammadz)

    Ammadz, thank you so much! It helped a lot! Finally I've got iMessage working again!

  • Zkalk Calculating status...
    Currently Being Moderated
    Mar 13, 2012 10:12 PM (in response to lavandero)

    i'm from chile too and I'm having the same problem, I turned on the automatic time settings and in iMessage apears the verifying message in my phone number but nothing happens

  • lavandero Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2012 1:58 PM (in response to Zkalk)

    I had to keep the automatic time settings on so that it verified the phone number.  As soon as I turned it off, it showed an error again. 

  • lsgomez2 Calculating status...

    I also live in Chile and the initial problem is clearly associated to the action of remove the automatic time setting last Sunday. After to restore the switch on,  iMessges can´t use the telephone number to send any imessage, and instead use the mail address associated to the Apple account.

    At the same time any trial to activate the iMessage function with the automatic time setting off, has sent a message to a telephone number of Great Britain. Why??????. Who pay for it?.

    As I also have one iPad with the same Apple account, all the imessages are redirected to both devices.

    I hope Apple can quickly fix this error

  • jjsuzukiv Calculating status...
    Currently Being Moderated
    Mar 18, 2012 9:02 AM (in response to lsgomez2)

    Chilean guys (and others who cannot resolve the issue)

     

    http://www.ohmygeek.net/2012/03/15/problemas-con-ios-5-1/

     

    This solution worked fine for me.


    Hope I will work for you too...

     

    I'm also worried about the SMS that had an international number :S ¿will they charge it to me?

  • crazyiphones Calculating status...

    Guys, i had the same problem and have spend more than 24 hours in reading internet about the issue. I have a factory unlocked iphone 4s and i'm using T-mobile sim... it was showing "waiting for activation" on both imessage and facetime. I called apple support and they said that this feature doesn't work on Tmobile network... they were wrong.... the issue was simple, if you using prepaid plan then check your balances... because to activate service the imessage and facetime send an international text messages, so 2 things to make sure -

    1. International message service is ON on your number

    2. You should have sufficient balance so that international msg be sent.

    Also make sure that Settings>> phone >> should have your number in this format "+1 XXX XXXX XXXX

    I did the same and now my imessage and facetime are up and running.

    Hope this will help!

  • ailyoc Level 1 Level 1 (0 points)

    OK, finally this morning my problem was solved. Basically, for me it was a carrier issue. I realized that I was also not receiving phone calls or texts from people in other networks (not before I missed a few appointments over it).

     

    I had to phone Vodafone everyday for the last week to get them to escalate the problem to their support team. First, they tried to tell me everything from turning the phone on and off to it was my SIM to on and on and on and on.

     

    Finally after all that, they got the technicians on it and seemingly there was some fault when I was ported that was causing the issue. No simple fix, but a fix none the less thank God.

     

    Hope the rest of you can get it solved. It's a huge pain in the backside.

  • lefteros Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2012 7:10 AM (in response to riajul)

    I just can't believe it! I have been trying the whole morning and a "cancel" was the solution??????? It's surreal! Anyway many many thanx mate! You're a life-saver!

  • ericrnav Calculating status...
    Currently Being Moderated
    Mar 28, 2012 7:09 AM (in response to Ammadz)

    Time and date setting to automatic should be your first step in solving this problem. If that doesn't work continue with other suggestions on this forum. The automatic time worked for me and it actually makes since- any automatic syncing or datalink is reliant on an accurate time for all users/devices.

  • samadslimshady Calculating status...

    I was tired of this...tried everything but imessage was still on waitinf fro activation..but I followed up with this guide and my problem was solved

  • thinkingnomads Calculating status...
    Currently Being Moderated
    Apr 10, 2012 7:19 AM (in response to Ammadz)

    Seems to have solved my problem this way.

  • moosquare Calculating status...

    Any other suggestions? I've tried all the tips and tricks I can find, but it's still not working.

     

    This is a brand new iPhone 4S. If I use my old back up, iMessage will try to verify (and fail) my old phone number. But under setting > phone, but setting > phone, my new number is listed correctly.

     

    If I set it up as a new phone, iMessage doesn't detect my number at all, although my number is still listed on setting > phone.

1 ... 14 15 16 17 18 ... 35 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (13)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.