4 Replies Latest reply: Jan 30, 2013 4:49 AM by knutklim
kendonw Level 1 Level 1 (0 points)

I am using iCal with Lion and have iPhone 4s. I have iCal tied to google calendar.

 

When I set up a new event on iCal on my computer, I set an alarm, but it doesn't set; i.e., I reopen event and there is no alarm. I repeat setting alarm several times and iCal will not record it. I can set an event with an alarm on the iPhone and it does remember it.

 

Any ideas? Is there something on with google calendar link?


MacBook Pro, Mac OS X (10.6.3), laptop
  • 1. Re: iCal will not remember alarm
    MadisonP Level 5 Level 5 (4,485 points)

    Greetings,

     

    It looks like this may be a known issue between iCal and Google: http://groups.google.com/a/googleproductforums.com/forum/#!topic/calendar/J8VmiY qHP8U

     

    The suggestion which seemed to fix it for those folks was:

    "If you use "Message" [Not message with sound] as the alarm in iCal, then this will sync with google calendar..."

     

     

    See if that does it for you.

  • 2. Re: iCal will not remember alarm
    kendonw Level 1 Level 1 (0 points)

    Thanks. Tried just setting Message, but still won't stick.

  • 3. Re: iCal will not remember alarm
    BeachGuyBrett Level 1 Level 1 (0 points)

    Agreed - I've been having this problem since I purchased a Macbook Air with Lion last fall.  I sync iCal with Google Calendar but Alarms disappear 50% of the time.  I've tried "Message", "Message with Sound"....nothing works.  I'm runnning OS 10.7.3 and iCal 5.0.2 (1571).  This is very frustrating.

  • 4. Re: iCal will not remember alarm
    knutklim Level 1 Level 1 (0 points)

    Ok this is definitely a work around but seems to have the desired effect.

    Set Google calendar to send a text as a reminder as well as a pop up, which means you get the sound via a text message. Save the google contact details and assign the same alert sound that iCal uses to the text message alert.

     

    To change the time of an alert in iCal, create a new item as a default "all day" event, then change it to a specific timed event and at the same time set an alert as "message" with the desired time.

    To make changes to the timing of the alert, change the event back an all day event, close, and then change it again. It's the only way I've found that makes the time stick in iCal.

     

    The text message will unfortunately only come in at the predefined time unless you log in to Google calendar and change it.

     

    Not a solution but this is how I made it work.