Skip navigation

Accounts Gone. Preferences Grayed Out.

8097 Views 34 Replies Latest reply: May 1, 2012 12:28 PM by Ralph Johns (UK) RSS
  • Northern Blu Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 24, 2012 3:35 PM (in response to DenVogel)

    I've run intot his problem a few times.  Initially I did a restart/re-install but that didn't seem like a good fix/workaround. (not resetting the PRAM as someone suggested in another thread)

     

    This works for me (killing the daemon). Check for the process:

    $ ps -ef |grep imagent

    501   931   888   0 17Mar12 ??         0:41.50 /System/Library/PrivateFrameworks/IMCore.framework/imagent.app/Contents/MacOS/i magent

    $ kill -9 931

     

    Now the agent should restart:

    $ ps -ef |grep imagent

    501 46651   888   0  4:29pm ??         0:00.10 /System/Library/PrivateFrameworks/IMCore.framework/imagent.app/Contents/MacOS/i magent

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Mar 24, 2012 3:42 PM (in response to Northern Blu)

    Hi,

     

    It is simpler to open Activity Monitor and find the IMAgent listing, highlight and use the Quit Button and confirm Force Quit.

     

    This does not need Terminal nor finding out what IMAgent current PID is.

     

    People also need to know that in most Cases their User Account in numbered as 501  (Mine is not as it is a Migrated account from a G4)

     

    I am not even sure what the -9 bit is for.

     

     


    10:42 PM      Saturday; March 24, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • bgausden Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2012 8:38 PM (in response to Northern Blu)

    Thanks for the heads-up.

  • uaeute Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2012 11:48 PM (in response to DenVogel)

    Restart worked for me, but if it happens again I will try to Activity Monitor trick. Thanks to all!

  • DC100I Calculating status...
    Currently Being Moderated
    Mar 28, 2012 5:08 AM (in response to DenVogel)

    Just in case apple is actually reading this, I just installed Messages beta yesterday, and it was working fine. As of this morning, I'm having that grayed out issue that everyone else is having. I will restart.

  • seer14 Calculating status...
    Currently Being Moderated
    Mar 30, 2012 4:21 PM (in response to DenVogel)

    Killing the imagent allowed this to start working again. Thanks for the information ...

  • Joe Gramm Level 5 Level 5 (6,315 points)
    Currently Being Moderated
    Apr 4, 2012 5:08 AM (in response to Ralph Johns (UK))

    Thanks Ralf - Activity Monitor also got me working again.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Apr 4, 2012 1:39 PM (in response to Joe Gramm)

    Hi Joe Gramm,

     

    You are welcome.

     

     

    On  separate note

    My name is listed at the top of my Posts.

     

    My Sig pic is included

     

    example:-

     

     

    Hi,

     

    It is simpler to open Activity Monitor and find the IMAgent listing, highlight and use the Quit Button and confirm Force Quit.

     

    This does not need Terminal nor finding out what IMAgent current PID is.

     

    People also need to know that in most Cases their User Account in numbered as 501  (Mine is not as it is a Migrated account from a G4)

     

    I am not even sure what the -9 bit is for.

     

     

    (As in the post you responded to).

     

    It's just one of those things that bothers me now and then - it's is not really that big a deal but it does tweak my sensibilities as it were.  (enough for me to post about it ) 

     

     

     

     

     

     


    9:39 PM      Wednesday; April 4, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Joe Gramm Level 5 Level 5 (6,315 points)
    Currently Being Moderated
    Apr 4, 2012 2:14 PM (in response to Ralph Johns (UK))

    My apologies Ralph, not a mistake I generally make. Again, Sorry and thank you for the help.

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Apr 5, 2012 1:07 PM (in response to Joe Gramm)

    No Problem.

     

    As I tried to imply, I know it is more my problem than other people's

     

     


    9:07 PM      Thursday; April 5, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Joe Gramm Level 5 Level 5 (6,315 points)
    Currently Being Moderated
    Apr 5, 2012 4:24 PM (in response to Ralph Johns (UK))

    I actually have a similar problem. I know it's not the same as simply spelling your name wrong, but my last name is spelled Gramm. Inevitably I have to spell it out to people because they will always spell it Graham. 

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Apr 6, 2012 12:03 PM (in response to Joe Gramm)

    Hi,

     

    I can see that.

     

    As well as the spelling of Ralph when used verbally (normally) I also have people mishearing "Johns" as "Jones"

     

    My daughter has solved that one by marrying a "Jones".

     

     

     

     


    8:03 PM      Friday; April 6, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • chadkouse Calculating status...
    Currently Being Moderated
    Apr 10, 2012 4:39 PM (in response to Ralph Johns (UK))

    FYI the -9 part of the kill statement is like an uber kill.  A normal kill may not work if the process is so hosed that it isn't responding to system messages.  Here is a great musical explanation (nsfw): http://www.youtube.com/watch?v=Fow7iUaKrq4

  • chadkouse Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2012 4:52 PM (in response to Northern Blu)

    Killing the imagent daemon worked great -- thanks for saving me another reboot

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    Apr 11, 2012 11:02 AM (in response to chadkouse)

    Thanks

     

     


    7:02 PM      Wednesday; April 11, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.