Skip navigation

Folder Actions Not Working

1424 Views 5 Replies Latest reply: May 10, 2012 6:55 PM by Frank Caggiano RSS
Killasyougo Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 11, 2012 7:40 PM

I had a simple folder action created in Automator that scaled images to 800 pixels whenever i added files to a specific folder.

 

It does not work anymore.

 

I have tried recreating the action in a new folder and all i get is a warning:

 

"The action “Scale Images” was not supplied with the required data."

iMac, Mac OS X (10.7.3)
  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Apr 11, 2012 7:53 PM (in response to Killasyougo)

    Has this ever worked in Lion or have you recently moved from SL?

     

    If you post the Automat script it would be easier to diagnose.

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Apr 12, 2012 8:16 AM (in response to Killasyougo)

    Just tried the same thing here on 10.7.3 and it worked for me.

     

    The only thing I can think of is to make sure the script you think is attached to the folder is the one that is attached.

     

    If you right click the folder and select Folder Action Setups you'll get the Folder Actions Setup window. Select the folder you attached the script to that should show you the name of the script attached to the folder. Then select the script and choose Edit. That will open the script in Automator. Make sure it is the correct script.

     

    With the autosaving in Lion I've had cases where the version of the script I thought was attached wasn't actually the one that was attached.

     

    regards

  • mdh98368 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 10, 2012 6:08 PM (in response to Frank Caggiano)

    Not to be too much of a neophyte, but I am unsure about how to create a folder action at all. (I'm trying to create one to automatically send a file to Evernote). When I right-click on a folder, I do not see the "Folder Action" choice in the menu. I'm sure I'm doing something wrong but not sure what.

     

    I'm attaching a screenshot of what I see when I right-click a folder:

     

    Screen Shot 2012-05-10 at 9.07.56 PM.png

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    May 10, 2012 6:55 PM (in response to mdh98368)

    How you attach a script to a folder depends on how you are making the script.

     

    The easiest way to begin with is to use Automator. When you open Automator one of the templates creates a folder action. In the Automator workflow you specify which folder to attach to. If you need to do more complex things then Automator can do you can always write an Applescript (or shell script) and have the Automator workflow run the script.

     

    If you are trying to attach a  pure Applescript there are a few ways to do that. You can do it in the script itself, you can write a script that attaches another script or you can access the folder actions setup window for any folder via the folders  Services menu item

     

    Screen Shot 2012-05-10 at 21.53.53.png

     

    Once in the setup window you can attach and modify scripts. Further questions regarding this should be directed to Mac OS X Technologies

     

    regards

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.