Skip navigation

Tried loading iLife '11: Why does application iPhoto not open and say it may be damaged or incomplete?

1272 Views 10 Replies Latest reply: Feb 23, 2013 7:04 PM by LarryHN RSS
Ho\'okele Calculating status...
Currently Being Moderated
Apr 11, 2012 10:58 PM

I tried loading an iLife '11 Replacement DVD from Apple onto my currently updated 27" iMac OSX Version 10.6.8 and now am unable to access my iPhoto, am getting a message saying: You can't open the application iPhoto because it may be damaged or incomplete.


Looking at my iPhoto under About this Mac>more info>Software>Applications>iPhoto there is a big blank for Version and Kind and sayng it was last Modified 4/6/12, the day I tried loading the disc, and "No" for 64-Bit (intel).


So it looks like loading the iLife disc actually eliminated my iPhoto Application. Trying to open the iPhoto application on the hardrive get the same message, but it says the iPhoto application is a 21 MB application.


Would there be a danger in trying to re-install the iLife '11 disc?


Would anyone have any suggestions?

iMac, Mac OS X (10.6.8), 27"


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.