Skip navigation

Why can't I save pdf files in Safari 5.1.2

35147 Views 33 Replies Latest reply: Jun 21, 2013 12:52 PM by Roger Walters1 RSS
1 2 3 Previous Next
Roger Walters1 Calculating status...
Currently Being Moderated
Feb 20, 2012 2:17 PM

Up to now it hasn't bothered me much, but today I wanted to download iBank 4 Quick Start Guide. When I clicked on the link for the guide, Safari went to a pdf page and displayed the first page of the pdf. When I selected "Save As" it gave me a name for the file and the download destination. When I said OK, I got this error: The document “iBank_4_Quick_Start.pdf” could not be exported as “iBank_4_Quick_Start”. This happens for every pdf page I try to download. I get an error every time. The only work around I've found has been to right click (control click) on the button that takes you to the pdf file and select "Save linked file to the desktop" Safari used to allow you do a "Save As" for all pdf's. Does anybody know how to fix this?

Mac Pro, Mac OS X (10.6.8)
  • Linc Davis Level 10 Level 10 (107,875 points)
    Currently Being Moderated
    Feb 20, 2012 2:31 PM (in response to Roger Walters1)

    Quit Safari.


    Open the Library folder in your home folder by holding down the option key and selecting Go ▹ Library from the Finder menu bar (Lion), or by selecting Go ▹ Go to Folder… and entering “~/Library” (without the quotes) in the text box that opens (pre-Lion.)


    Delete the following items from the Library folder:




    Preferences/QuickTime Preferences


    Relaunch Safari and test.

  • dcnicholls Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 12, 2012 5:12 PM (in response to Linc Davis)

    OK, same problem, tried the solution (after fully closing Safari 5.1.5), but the problem was not fixed.  Since I have been able to save PDFs in the past from Safari, I wonder if it's a new(ish) bug?  This is the first time I've noticed th problem and I haven't tried saving a PDF for a few weeks.


    When I mouse over the PDF in the Safari window, a toolbar appears at the bottom, one control being a "save" icon, which works.  But the "Save as" menu option doesn't.


    The URL in question is D&data_type=PDF_HIGH&whole_paper=YES&type=PRINTER&filetype=.pdf



  • dcnicholls Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 12, 2012 6:07 PM (in response to Roger Walters1)

    They were the same files I deleted.  Also using 10.7.3 and Safari 5.1.5.  I have Acrobat Pro installed, as well as Skim.  I'm wondering if the latter might not be playing nicely w. Safari.  Anyway, the toolbar that appears when I mouse over the PDF allows me to save the file, so I'm not stuck, but I'm awlays curious why things start to break.



  • dcnicholls Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 12, 2012 6:35 PM (in response to dcnicholls)

    OK, I found the problem.  When I installed the latest Acrobat X update yesterday, it installed a new Safari plugin, AdobePDFViewerNPAPI.plugin, into the directory /Library/Internet Plug-ins  (ie System Library, not User Library).


    I deleted the NPAPI plugin and things are working as they used to.  I noticed that the NPAPI plugin was also hogging the processor (76%) on some PDFs.  It seems like bad news, and is probably not necessary.   (I left in place an earlier plugin, AdobePDFViewer.plugin.)



  • Fred L Johnson Level 2 Level 2 (355 points)
    Currently Being Moderated
    Apr 15, 2012 5:33 AM (in response to dcnicholls)

    I just had the same problem after updating Acrobat Reader. Moving the AdobePDFViewerNPAPI.plugin to my Diabled Plug-Ins folder solved my problem. (Deleting it also worked).

    I have no idea what I now can NOT do in Acrobat Reader after disabling this plug-in. Any help on how I've compromised Acrobat Reader?

  • dgivan Calculating status...
    Currently Being Moderated
    Apr 15, 2012 5:50 AM (in response to Fred L Johnson)

    This worked for me as well.  But I also had to remove the AdobePDFViewer.plugin.  I assume the apple WebKit takes over the functions when this is removed and works as it did before I updated my Adobe Acrobat and Reader applications.  Thanks for the help.

  • Wally Himself Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2012 4:21 PM (in response to dcnicholls)

    This worked for me - removing the AdobePDFViewerNPAPI.plugin - from the Library.



  • Brian_P Calculating status...
    Currently Being Moderated
    Apr 17, 2012 1:14 PM (in response to dcnicholls)

    Thank you. Thank you. Thank you, dcnicholls. This has been bugging me all through the last several days (apparently ever since I updated my Adobe PDF plugin on April 12), frustrating my ability to save pdfs needed for tax preparation and college financial aid applications. If not for the update, I could have been done last Friday. Instead, the update cost me a whole weekend of grief, as I worked around the problems, going back and forth between my Mac and my wife's Dell and printer.

  • Peaeye Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 18, 2012 1:06 PM (in response to dcnicholls)

    Thanks.  Deleting the new plugin worked for me.


    Is there a way to make Safari just hand off .pdf files to Acrobat if you have it?  I've just moved over to using Safari more after years with Firefox, and I can find the Safari equivalent to the Firefox content settings that allow you to tell it how to handle different kinds of files.  Any tips?

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.