Skip navigation

my macbook pro does not detect external display anymore

432284 Views 350 Replies Latest reply: Mar 31, 2014 2:28 AM by iDinev RSS Branched to a new discussion.
  • andrewfromMY Calculating status...

    Hi emgsilva

     

    It doesn't work for me.

    Perhaps I did it wrongly.

    Can you take us through step by step again?

  • emgsilva Calculating status...

    Sure, here are the things I did:

     

    1) download http://codykrieger.com/gfxCardStatus, install it and it will show an icon on your menubar

    2) whenever you want to connect an external display (or even after you already connected it) go to the gfxCardStatus icon and set it to "discrete".

     

    That is it... this worked for me in different displays (Samsung, LG, Philips)...

     

    When it is in "discrete" mode it makes sure you are using your discrete graphics card mode (in my case ATI)... since, aparently, the "integrated" (intel) is not able to output signal to the display.

     

    So, the solution basically consists on making sure you select that mode every time you connect an external display... or simply have it always set to discrete (which is not always good, if you want to extend you battery live while you are on the go - in those cases I use the "integrated" graphics mode).

     

    I hope it helps! Cheers

  • andrewfromMY Level 1 Level 1 (0 points)

    Thank emgsilva for the instructions but it is not working for me.

  • emgsilva Level 1 Level 1 (0 points)

    What macbook do you have? Mine is Macbook Pro 15, early 2011, ATI graphics card.

     

    What display are you trying to connect?

     

    Also try to reboot the macbook with the adaptor connected to the display... it worked for me with a display, before I discovered the trick that works for me.

     

    Good luck!

  • andrewfromMY Level 1 Level 1 (0 points)

    MacBook Pro 13-inch, Early 2011.

    Graphic - Intel HD Graphics 3000 384 MB

     

    Was trying to connect to a Panasonics Viera. Funny thing is I have been connecting to the same TV and was watching movies on it last 5 days ago. And today, i cannot detect the TV.

  • emgsilva Level 1 Level 1 (0 points)

    OK, so you do not have an NVIDIA or AMD RAEDON graphics card... which means that your setup is different from mine.

     

    The only thing I can tell is that my card on the integrated graphics mode (which uses the Intel HD Graphics 3000 384 MB) does not work with external displays... However, I just found out that a person with the same (or similar) setup as you did solve his problem with the same approach I take, take a look: https://discussions.apple.com/message/16685778#16685778

     

    Maybe this helps... do exactly like him/her, and good luck!

     

    Cheers!

  • cerocomados Calculating status...

    Hi! Since last week i´m having the same problem that most of you. I have a mid 2010 13"  MBP 2.4 Core 2 Duo with mini display to DVI connected to a Samsung 24 Display since last August and it has worked flawlesly until now.

     

    I´ve read this entire thread and others and I think i have tried everything. It has worked four times since the trouble begun. It started in a moment when the laptop runned out of battery, I plugged the power cord and the external screen didn´t come back.

     

    Also the gfxCardStatus doesn´t work in my laptop, it isn´t compatible. It seems that it only has one Graphic Card, Nvidia Geforce 320M, and the program doesn´t change to any integrated card.

     

    Any help will be welcome, thank you.

  • Kurt Liebezeit Level 1 Level 1 (5 points)

    Thank you, thank you! This worked for me.

     

    Kurt

    tcc13 wrote:

     

    I was having this issue just a few days ago when I switched my graphics card from dicrete to integrated to save battery life.  I also installed gfxcardstatus to do this.  What I founf from digging around was this from the gfxcardstatus website, "

    Why doesn't my external display work?

    Don't worry - nothing is broken. If your external display is not being detected while you're using gfxCardStatus, it means that you have a newer i5/i7 model, and you're currently on Intel Only mode. Switch to Discrete Only or Dynamic Switching to use the display. The Intel graphics chipset is incapable of outputting video through the Mini DisplayPort."

     

    So after switching back to discrete or dynamioc switching everything was working fine again. 

     

    Hope this helps some of you.

  • charris101 Calculating status...

    I  had this same problem with my MBP,15-inch, Early 2011, 10.7.3 with a new cable that i bought in amazon, it worked perfect for a while , but i take my MBP to home, and when i plugged again at work the external display will not turn on, now im using my old apple minidisplay to vga, and it's working again , seems like Lion doesn't like hdmi, since the update I have to enter the wifi password every time that I restart my MBP, an other issue no sound, for the no sound problem I have to reset de PRAM , someone else is having this problem?


  • 1STEPAWAY Calculating status...

    Thank You!! I have had mine for about 4 months so It was the last thing that I thought could have failed so soon. My Macbook is an early 09 so I assumed it was a software issue. Thanks again! My problem has been solved...for now.

  • SanctionOne Level 1 Level 1 (0 points)

    Okay,

     

    I originally posted a response to how I have solved this with my setup and ill repost it here...

     

    You have to unplug the power cable from the syncmaster... then plug in the mini diplay adapter... then do a "detect display" is system preferences to check to see if it's detecting it...  then simply close the lid to the laptop and plug in the power to the syncmaster... it will "detect" the monitor and it comes back every time for me now... I've dealt with this issue for over a year.... but it's how I get my external monitor back up every time.  Apple and Samsung need to get together and fix this but until then it's the only thing that has worked for me...

     

    However, people seem to still have issues following this so I have went ahead and put together a video as well...

     

    You can view the YouTube video I've made here... http://www.youtube.com/watch?v=41tfRsfNU0A

     

    This is what I have to do everyday to get my Macbook Pro to redectect/recognize my Samsung Syncmaster External Display....

     

    Hope this helps some people.

  • - Luthien - Calculating status...

    I'm having a similar issue with my early 2008 MBP since about two weeks.

    I always use it together with an external monitor; at work and home; I connect them with a DVI cable (this model MBP still has a large DVI external display port).

    The monitor at work is a HP Compaq LA2205wg, and at home I have a Benq G2420HDBL. Until two weeks ago both have always worked flawlessly.

     

    When I connected the HP monitor at work that morning I noticed that some application windows - such as Eclipse, but not the Finder! -  looked strange on the external monitor: a bit similar as when you view a TIFF file with the wrong endianness.

    I eventually logged in and out of my account and then everything looked normal again. Until later that day, when the display suddenly went black. And it has remained black ever since: both at home and at work. I tried other cables, yet another monitor, a PRAM reset. Nothing helped so far.

     

    I assumed that my MBP was just getting a bit old and it might be a hardware failure. It's four years old and I have used it very intensively: it's been on for about 14 hours a day in those four years. I have replaced some parts, like a faulty fan, and put a larger HD in last year.

     

    But I did notice that when I connect the external display it is being recognised: I can see it in the Display settings. It even recognises the make, model and resolution. I can see the mouse pointer moving off the screen of my primary display - into the black nothingness .

     

    In the console, there are a lot of lines such as this:

     

    23-4-12 11:13:07.623 AM Google Chrome: kCGErrorIllegalArgument: CGSGetDisplayBounds: Invalid display 0x3c0a1201

    23-4-12 11:13:07.623 AM Google Chrome: _NXGetScreenRect: error getting display bounds (1001)

    23-4-12 11:13:13.031 AM Finder: kCGErrorIllegalArgument: CGSGetDisplayAliasList: Invalid display 0x745e4385

     

    (just picking a few at random - there are many more of this sort)

     

    I had more or less settled into the idea that it was time to upgrade my MBP - but reading this and similar topics has made me wonder if it might be a software / driver related issue after all. Unfortunately, I don't remember if there was an update just before the screen went black.

    It'd be nice if I could get the external display back to work - even if just for the months until the new MBP comes out.

  • jkruells Calculating status...

    @SanctionOne

    Thanks a lot, that worked fine for me. Have done this whole procedure several times as a testing, it seems that the display is right now detected even when I leave the syncmaster plugged to power.

    Thanks again

     

    Jo

  • dillrepair Calculating status...

    YES.   EMGSILVA's  SOLUTION OF DOWNLOADING GFXCARDSTATUS WORKS FOR ME  SET TO DISCRETE WHEN CONNECTED TO EXTERNAL IF YOU HAVE THE SAME/SIMILAR SETUP AS ME...  I HAVE LATE 2011 15" MACBOOK PRO.   Thank you so much.   I'm really not sure why apple cannot simply release an update to address this if it is as simple as making sure your gfx card is discrete when connected to external.      As for the 13" macbook pro users i sympathize with your plight and since there is no discrete gfx card on these models... and i would try gfxcardstatus anyway as emgsilva describes above.. and links to here https://discussions.apple.com/message/16685778#16685778 

     

    an apple representative needs to tell me now why they couldn't have figured that out and told me about it when i first got this computer and was having the problem.    This appears to be simple... so why did i pay $2500 for the best macbook around and then have this persistent simple problem that i had to solve myself???

  • - Luthien - Level 1 Level 1 (0 points)

    It's getting weirder and weirder:

    I figured out that I can still use the VGA signal. If I hook up my external monitor using a DVI -> VGA adaptor, I can use it. The image is not as crisp as with DVI, but no big deal.

    This week I had an OS update (to 10.7.4) and because I think it's still possible that this is a software issue (in combination with this particular model MBP, 15-inch Early 2008; 2.4 GHz Intel Core 2 Duo; NVIDIA GeForce 8600M GT 256 MB) I tried after installing the update.

     

    And behold: DVI worked again. At least, for as long as it took to disconnect the VGA cable and get ready for work - and then the screen blacked out again.

     

    So it's back again to VGA.

     

     

    Sigh.

1 ... 7 8 9 10 11 ... 24 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (12)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.