Skip navigation

My iMessage shows my email not my number

243737 Views 72 Replies Latest reply: Apr 18, 2014 9:37 PM by Joseph The Jordanian RSS
  • Terid87 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2012 12:03 AM (in response to Katietherese)

    The post code for Australia is 0064

  • Katietherese Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2012 12:18 AM (in response to Terid87)

    Thanks    now hopefully I can get it to

    Fully work with iMessage. I turned it offf and now

    When I go to turn it on it just

    Won't verify my mobile number.

    Now there isn't even a spot to do so,

    By any chance do you know if I actually

    Need credit as well as an active wi-fi

    Connection to make it work

    Thanks for your help  

  • BenjiiiBurberry Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2012 7:07 AM (in response to Terid87)

    I need some assistance I'm still having the same problem I've went to setting>store>view apple I.d then view payment information and my billing address has my info but I don't still don't see my option to use my phone # as my apple I.d. I live in Ny so my zip code 11234 is for the specific area in brooklyn im located Shouldn't that be full zip?

  • zachkolk Level 1 Level 1 (20 points)
    Currently Being Moderated
    Apr 14, 2012 6:11 AM (in response to BenjiiiBurberry)

    I haven't read the entire post, but I know how to fix this (at least it worked for me). Settings>Messages>Recieve At>Caller ID, then select if you want people to see your Apple ID or your phone number.

  • Aaron Barna Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2012 2:17 PM (in response to Terid87)

    it didn't work for me.  I'm having same problem as above with my imessages being sent from my apple id email instead of my phone number.  There is no option to add my phone number under the "receive at" tab under imessage in settings.

  • drbriggs Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 6, 2012 2:51 PM (in response to M155qt)

    turn imessage off and on should re activate

  • Momdogzzzzz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 2, 2012 3:48 PM (in response to Terid87)

    Thank you - I did find that my home number was listed in the billing information.  I replaced with my mobile #, but the iMessage settings - "receive at" still showed email address option only.  I then turned iMessage option OFF, clicked it back on, and though it took a few minutes to "verify" my mobile #, it eventually worked.  Now my iMessages are linked to my mobile number.

     

  • ria.apo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2012 7:03 AM (in response to M155qt)

    do you know the complete areacode that i need to use in greece?

  • NOVAx24 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2012 10:33 PM (in response to M155qt)

    I am having this exact issue as well, with iMessage and with Facetime, in their Settings i can only see my email address but not my phone number as an option, there are no "Caller ID" options in the iMessage so i can ADD my number in. I have confirmed that in the "Store" Setting, my Apple ID has my mobile phone number, im in the USA so my number reads as (xxx)xxx-xxxx.

    PLEASE ANY HELP????

  • lmason48 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 20, 2012 12:15 PM (in response to muchostylez)

    Mine is similar to this. Mine has "you can be reached for messages at" then my email is blue but my phone number is grey'd out and i cannot click on it. And on my caller ID i can check my number but that does nothing

  • iorganutan Level 1 Level 1 (35 points)
    Currently Being Moderated
    Aug 1, 2012 8:56 PM (in response to Terid87)

    The Country code for Australia is +61, not 0061. The + depends from which country you are calling. Same with the NZ number above, which should read +64.

     

    For example, if calling from Australia to NZ, the + part is actually 0011, and from a landline you call 001164...., whereas from the UK to NZ it is 0064...

     

    Often when entering coutry codes online you (like in your Apple ID) you just enter 61 or 64, or for UK 44; never 0061.

  • RakheeB Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2012 8:58 AM (in response to M155qt)

    Hello

     

    I live in Antigua and use a local sim in my iphone 4s. I recently travelled to the UK and changed to an Orange Sim while there. On returning home, I replaced the orange sim with my old (local) sim. However, even after restarting several times, turning on and off iMessage and doing a network reset, my iMessage is still picking up my UK number and it is saying verifying.

     

    Please advise on how I can rectify this problem.

     

    Thank you.

  • Colefromsa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 5, 2012 8:17 AM (in response to Terid87)

    No 0064 is the code for Nz.. the code for Aus is 0061

  • Razak107 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2012 3:53 PM (in response to M155qt)

    Hi guys

     

    I had the same problem and it is easy to be solved

     

    what I did is that I went to my contacts and under my name I changed my phone number from HOME to iPHONE
    then turned off the iMessage and turned it on again .....And it worked !!!

     


    Cheers

  • Daizy1111111 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2012 11:59 AM (in response to M155qt)

    I had this problem after visiting Singapore and using a local SIM in my iPhone 4S. After returning all my settings seemed different and I had various issues with iMessage and FaceTime.

    But what worked was going to settings>messages>send & receive (it didn't show this option at first but rebooted phone and it seemed to show up when iMessage is switched on). My number was showing on the list but in grey and I wasn't able to select it. I clicked on apple ID and then "view account". I re-entered all my log-in details again and then went back to messages menu. My mobile number seemed to finally show up properly and I was able to select it as an option.

    I'm not sure why this worked as my apple ID details and password hadn't changed but after weeks of wanting to throw my phone out the window out of sheer frustration I'm just grateful I got there in the end!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.