Skip navigation

how do I delete my iCloud bookmarks and upload a new bookmark file

73376 Views 75 Replies Latest reply: Apr 8, 2014 4:06 PM by Jerome Krinock RSS
  • pjt2012 Level 1 Level 1 (0 points)

    Bookmarks got messed up using iCloud synch and a MB Air, an iPhone 4S and 2 iPad2s. Running 10.7.2 and 5.01.1.

     

    Solution:

    Disable the bookmark synch in the iCloud panel on the iPhone and iPads. Choose the option to delete the bookmarks on the devices - very important.

     

    On the MB Air, manually tidy up. Which for me consisted of holding down the delete button for about 3 minutes. Fun.

     

    Since the Air is still synched to the iCloud this tidied up the bookmarks there.

     

    Then re-enable the synch on the mobile devices. The bookmarks will replicate the set-up on the MB Air.

     

    I think I ended up in this mess because I tried the iCloud control panel for WIndows on a PC desktop. That messed up a lot of things I've abandoned the Windows side of the iCloud.

  • pullman Level 4 Level 4 (1,135 points)

    I also had problems with iCloud. I use a Mac Pro, a Macbook and an iPhone 4S, all running the latest operating systems.

     

    It seems the best way to overwrite iCloud's bookmarks is to have two Mac computers -- I couldn't get the below to work using one computer and one phone only.

     

    What I did was turn off bookmark synching in Sys Prefs > iCloud on both computers and on the phone.

     

    Then I deleted all bookmarks in Safari on both computers and on the phone.

     

    Then I turned on bookmark synching on the computers only.

     

    With Safari open on both computers, I checked that no bookmarks appeared in the bookmarks bar. I actually had to try a few times to delete bookmarks because it seems there was some old stuff in the iCloud "pipeline" which kept being synched to the computers.

     

    Eventually, however, the bookmark bar on either computer was nicely empty and clean. This is what I meant above - two computers synching empty bookmark bars seem to "flush" iCloud's bookmarks. I couldn't get this to work using one computer and the phone (ymmv of course).

     

    Then I turned on synching on the phone, waited a bit and checked that Safari didn't have any bookmarks.

     

    The next step may seem odd: I turned off synching on the Mac Pro before importing my bookmarks from an html backup. Because iCloud seems to synch continually, I wanted to avoid getting only some bookmarks synched while the Mac Pro was busy importing. Perhaps an unnecessary step.

     

    After the import, I verified that the Mac Pro's Safari had a complete set of the bookmarks in the bookmarks bar (the imported bookmarks end up under a separate "imported 2011-xx-xx" heading so I moved them manually to the bookmarks bar).

     

    Then I activated the Mac Pro's bookmarks synch in Sys Prefs. The message "Do you want to merge bookmarks with iCloud?" appeared and I clicked Merge (btw it is very odd how limited iCloud's functionality is in this respect).

     

    I checked on the Macbook and on the phone that Safari updated the bookmarks bar as the Mac Pro's bookmarks were "merged" with iCloud's empty set.

     

    Fwiw, hope it helps someone.

    /p

  • stoughnow Level 1 Level 1 (0 points)

    This is it.  Outsmart your iDevices.  Good job.  Worked for me.  Thanks.

  • Glen M Level 2 Level 2 (270 points)

    I recently decided to turn on iCloud in my Mac as I will be getting an iPhone soon. I wanted to get a head-start on how it works, so it will be quick and smooth when I get the iPhone. By merely activating iCloud (not owning any other devices), iCloud promptly rearranged my Bookmarks Bar to a point many months earlier. Recent important bookmarks were gone. I deactivated iCloud, and only because I had Time Machine running and I knew where to locate and restore the Safari file, was I able to fix it. I couldn't image any of my less-computer-savy friends and relatives trying to deal with this problem.

     

    This is a HUGE bug!! Based on other forums, countless postings, many months old, I don't know why Apple is allowing this to continue. Are they too busy with other, bigger, bugs?

     

    iCloud is the first Apple software/service that is far worse than anything I had seen from Microsoft recently. As such, it will be a very long time before I try iCloud again.

     

    I understand having a bug, but not promptly fixing it is irresponsible and terrible customer service.

    Perhaps worse, now, I must babysit everything from Apple.

    ...and seriously second rethinking the iPhone. If I am too apprehensive to sync it to my Mac, then there is no difference what phone I get. I could save a lot of money with other phones and services.

  • TheKnowledgeSeeker002 Level 1 Level 1 (65 points)

    This seems crazy; there must be a fix for this.

     

    Apple used to have a free live chat service for MobileMe (free presumably as MobileMe was a subscription service).

     

    Does anyone know whether free live chat is still available and whether it can be used for iCloud?

     

    My experience of LiveChat was that it often resulted in a fix becasue a 'real person' was on the end of the line who could talk you though possible fixes and check your account to see what was happening.

     

    The idea of having to pay for support for a service I'm already paying for and which is bug-ridden seems totally wrong!

  • Gordon Shamway Level 1 Level 1 (45 points)

     

    I found a solution which is rather simple.

     

    Understand that iCloud only keeps a coply of your local Safari Bookmarks folder:

    Push: Mac -> iCloud -> iPhone

     

    Therefore: turn off bookmark syncing on all devices. Clean up the bookmarks in Safari. Close Safari. Locate the Safari folder inside the homefolder Library. Drag it to the desktop. Start Safari -> Bookmarks should be blank. Let it sync to iCloud. Close Safari, move the Safari folder back to the home folder library.

    Start Safari. Edited bookmarks are back in place. Let it sync to iCloud.

     

    Open up iTunes. Force sync your iPhone with the new/edited bookmarks.

     

    Any comments welcome.

     

  • rpaloalto Level 1 Level 1 (25 points)

    THANK YOU! Gordon Shamway

    Gordon Shamway wrote:

     

     

     

    I found a solution which is rather simple.

     

    Understand that iCloud only keeps a coply of your local Safari Bookmarks folder:

    Push: Mac -> iCloud -> iPhone

     

    Therefore: turn off bookmark syncing on all devices. Clean up the bookmarks in Safari. Close Safari. Locate the Safari folder inside the homefolder Library. Drag it to the desktop. Start Safari -> Bookmarks should be blank. Let it sync to iCloud. Close Safari, move the Safari folder back to the home folder library.

    Start Safari. Edited bookmarks are back in place. Let it sync to iCloud.

     

    Open up iTunes. Force sync your iPhone with the new/edited bookmarks.

     

    Any comments welcome.

     

     

  • jdm123 Level 1 Level 1 (0 points)

    At last a solution - well done 'pullman'....much appreciated

  • Scott Young Calculating status...

    Perhaps this is just another way to do what Gordon Shamway described:

    1. Turn off Bookmark synching on your iPhone or iPad under iCloud

    2. Connect iPhone or iPad to your computer with USB, turn on iTunes

    3. Press the "Info" (between "Summary" and "Apps" buttons) when you select your Device

    4. Scroll down to enable sync of bookmarks and just below to replace one time the bookmarks on the iPhone or iPad

    5. Sync

    6. Your iPhone or iPad now has the set of the bookmarks that were in your computer's Safari

    7. Turn Bookmark synching back on your iPhone or iPad (I can't predict whether or not synching will now be automatic over iCloud but you can use this manual approach everytime you desire to update your device's bookmarks)

  • Lord Of The Weirdos Calculating status...

    Ok. I found out how to do it.

     

    Here are the steps:

    1. Remove all iPhones iPads computers from your iCloud bookmark syncing.

     

    2. Fix your bookmarks.

     

    3. Export your bookmarks (always good to have a backup anyways)

     

    4. Turn on iCloud bookmarks on the computer you made the backup on. Make sure you have an Internet connection.

     

    5. Wait for a minute or so, depending on the amount of bookmarks.

     

    6. Delete all bookmarks on that one computer.

     

    7. Wait a minute or so, then restore your backup you just made.

     

    8. Wait a minute or so.  It will delete, then add the new backup file as the master.

     

    9. Turn on one other devices iCloud bookmark syncing, check.  If ok you did it right.

  • McCartman Level 1 Level 1 (0 points)

    Yours is the correct way. As per instructions already posted, turn off bookmark sync on mobile devices and choose to delete from device. Then, on the "master"computer, export for safety reasons, clean them up, but do NOT shut off the sync on that computer. As you clean your bookmarks up on the "master", the changes are being synced to iCloud. Once the master is cleaned up, so will everything in iCloud. Then go in on the mobile devices and turn sync back on. This did the trick for me - after seeing duplicates for months on my iPhone.

     

    I just have an iMac and an iPhone. If you have more than one computer, you'd probably have to turn sync off and deleted all bookmarks on that device before working on the "master". A second (or more) computer would be treated just like the iPhone or iPad using this method.

  • Peter Berglund Calculating status...

    I followed the method outlined in this blog post. It worked for 100,000+ iCloud duplicates.

  • ROGER BURTON Calculating status...

    This will hopefully help me tidy up my bookmarks thanks chaps but when I started syncing bookmarks with icloud I now have all my wife's (another user account) bookmarks on all my devices ... any thoughts ?

     

    Best Roger

     

    (I started a new thread before I discovered this one, sorry, hope that's not a problem) ?

  • Ned1 Level 1 Level 1 (0 points)

    Did you ever figure out how to clean up your bookmarks versus your wife's bookmarks?  I'm sure this has to do with the Calendar problem across accounts, too.

     

    Ned

  • ROGER BURTON Level 1 Level 1 (30 points)

    Hi Ned - well I did sort it out but it was a while ago and I'm not quite sure of the process, I think it involved simply turning off iCloud in my wife's user account (she doesn't have any other 'devices') - and is this did the job I didn't pursue the problem further so, actually I'm still not sure if you can use iCloud for each user account !

     

    Good luck Roger

1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.