Skip navigation

Buggy Buttons and Random Reputation Points: Trouble-shooting?

1964 Views 27 Replies Latest reply: Jun 20, 2013 10:44 AM by BDAqua RSS
1 2 Previous Next
léonie Level 8 Level 8 (46,550 points)
Currently Being Moderated
Apr 12, 2012 1:12 PM

Hello,

does anybody else also have a problem with truculent "Solved" and "Helpful" buttons that are acting up and randomly marking the wrong posts as "solved" or "helpful"? Half of the time when I try to mark a post as "helpful" and press the button, the page immediately, magically scrolls up to a  different post, and the wrong answer will be marked, before I can react and stop this. At first I found that quite funny, for if there often are so many helpful answers to choose from, it didn't matter much, but last week this scary scrolling caused my own thank-you post to be marked as "solved" - oh, how embarrassing !

 

Only, I have no idea how to trouble-shoot this bug; I see no way to experiment with marking post, for I really cannot start a test series of bogus posts and ask people to answer to be awarded random points - who would volunteer? So what can I do to explore this? I don't think the trackpad is faulty; my MBP is only half a year old, and the trackpad works fine in all other Applications; I see this randomness only when posting in the Support Communities. Has anybody else experienced this magic mouse? Any suggestions are very welcome, for this bug keeps me from posting some questions I have.

 

Regards

Léonie

 

Safari,

MacBook Pro, Mac OS X (10.7.3), 2.4 GHz I.Core i7, 16GB RAM, 500GB
  • ScotMij Level 7 Level 7 (20,635 points)

    I have posted very few questions of late but I have not experienced your problem. I mainly use a Magic Mouse. I do have a TrackPad attached to one iMac but rarely use it. My TP has misbehaved so right now it is not paired.

  • ScotMij Level 7 Level 7 (20,635 points)

    Unexpected jumps on occasion but my memory for details is not good. The TP has been idle for many weeks. I thought at one point that Bluetooth was getting confused and the iMac kept losing the TP, so I gave up. I may try it again.

  • rccharles Level 5 Level 5 (5,150 points)

    You could create another id and set in your post that this was far testing out the jumping solved issue.

     

    Robert

  • b noir Level 9 Level 9 (71,990 points)

    Does the same effect occur if you post using Firefox rather than Safari (or vice versa), leonie?

  • rccharles Level 5 Level 5 (5,150 points)

    1) Actually, clicking on solved or helpful for a thread you created from your id doesn't award yourself points.

     

     

    2) I suggested creating a new id. Call it testLeonieDF.  So what if it gets a few points.  An id with a low  level of points will not show up anywhere. 

     

    3) I thought there whas a test forum/community?  I could not find it.

     

    Robert

  • b noir Level 9 Level 9 (71,990 points)

    What is weird - both times I accidentally marked my own posts, I found that the edit of my last post had not been finished on the server: When I pressed the reply button below the the post of the poster to whom I wanted to award points, a recovered version of my "thank you" letter was opened. So maybe the wrong buttons receive the "hit" signal, if you award points while the editor window is still open - or the server thinks the editor window is still open?

     

    That's a nice catch.

     

    More thoughts in the interests of narrowing in on the circumstances producing the problem. Has the issue been cropping up during the 15 minutes after making the edit? Or does it happen just so long as there has been an edit by you at some stage during the lifetime of the topic?

  • b noir Level 9 Level 9 (71,990 points)

    Thank you for taking an interest in this.

     

    That's okay ... mostly I'm hoping that we can generate enough info about the symptoms so that the Hosts can properly get their teeth into the issue.

     

    It's sounding a bit like a server/display lag thing ... the display isn't reflecting the current status of the topic on the server (due to the edit in process). So the thing you're clicking on in the display of the topic isn't necessarily aligned with the current status of the topic, and the wrong instruction gets sent to the server (and a different post than the one you intended gets the helpful or solved).

     

    Speculation of course ... but if that's what is going on (as a workaround), it might be worth refreshing the display of the topic (F5 or the Mac equivalent) prior to making a helpful/solved assignment (if you've edited a post in there recently). Fingers crossed, that'll bring the display of the topic back into accordance with the current status of the topic on the server, and then the helpfuls and solveds will land on the correct targets.

     

    Another possibility (if you've got email notifications up and running) is trying to use the helpful/solved controls in email notifications for replies to assign points rather than using the ASC GUI in the browser ... do the email-generated helpfuls/solveds seem to go to the right place if you've edited a post in the topic recently? Or do they displace as well?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.