2 Replies Latest reply: Apr 15, 2012 8:43 AM by Texas Mac Man
Bpeacful Level 1 Level 1 (0 points)

I have a MacBook 10.4 and I would like to update my Firefox and Safari Browsers, but I get error messages stating that I need 10.7 or higher. Is there a way to update browsers on an older Mac?