Skip navigation

Can't copy text in a preview-document opened in Safari.

1651 Views 10 Replies Latest reply: Apr 9, 2013 2:00 PM by ModestoTish RSS
tiba Calculating status...
Currently Being Moderated
Apr 16, 2012 6:28 AM

Since the last upgrade of safari (I think) I can't copy text in a preview document opened in Safari. Can I adjust anything in the preferences or is there any other solution to get the normal behaviour back?

Safari, Mac OS X (10.7.3)
  • Linc Davis Level 10 Level 10 (107,850 points)
    Currently Being Moderated
    Apr 16, 2012 6:40 AM (in response to tiba)

    Quit Safari.

     

    Open the Library folder in your home folder as follows:

     

    If running Mac OS X 10.7 or later, hold down the option key and select Go ▹ Library from the Finder menu bar.

     

    If running an older version of Mac OS X, select Go ▹ Go to Folder… from the Finder menu bar and enter “~/Library” (without the quotes) in the text box that opens.

     

    Delete the following items from the Library folder:

     

    Caches/com.apple.Safari/Cache.db

    Preferences/com.apple.quicktime.plugin.preferences.plist

    Preferences/QuickTime Preferences

     

    Relaunch Safari and test.

  • Linc Davis Level 10 Level 10 (107,850 points)
    Currently Being Moderated
    Apr 16, 2012 7:19 AM (in response to tiba)

    Does that mean you couldn't delete the files, or you did delete them and there was no change?

  • Linc Davis Level 10 Level 10 (107,850 points)
    Currently Being Moderated
    Apr 16, 2012 10:38 AM (in response to tiba)

    Please give more details of the problem. What kind of content are you having a problem with, and what exactly happens when you try to view it?

  • Linc Davis Level 10 Level 10 (107,850 points)
    Currently Being Moderated
    Apr 17, 2012 6:13 AM (in response to tiba)

    In the Finder, select Go ▹ Go to Folder... from the menu bar, or press the key combination shift-command-G. Copy the line of text below into the box that opens, and press return:

     

    /Library/Internet Plug-ins/AdobePDFViewer.plugin

     

    If a Finder window opens with that item selected, delete it, then quit and relaunch Safari. Otherwise post again.

  • ModestoTish Calculating status...

    Hi Linc. I've tried all of the above to no avail. I rely heavily on the ability to copy from a web-based database generated PDF into a separate web-based database.

     

    When the (cfm) PDF opens in Safari, I can copy once, and paste, but then, once I paste, I am unable to copy new PDF info from a different report. It continues to paste from the first copy action. Whatever this new functionality is, it really has thrown my workflow into a tailspin. Copying and pasting from Safari PDFs used to be so painless.

     

    Running Safari 6.0.3 on Mac OS 10.7.5

     

    I also recently upgraded Adobe CS which included Acrobat X (10.1.6)

     

    I completed all of the above suggestions. I would like to revert to a mode wherein Acrobat is not meddling in my Safari activity.

     

    Any insights would be heeded. Thanks!

  • ModestoTish Level 1 Level 1 (0 points)

    Oops - fixed it myself. Was looking in my personal applications file, instead of the system file. Thanks anyway!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.