Skip navigation

safari will not let me save pdf

4681 Views 10 Replies Latest reply: Jun 2, 2012 8:02 AM by thinkirish RSS
isvanson Calculating status...
Currently Being Moderated
Apr 16, 2012 9:34 PM

im not sure but Safari 5.1.5 will not let me save pdf?

MacBook Air, Mac OS X (10.7.3)
  • John Galt Level 7 Level 7 (33,090 points)
    Currently Being Moderated
    Apr 16, 2012 9:59 PM (in response to isvanson)

    Are you using Safari's File > Print menu, selecting the PDF button at the lower left, and selecting "Save as PDF..."?

     

    Screen Shot 2012-04-17 at 12.58.46 AM.png

     

    If that isn't working I don't know what could be wrong.

  • Wildwood Guy Calculating status...
    Currently Being Moderated
    Apr 29, 2012 4:03 AM (in response to John Galt)

    I am also using Safari 5.1.5 and have the same issue.  Normally, I would simply use Command+S and could save that way, but that option no longer works.  I don't see the option under the pull-down menu for Save as PDF... however, there is a (vanishing and dark-colored) tool bar INSIDE the window I am trying to save (near the bottom of the window) with a file-folder option.  I was able to save the page as a PDF file to my Finance Files... but did not have all the same options for WHERE I wished to save a file.  (Well... at least, I could not, on this simple option, locate any other location to store the file.)

     

    Thanks for any assistance.

  • Hensha Gansbourg Calculating status...
    Currently Being Moderated
    May 1, 2012 1:19 PM (in response to isvanson)

    I am also having this problem. I am on OS 10.7.3 and have Safari 5.1.5.

    I used to be able to use Save as and download PDF's to my computer. I had trouble last week and thought it was only one file, but I am having the same issue with every file I want to save as a PDF. I also took the advice of Jon Galt, but it produced a blank page. Will someone at Apple please find a solution to this problem.

    Thanks for any assistance

  • ezollars Level 2 Level 2 (255 points)
    Currently Being Moderated
    May 1, 2012 4:21 PM (in response to isvanson)

    A couple of thoughts.  It appears there may be two issues--one is saving a PDF that Safari has loaded in the browser window, while the second (which is the one John was talking about) is saving a standard HTML page as a PDF document.

     

    For the PDF loaded in Safari:  Is it possible you might have loaded up a third party PDF ready (like Adobe Acrobat Reader) that might have installed itself to handle PDFs in Safari?  I've not checked, but wonder if that might disable the "normal" Safari options that would be available with Preview.

     

    If the PDF is displayed, you should get a black box at the bottom of the window if you place the mouse cursor there while Safari has focus.  While not perfect, if you select the far right icon it will save the PDF to your Downloads folder.  If you select the second from the right, it will load the PDF into a stand-alone instance of your standard PDF reader and from there you would be able to save the file anywhere you want using a Save As command in the reader.

     

    For HTML to PDF--that is controlled with the Print command, using the option at the lower left of the print dialog to print to PDF (which is the menu John showed you).  That works for all files *except* PDFs (since printing a password protected PDF to a new PDF would effectively strip the password and would also strip out other features of the PDF, you aren't allowed to print PDFs to PDF).

  • leighfromelderslie Calculating status...
    Currently Being Moderated
    May 5, 2012 1:55 AM (in response to isvanson)

    I've been having the same problem since loading Lion. With a pdf document in the Safari browser that I wanted to save, the "Save As" menu option didn't work and told me the file could not be saved as a pdf (even though it was one).

    After reading the responses above I had a bit of a fiddle and found this sequence works for me.

     

    Back to the pdf file displayed in the Safari window.

     

    At the bottom centre of this window a shaded bar appeared when I placed my cursor there. It's the one that lets you increase or reduce the displayed size and also scroll through the pages. On the far LEFT of this bar is a symbol of a floppy disk that usually indicates a "save" function. If I press that I get a window that lets me rename the file if I want to and select where I want the file saved and the format. I used "Adobe PDF Files".

    Then hit "Save" and bingo! there it is!

  • Mike Turner Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 9, 2012 5:47 AM (in response to leighfromelderslie)

    Thank you. This issue has been a problem for me for a while but I have only just got around to finding a solution. Your response worked prefectly for me.

  • RRFS Level 5 Level 5 (4,425 points)
    Currently Being Moderated
    May 9, 2012 8:18 AM (in response to isvanson)
  • slicebogey Calculating status...
    Currently Being Moderated
    May 13, 2012 8:23 AM (in response to leighfromelderslie)

    Thanks alot, this worked for me.

  • sassyfraz Calculating status...
    Currently Being Moderated
    Jun 1, 2012 8:43 AM (in response to slicebogey)

    I had this problem. My solution was to be sure that I had the latest Adobe Reader installed. Clicking the icon for "save" in the menu bar of Adobe Reader will allow you to save the pdf anywhere you want to (I use desktop).

  • thinkirish Calculating status...
    Currently Being Moderated
    Jun 2, 2012 8:02 AM (in response to leighfromelderslie)

    Perfect...Thanks.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.