Skip navigation

Help upgrading OS X 10.4.11 to whatever is possible?!

1777 Views 8 Replies Latest reply: Apr 17, 2012 9:40 AM by BDAqua RSS
lisaatcreativesofa Calculating status...
Currently Being Moderated
Apr 12, 2012 2:07 PM

I would like to upgrade to a later operating system, as things are starting to not work in 10.4.11.

However it looks like without an Intel Processor I am only able to upgrade to 10.5.

 

Is this true and if so is there any point or is 10.5 out of date now too?

Is my computer just so old its not worth bothering (I don't really have funds to buy a new one so I feel Im a bit stuck!)

 

Power Mac G5, Mac OS X (10.4.11), Dual 2.5 GHz PowerPC G5. Memory 2.5 BG DDR SDRAM

 

I am a bit of a dinosaur I admit! The reason I have not upgraded so far is I always seem to destroy key functions when I do anything technical!

Thanks

Power Mac G5, Mac OS X (10.4.11), Dual 2.5 GHz PowerPC G5
  • Kappy Level 10 Level 10 (220,980 points)

    Yes, that is correct. Leopard is the highest version of OS X to which you can upgrade. Leopard is going to become unsupported later this year, so, yes, it is out of date. It is also expensive to buy - $129.00 or more - if you can find it. It's no longer available from Apple.

  • BDAqua Level 10 Level 10 (114,685 points)

    Leopard requirements/10.5.x...

     

        *  Mac computer with an Intel, PowerPC G5, or PowerPC G4 (867MHz or faster) processor

     

    minimum system requirements

     

        * 512MB of memory (I say 1.5GB for PPC at least, 2-3GB minimum for IntelMacs)

        * DVD drive for installation

        * 9GB of available disk space (I say 30GB at least)

    Classic/OS9 Apps no longer supported.

    Trouble is Apple no longer sells it, check eBay & such for the Retail version, not the Gray Discs...

    http://www.ebay.com/sch/i.html?_nkw=mac+os+x+leopard+retail+10.5

     

    List of Applications Not Compatible with Leopard...

    http://guides.macrumors.com/List:Applications_Not_Compatible_with_Leopard

  • Texas Mac Man Level 8 Level 8 (44,205 points)

    Mac OS X 10.5 Leopard installation system requirements

    http://support.apple.com/kb/TA24950

     

    Leopard is no longer available at the Apple Store but may be available by calling Apple Phone Sales @ 1-800-MY-APPLE (1-800-692-7753).

     

    If you can't obtain a retail install DVD from Apple, look on eBay or Google the installer part numbers to possibly find at an on-line store. Here's what to look for:

     

    MB427Z/A  Leopard 10.5.1 install DVD

    MB576Z/A  Leopard 10.5.4 install DVD

    MB021Z/A  Leopard 10.5.6 install DVD (single user)

    MB022Z/A  Leopard 10.5.6 install DVD (5-user family pack)

     

    Installing Mac OS X 10.5 Leopard

    http://support.apple.com/kb/HT1544

     

    Mac OS X 10.5 Leopard Installation and Setup Guide

    http://manuals.info.apple.com/en/leopard_install-setup.pdf

     

    After you install the base 10.5, download & install the 10.5.8 combo update at http://support.apple.com/downloads/Mac_OS_X_10_5_8_Combo_Update

     

    The DVD should look like this

    leopard.jpg

    Caution - Leopard does not support classic mode. So, if you currently open OS 9 apps in classic mode, you won't be able to do this if you upgrade to Leopard.

     

     Cheers, Tom

  • Klaus1 Level 8 Level 8 (43,310 points)

    lisaatcreativesofa wrote:

     

    Thanks for your reply. When you say it will be unsupported later this year, what does that actually mean in real terms? Does it mean that updates of various softwares will no longer work with it, like the problems I am starting to experience now. eg. I cannot upgrade to the latest version of firefox etc. So would I perhaps be buying myself just a few months more time before I have the same problems again? Thanks.

     

    IMO Leopard has not been supported for the past year, in terms of security updates etc, but that does not stop it working!

     

    You (and I) can only run applications that are written for PPC Macs, and they will continue to run as well.

     

    As for Firefox, there is PPC version called TenFourFox, which actually works better with some Flash sites than Safari:

     

    I cannot watch flash videos on the BBC website or on BBC iPlayer, although all other flash videos (YouTube for example) are fine.

     

    For reasons that passeth all understanding, they work with the PPC version of Firefox, called TenFourFoxG5.app, once you have anabled plug-ins, as it does not natively support Flash.

     

    You can download TenFourFoxG5 from here:

     

    http://www.floodgap.com/software/tenfourfox/

     

    Now for the intersting bit: TenFourFox, like Firefox, does not support most plug-ins. Unless you are prone to headaches (in which case don't) you can read about that here:

     

    http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

     

    But there is a workaround!

     

    Open TenFourFox and type in the address bar: about:config (no spaces) and click return. This gives you a warning that it might harm the application. Ignore that and click on 'I'll be careful, I promise' and you get the config file that you can edit - with great care.

     

    Look/search (scroll down) for: tenfourfox.plugins.enabled

    Set it to true. (Double click it to toggle it)

     

    Now close TenFourFox, open it again, and Flash will now work, as it now uses the plug-ins that Safari has stored.

     

    I am using Flash 10.1.102.64 in TenFourFox and it works just fine.

     

    You are correct about Skype. Skype (v.5 or later)  is for Intel Macs only.

     

    The version for PPC Macs is v. 2.8.0.866 which you get from this link:

     

    http://en.softonic.com/author/skype

     

    Just scroll down until you find it, or possibly this direct link will get you there a bit quicker:

     

    http://www.skype.com/go/getskype-macosx-2.8.dmg

    iMac iSight G5 2.1 GHz, QT Pro 7.7, Mac OS X (10.5.8), iLife 9 but iMovie 6, Safari 5.0.6
  • BDAqua Level 10 Level 10 (114,685 points)

    Good luck with it, thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.