Skip navigation

Quicktime Pro 7 refuses to launch independently after installation of AVID MC7 / Sorenson Squeeze

1115 Views 9 Replies Latest reply: Apr 19, 2012 2:21 PM by b noir RSS
JSusi Calculating status...
Currently Being Moderated
Apr 17, 2012 9:35 PM

Hi guys,


Hopefully someone knows a fix for this.


After installation MC7 and Squeeze, i can no longer launch QT / QT Pro. The only way i can play .mov files is via iTunes, which for me is less than desireable. So the codec is obviously there.


Please note that QT 7 (non pro) was working fine prior to installing Avid & Sorenson.


I've tried 'repairing' QT by downloading the file, but even after the repair it still refuses to launch.


Also, QT is non longer listed in the 'open with' options... Please help!

Windows 7 home x64 (latest ver.)

x6 Phenom 945

8GB Ram

GTX 560 ti

  • b noir Level 9 Level 9 (71,990 points)

    Could you walk us through what happens when you try to launch the Player?


    If you get an error message, let us know what it says. (Precise text please.)


    If you don't get an error message, let us know whether or not a button for the QuickTime Player appears in your task bar (even though the player itself doesn't appear).

  • b noir Level 9 Level 9 (71,990 points)

    Good catch!


    I must note that when i launch QT from the start button and it prompts the user account control popup, i notice the target is in 'Program Files - Quicktime Alternative.'


    It'll probably be a conflict with QuickTime Alternative (It's a third-party chop-down of QuickTime) and the standard QuickTime Player.


    Head into your uninstall a program control panel. Uninstall QuickTime, then uninstall QuickTime Alternative. Now try reinstalling the QuickTime Player:



    Does the player launch for you now?

  • b noir Level 9 Level 9 (71,990 points)

    Although i have lost my 'pro'status.


    Did you make a note of your Key and Name (precisely as it appeared in the registration tab) prior to the uninstall? (Sorry, forgot to remind you about that.)


    If not, the following document might be of some assistance with retrieving the key:


    QuickTime Pro Key: Retrieving a lost key


    it's giving me a ''qt_cf.dll missing from link library.


    Doublechecking ... it's saying qt_cf.dll, not QTCF.dll? (QTCF.dll is the standard name for the dll in a QuickTime installation.)

  • b noir Level 9 Level 9 (71,990 points)

    many thanks.


    QuickTime componentry is 32-bit rather than 64-bit. So if you've got a copy of the QTCF.dll, try stashing it in SysWOW64 rather than System32. Any better luck with Sorenson? If so, does the QuickTime Player still launch?

  • b noir Level 9 Level 9 (71,990 points)

    You're welcome!


    Just one further thought. Best to keep a note that you've got a QTCF.dll down in SysWOW64, just in case you ever need to do a QuickTime Player update. The QuickTime Player installer won't "know" that there's a QTCF.dll down there, so it won't update it ... and if you get a mismatch between the version in SysWOW64, and a newer version in the standard location in \Program files (x86)\QuickTime\QTSystem\, there's scope for another sort of launch error with your QuickTime Player.


    If you run into trouble with the Player launching after a QuickTime update in the future, try replacing the QTCF.dll in SysWOW64 with the newer version of the dll in \Program files (x86)\QuickTime\QTSystem\.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.