7 Replies Latest reply: Apr 25, 2012 1:43 PM by Ralph Johns (UK)
greyhatguy Level 1 Level 1 (0 points)

For some reason when I send a message through Yahoo (only client I really use on Messages Beta) my links break.

 

It's like they code themselves multiple times. For example it would look like:

(I type): www.google.com
(They receive): <a href="www.google.com>www.google.com</a>

 

The end user receives the entire line of code as a blue link - from <a href to </a>. Obviously it's frustrating for them to fix every link I send them.

 

Is this a global setting? I can't find an option that looks like it would disable this.


MacBook Pro, Mac OS X (10.7.3)
  • 1. Re: Links breaking
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    HI,

     

    I have not tried to send plain text Links in the Yahoo Buddy List.

     

    I will not be able to test until the weekend.

     

     


    10:15 PM      Thursday; April 19, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 2. Re: Links breaking
    greyhatguy Level 1 Level 1 (0 points)

    Have you had a chance?

    I'm still sending broken links and it is very annoying.

  • 3. Re: Links breaking
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    From iChat 6 in Yahoo to Yahoo for Mac running in Snow Leopard I do not get the symptoms you describe.

    All URLs in plain text show up as active links  but just plain text.

     

    I will boot into Messages (actually another OS version that has Messages Installed.

     

     

     


    8:50 PM      Wednesday; April 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 4. Re: Links breaking
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    Sending in Messages does seem to produce both the URL as plain text (but an active link) as well as the same info contained by the so called square brackets.

     

    An example

     

     

    https://discussions.apple.com/index.jspa/index.jspa?categoryID=1 <https://discussions.apple.com/index.jspa/index.jspa?categoryID=1>

     

     

    The software here shows this as two lines as I type  (I expect it to be posted differently)

     

    If I actually type something and Format that as a Link (CMD + K) then I get both at the Yahoo for Mac end.

     

    Example

     

     

    Sending text
    <https://discussions.apple.com/index.jspa/index.jspa?categoryID=1>

     

     

    In Messages this looks like the "Sending text" in the example (two words that are an active link)

     

    It does seem that there have been changes to the Yahoo Plug-in.

     

    I can't find anything that changes this behaviour.

     

     

     


    9:13 PM      Wednesday; April 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 5. Re: Links breaking
    greyhatguy Level 1 Level 1 (0 points)

    It does seem that there have been changes to the Yahoo Plug-in.

    So does that mean there's an update for Messages Beta coming? Or how do we let them know about the bug?

  • 6. Re: Links breaking
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Thanks for the points

     

     


    9:33 PM      Wednesday; April 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 7. Re: Links breaking
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi.

     

    Although the Messages beta is written on the iChat engine it does not seem to have been added to the iChat Feedback page  (http://www.apple.com/feedback/ichat.html)

     

    (this page has never been fully up to date with OS or iChat versions).

     

    It seems that the Developer team may be watching this Forum about issues that people are describing.

     

    Some people have been adding links to the Bug Reoprt site but you have to register as a Developer for that.

     

    In the past Apple have continued to produces Updates for the current OS even if they have already announced the next OS.

     

    Having said that OS X 10.4 got as far as OS X 10.4.11 whereas Snow Leopard (OS X 10.6) only got to OS X 10.6.8

    Lion may get as far an OS X 10.7.4 before Mountain Lion comes out.

    It may or may not contain updates to the Messages Beta.

     

     


    9:43 PM      Wednesday; April 25, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously