4 Replies Latest reply: Aug 26, 2012 12:07 AM by mat060
whizzo Level 1 Level 1 (15 points)

Hi all -


My Apple TV2 has recently stopped receiving a functioning IP address when connected via Ethernet to my Airport Extreme. Instead, it self-assigns a 169 address (when the ATV2 even recognizes the device is connected via Ethernet at all, that is). The DNS field is blank when this occurs.

 

I suspect the Ethernet port has gone bad. It is covered under warranty - will the Apple Store genius bar be able to replicate this issue and replace this ATV2?

 

thanks -

 

Michael

  • 1. Re: Ethernet self-assigned IP on ATV2?
    Winston Churchill Level 10 Level 10 (81,980 points)

    Try restarting the router and the Apple TV.

  • 2. Re: Ethernet self-assigned IP on ATV2?
    whizzo Level 1 Level 1 (15 points)

    Thanks for the suggestion. As it happens, I have done both multiple times, including soft/hard reset of both (and getting a new AEX router yesterday) as well as physically unplugging cables and re-inserting. Also switched ports/cables - no luck. The other wired peripherals in the AEX (DVD player, VOIP adapter) work just fine. Only ATV2 is self-assigning IP address.

     

    Only happens with wired Ethernet. Wireless works fine - ATV2 gets an IP address and works fine that way. All this leads me to think that the wired Ethernet port has been fried on the ATV2.

  • 3. Re: Ethernet self-assigned IP on ATV2?
    Loren Ryter Level 2 Level 2 (495 points)

    Same issue.

  • 4. Re: Ethernet self-assigned IP on ATV2?
    mat060 Level 1 Level 1 (0 points)

    Same issue here with my ATV2! I actually tried with another Apple TV3 to make sure it's not the router and it got a correct IP and internet access. Getting back to the ATV2, same router, same configuration, same cable, the ATV2 does not get a valid IP, it just get a 169.254.*.*. It actually some times it does not even turn the router led on, as if the cable wasnt plugged at all. I tried in different router ports, same results.