Skip navigation

iCal no longer displaying delegates

15217 Views 27 Replies Latest reply: Jan 28, 2013 9:24 AM by NoreenB RSS
1 2 Previous Next
CavemanCooking Calculating status...
Currently Being Moderated
Apr 18, 2012 3:42 PM

Until a few hours ago, I had several Google Calendar delegates synced with the iCal app on my iMac.  Now, only one delegate will show up in my list ... all the others are still there on my Google Calendar, and all the delegates show up fine on my phone.

I have tried deleting my CalDAV account and have cleard the library/calendars folder and relanuched iCal, but still only the one account will show up.  PLEASE help ... Ineed my desktop calendar!


iMac, Mac OS X (10.5.8)
  • panettore Calculating status...
    Currently Being Moderated
    Apr 19, 2012 7:54 AM (in response to CavemanCooking)

    Same issue here. Just to point that out, I'm using iCal 3.0.8 on a Macbook late 2008 with Mac OSX 10.5.8.

  • panettore Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 19, 2012 8:01 AM (in response to panettore)

    And there seems to be a similar issue discussed in this thread:


  • Stace Felder Calculating status...
    Currently Being Moderated
    Apr 19, 2012 1:51 PM (in response to CavemanCooking)

    Same issue: multi calendars in iCal as delegates, all but one have disappeared.  Running 10.5.8 and iCal 3.0.8.


    Interesting to note: in addition to the affected account, I have replicated this issue with new user accounts and new caldav accounts on both this machine and another also running 10.5.8 and 3.0.8.  Accounts on a 10.6.8 machines with iCal 4.0.4 seem to be fine, not dropping delegates from existing accounts and seeing/syncing all delegates for new accounts.


    Bottom line is that I don't think it's an issue at our end; rather something changed at Google's and hopefully it will be corrected soon.

  • Salix11 Calculating status...
    Currently Being Moderated
    Apr 20, 2012 7:03 AM (in response to CavemanCooking)

    Hi guys, same thing happended to me. There is a great, free program that syncs your google cal and your ical. It was so easy to set up. You download it free, put in your google account and password and that was it. Works great and no more delegates.

    Here is the link:

  • panettore Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 20, 2012 7:15 AM (in response to Salix11)

    Calaboration seems to do the job. It's just frustrating that you have to use such an old fix...

  • Stace Felder Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 20, 2012 7:27 AM (in response to Salix11)

    My understanding of Calaboration is that it's a (really old) way of adding read-only calendars.  In my case, anyway, I'm able to add read-only calendars without issue.  It's the adding of writable calendars - through the delegates process - that's posing problems.


    Anyone had different experence?

  • smsuch Calculating status...
    Currently Being Moderated
    May 4, 2012 11:47 AM (in response to CavemanCooking)

    I'm having the same issue... it only shows the most recent calendar i've created on google calendar, but doesn't show any of the other calendars under delegates....


    Is there a fix for this??? I really want to keep using iCal if possible

  • CompComp Calculating status...
    Currently Being Moderated
    May 9, 2012 5:34 PM (in response to CavemanCooking)

    (re: write capabilities)


    Yes, I found this to be the case as well:

    I applied the workaround (using calendar IDs) and was able to successfully add all my (actually my client's) secondary calendars to iCal with read/write access.  But the primary calendar--whos ID is just the user's Google login--only comes readonly.


    In this case the user has 8 calendars so they got 7/8 of a solution, which turned out to be good enough in this case.  But clearly Google needs to fix something...unless they intend to simply drop all support for iCal 3.x.   Goodbye Leopard?


    p.s. thanks for the great workaround!

  • chipmunk6 Calculating status...
    Currently Being Moderated
    May 11, 2012 9:23 AM (in response to CompComp)

    CavemanCooking. A hearty thank you for your post - spot on and it works.  Until recently there were problems with google calendats and IiCal in OSX Lion. One can't help but think Apple is disincentivised from supporting google stuff in general. It's worth noting that the iPhone supports delegates directly, so why shouldn't iPad. It's not as if the code hasn't been written, so whay not include it. What convoluted policy decision gave rise to this ommission i do not know.


    Still, I no longer care thanks for the workaround again. Really appreciated.

  • Tony Reidsma Level 1 Level 1 (55 points)
    Currently Being Moderated
    Oct 3, 2012 7:41 AM (in response to CavemanCooking)



    You had me till I had to Click the triangle. I don't see one.


    I just upgraded to Mountain Lion, and now I'm having this issue.





  • Śāntanu Calculating status...
    Currently Being Moderated
    Oct 9, 2012 9:01 AM (in response to Tony Reidsma)

    Tony, I ran into the same problem and I found the solution. After clicking "add account". Choose your account type as "CalDAV". A field for "Server Address" shows up. Paste the address you created into that and fill in your gmail info into the User Name and Password fields. It worked for me. I hope that helps.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.