2 Replies Latest reply: Apr 22, 2012 4:03 AM by Gary - former developer
Gary - former developer Level 1 Level 1 (95 points)

I added a second disk to my G4. It shows up on the desktop just fine.

 

I copied my System folder to it successfully. I then "chose" it as the Startup disk via the Control Panel. But when I restarted, the original disk was still the system disk.

 

I even tried to force the computer to start from the second disk by unplugging the first one. But all that did was vring up the flashing question mark icon.

 

What else can I try to get the system to start from my new disk?

 

 

Gary


G4, Mac OS 9.2.x
  • 1. Re: Setting the startup disk?
    Don Archibald Level 10 Level 10 (101,155 points)

    Make sure on the second drive that -

     

    • the System Folder is at root level of the jard drive. Meaning, that it is visible in the initial window seen when opening the icon of that drive.

     

    • the System Folder is "blessed". This status is indicated by the System Folder displaying the Mac OS glyph superimposed on the folder icon.

     

    • the second drive is not larger than 200GB, or, if partitioned, that the volume being used does not exceed 200GB.

     

    *****

     

    Unplugging the first drive won't work, unless you also reset the second drive's jumpers to Master (or Single if it is a WD brand drive and offers that setting) and disconnect the first drive from the IDE/ATA ribbon cable.

     

    If you did not reset the second drive's jumpers, they may be set wrong. With two drives on a pre-QS G4, use the Master and Slave jumper settings when there are two drives. Note that if the original drive is a WD brand, it may have been set to Single; in that case, it needs to be reset to Master when adding a second drive.

  • 2. Re: Setting the startup disk?
    Gary - former developer Level 1 Level 1 (95 points)

    > disconnect the first drive from the IDE/ATA ribbon cable.

     

    This was the magic phrase. I only pulled the power plug. Once I disconneced the IDE cable, all was well.

     

    Thanks.

     

     

    Gary