9 Replies Latest reply: Jun 4, 2014 3:37 PM by LilLatte
sheafrank Level 1 Level 1 (0 points)

i try to login to the itunes store to update my genius and the 0x80090330 error code comes up. and it did it even when i was already logged in. i can get into itunes help just not the store. what do i do?


Windows 7
  • 1. Re: error 0x80090330
    THEHALLSMTG Level 1 Level 1 (0 points)

    I have the same issue.  Windows 7.  I've talked with Apple and they don't have an answer either.  Definitely a Windows issue, though, I can log in with my iPod and iPad....

  • 2. Re: error 0x80090330
    azsorceress Level 1 Level 1 (0 points)

    me too.  I've been dealing w/it for a couple of months.  First I kept getting an error when I tried to sign into the iTunes store that "a secure connection could not be established".  I did everything all the other knowledge bases said to do - winsock reset, disable firewall, disable antivirus, uninstall / reinstall (have been uninstalling / reinstalling since 10.5), disable Windows Defender, you name it, I've done it.  Another reason I think it's a Windows problem - specifically Windows 7 - ?  I also can't log into Barnes & Noble Nook for PC or Nook Scholar; nor can I download anything from Amazon Unbox Video.  I've told my firewall to open ports 80 and 443, changed the internet options on ALL my browsers (IE, IE 64 bit, Firefox), and nothing has helped.  BUT, the only computer in the house I have trouble with is the desktop running windows 7.  There's a desktop running XP, two laptops running XP, and a laptop running Mac OSX Lion in the same house, no problem - plus a Nook Color, and two iPods.  No Problem.  It's gotta be something in Windows 7, but I dunno what. 

  • 3. Re: error 0x80090330
    azsorceress Level 1 Level 1 (0 points)

    okay.  After months - literally - of screwing around with this, here's what solved the problem:

     

    1) I got rid of RealPlayer using Advanced Uninstaller Pro (if you just uninstall it from its own menu or from your Control Panel, it leaves 400-odd registry entries.

     

    2) I got rid of Avast! Antivirus and installed Microsoft Security Essentials.

     

    3)  I ran a utility called the System File Checker.  Open your command prompt as an Administrator, and enter this: sfc /scannow

     

    Apparently I had a corrupt LSP (Layered Service Provider), which is something that chkdsk doesn't find / correct but the SFC does.

     

    I dunno if my problem would have been solved had I left RealPlayer or Avast! in place, so I'm not gonna blame them .... but I will say that both of 'em almost act like malware, leaving so much stuff in your registry that you have to go thru a whole bunch of steps to get rid of them.

     

    So, that's the end of my saga.  Hope this works for someone else.

  • 4. Re: error 0x80090330
    thebol Level 1 Level 1 (0 points)

    Thanks for your post.  Didn't have Realplayer or Avast! but ran step 3 and it worked a treat.  A problem which has been p***ing me off for weeks has now been fixed. I tried loads of stuff before this and all failed so thanks again buddy!

  • 5. Re: error 0x80090330
    stier1989 Level 1 Level 1 (0 points)

    Thank you so much for this post! As 'thebo" I also only ran step 3 and it worked perfectly! I haven't been able to use Safari (https sites), icloud control panel, and iTunes store for months.

    Now, everything is running smoothly.

  • 6. Re: error 0x80090330
    bondie86 Level 1 Level 1 (0 points)

    theres a command that comes up on this screen that says i am not an administrator so i cant perform this task. but i am an administator on it as its m laptop and no one else cann log on it! please advise

  • 7. Re: error 0x80090330
    Rakesh.HB Level 1 Level 1 (0 points)

    1) I uninstalled Avast! Antivirus.

     

    2)Open your command prompt as an Administrator, and enter this: sfc /scannow. (sfcSPACE/scannow)

    If u re not getting Admin control --> Go to safe mode and Run that command(sfc /scannow) OR goto C:\Windows\System32 and search for sfc and Run as admin and try. It worked for me, hope it works for everyone.

    Thanks to azsorceress for the solution.

  • 8. Re: error 0x80090330
    rumawolf2 Level 1 Level 1 (0 points)

    Okay I tried everything everyone said to do and nothing worked sooooooooo I remembered I had gotten Windows updates about the time of my problem. I went to my file update center and deleted every Windows security file that came in on the date I started having issues.......Problem solved!!!!!!!!! My I tunes store is running perfectly and I hadn't been able to log on since Jan. 18th, 2014.   Just thought this might help someone else out there. I deleted every Windows Security update that I received on Jan. 18th and then restarted my computer and I tunes worked again. 

    Also other programs started to work that aren't even Apple but were presenting the same issues, network connectivity.

  • 9. Re: error 0x80090330
    LilLatte Level 1 Level 1 (0 points)

    Thank you thank you thank you.  I've not been able to access Windows explorer or iTunes store since Nov 2013. I too had tried everything Apple had suggested and everything suggested in the posts above.  i read your post and I figured out the last thing I bought in iTunes was 12th Nov and I went in and removed some windows security updates that came in on the 16th Nov - and BINGO !!  both are now restored.  Thanks so much for your post.  Can't believe its taken 7months to sort this for something so simple.