13 Replies Latest reply: Jan 14, 2013 10:44 PM by Brian Wade Canfield
Lisagbevan Level 1 Level 1 (0 points)

Why do my iMessages show on other peoples iPhones as coming from my email address and not my mobile number?


iPhone 3GS (8GB)
  • 1. Re: iMessage and email address
    Lisagbevan Level 1 Level 1 (0 points)

    By the way, I have tried turning iMessage on and off - no luck and the caller I'd is set to my phone number.

  • 2. Re: iMessage and email address
    randers4 Level 9 Level 9 (57,195 points)

    Go to Setting>Messages>Receive At>Caller ID, choose your phone number rather than your email address.

  • 3. Re: iMessage and email address
    Lisagbevan Level 1 Level 1 (0 points)

    Thanks, but the caller I'd is ticked for my phone number already. But it still shows my email address.

  • 4. Re: iMessage and email address
    randers4 Level 9 Level 9 (57,195 points)

    Then it should identify your messages to others by your phone number. You could try changing it to your email address and then back again to see if that helps.

  • 5. Re: iMessage and email address
    Lisagbevan Level 1 Level 1 (0 points)

    I gave up last night as my phone seemed to stop sending imessages completely!  This morning everything is working fine.  I'm not sure what combination of turning imessage on and off, swapping email and phone as caller ID worked - but one of them plus a good nights sleep must of.

     

    Thanks for the help.

  • 6. Re: iMessage and email address
    Aaron Barna Level 1 Level 1 (0 points)

    I do not have the option to click on "Caller ID" under the imessage settings.  It only gives me the option to add another email address insted of my apple ID address. There's no phone number option.  Please help!

  • 7. Re: iMessage and email address
    randers4 Level 9 Level 9 (57,195 points)

    The Caller ID setting is only available if you have more than one item listed in Receive At (because if you only have one option for Receive At there is no other option to choose for a Caller ID).  If you don't see your number listed along with your email address in Receive At, your number isn't yet activated with the iMessage server and you will probably see "waiting for activation" under iMessage.  Once it does activate you will see your number and email address listed under Receive At and the Caller ID setting will be visible.

  • 8. Re: iMessage and email address
    Aaron Barna Level 1 Level 1 (0 points)

    My iphone was activated over a week ago. How long does it take to activate it because I do have that message "waiting for activation" under my imessage tab when I turn it on.

  • 9. Re: iMessage and email address
    randers4 Level 9 Level 9 (57,195 points)

    Shouldn't take more than a couple of days, and often only takes minutes or seconds.  Some users have a lot of trouble getting iMessage to activate their phone number though.  You can search the forum for "iMessage waiting for activation" and you may find a solution.  Some solutions I've read include:

    • Go to Settings>General>Date & Time, make sure Set Automatically is set to On.
    • Be sure you are able to send and receive messages.
    • Replace the DNS servers on their wireless router with  8.8.8.8 and 8.8.4.4 (these are Google's Public DNS servers, see https://developers.google.com/speed/public-dns/docs/using).

    If you make any of these changes, turn iMessage off, wait a minute or two, then turn back on to reinitiate the activation request process.  You may also need to turn wi-fi off, then back on on your phone to reconnect to your wi-fi if you change the DNS settings.

  • 10. Re: iMessage and email address
    Aaron Barna Level 1 Level 1 (0 points)

    None of these solved the problem

  • 11. Re: iMessage and email address
    randers4 Level 9 Level 9 (57,195 points)

    Yea, it can be a tough one to solve.  Haven't seen any solution that works for everyone.  All I can suggest is that you search the forums; you won't have any trouble finding posts on this issue.  Hopefully you can find a solution that works for you.  Good luck.

  • 12. Re: iMessage and email address
    outlaw307 Level 1 Level 1 (0 points)

    my iMessage just stopped working yesterday.  If I send an iMessssge it shows up as (2) messages...the person i'm sending to (as if they sent it to themselves) and my email.  Plus I can no longer receive iMessages only text  messages.  I have tried ALL of the suggestions above.....UGH!!

  • 13. Re: iMessage and email address
    Brian Wade Canfield Level 1 Level 1 (0 points)

    To anyone having troubles with iMessage and/or Facetime showing e-mail addresses instead of phone numbers:

     

    When initially trying to activate iMessage and Facetime on my iPad, I had a problem with being able to access my phone number. When I signed into my account (on my iPad), I actually wasn't even presented with the option of a phone number - notwithstanding the fact that I was contacting others (and being reached by others) by my phone number on my iPhone. Having both the iPad and the iPhone on, I kept trying to turn off and on both iMessage and Facebook in "Settings" on both my iPad and iPhone, hoping that that they would eventually sync. But this proposed solution by others was unsuccessful for me.

     

    So: I was able to send & receive messages (as well as contact others via Facetime); in "Settings", my "Date & Time" was "Set Automatically" to "On"; and I even tried to turn off the Wi-Fi and sync via Cellular Data only. None of these proposed solutions worked.

     

    Then, I found out what the problem was: When my iPhone was originally activated, it automatically registered my phone number for contact purposes. But I was using iMessage on my iPhone for quite some time without actually being signed into my Apple ID account. When another device - such as an iPad or iPod - is being used for iMessage or Facebook, you are prompted to sign into your Apple account, using your username and password. These two devices will not register your phone number as an option for contact unless your iPhone is signed into your Apple account as well. In other words: your phone number will not be synced.

     

    Go into your "Settings" on your iPhone and click on "Messages". Scroll down and click on "Send & Receive" (which should be followed by your phone number). On the next page, you will be able to determine whether or not your iPhone is using the Apple ID for messaging purposes. (Note: This information applies for Facetime as well.) If it is using your Apple ID for messaging, than at the top, you will see "Apple ID: <your particular e-mail account>" in Blue text. However, if you are not using your Apple ID for messaging, than you will see the words: "Use your Apple ID for message". Even though below this you will see your phone number checked as the contact source, you will want to click the tab that says, "Use your Apple ID for message". Sign into your account (just as you must sign in for iMessage on your other devices), and just choose your phone number as the "Send & Receive" contact. (The option of the e-mail will be there too, but you don't have to check it. And later on, you can delete it as an option.)

     

    Now that all of your devices are signed in using your Apple ID, the other devices should register your phone number as a choice. It may take a little while, however. What I did was sign out of iMessage on my iPad, and then sign in again. If the option didn't appear, I just went back and signed in again, and kept doing this until the option for the phone number appeared.

     

    Again, this will work for Facetime as well. The solution is to sync your iPhone account with the other devices by using your Apple ID for messaging (and Facetime) purposes.

     

    I hope that this works for anyone who is having troubles with this issue! ~ Brian