Skip navigation

Apple TV 3rd gen. DoS-bug stopping homesharing

2952 Views 26 Replies Latest reply: Sep 29, 2012 3:30 AM by wwebers RSS
1 2 Previous Next
wwebers Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 23, 2012 11:06 AM

Hi.

 

As many others here I experienced a nasty bug in Apple iTunes eco-system: Homesharing just stopped after a while.

 

My setup: A mac mini server running 10.7.3 with iTunes 10.6.1 sharing my whole library

One AppleTV 2nd Gen. and one AppleTV 3rd Gen.

 

I first suspected one of the latest iTunes updates. But even downgrading didn't help. First after looking deeper into whats going on network-wise on my revealed the following:

 

netstat itunes.png

Alltogether that made up 198 connections, all to my AppleTV 3:

 

itunes count daap.png

I can imagine it has something to do with the sleep mode. But I'm not sure. All I can see is that I do not experience such a connection hazard with my older AppleTV 2.

 

It really looks like the 3rd Gen AppleTV is running a DoS-attack against iTunes so that finally no other devices are able to connect (thus the definition of a DoS-attach).

 

That's something Apple really has to fix very soon!

Apple TV, Mac OS X (10.7.3)
  • sjogreen Calculating status...
    Currently Being Moderated
    May 6, 2012 4:52 PM (in response to wwebers)

    This is the first sensible thing I've read that explains the problem (a lot of other posts have crazy stand on one leg while hitting "done" type answers).  I can confirm the same thing -- lots and lots of connections to an ATV3rd generation that seem to persist.  I had that ATV3 plugged in via ethernet, I'm going to see if switching to Wifi helps.  Given that quitting and restarting iTunes reliabily fixes the problem, I'm pretty convinced there is some bug between iTunes/ATV3 that causes these network connections to remain open until iTunes just stops responding.

     

    Hoping the propblem doesn't exist over Wifi.  Does Apple actually read these threads -- feel like this is closing in on a nice reporoduceable bug report for them to look into.

  • ejulius Calculating status...
    Currently Being Moderated
    May 6, 2012 5:26 PM (in response to sjogreen)

    It happens to me over wifi.

    Today I've update my AppleTV2 software and installed new iTunes (10.6.1.7) on PC. Now my connection drops every 10 minutes, maybe less.

    Its impossible to watch a single movie.

    Tried to setup Bonjour and make this free on firewall, but did not work

  • infosebca Calculating status...
    Currently Being Moderated
    May 7, 2012 11:35 AM (in response to wwebers)

    I have the same problem and I've seen all the connection in the netstat logging.

     

    I will try to switch to WIFI instead of Wired to see if the problem is solved.

     

    It would be better that the solution that level 2 apple support told me Friday : "Just restart the iTunes software..."

  • TWParker Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 7, 2012 12:18 PM (in response to wwebers)

    Did you apply the latest update to your ATV2, as in it has the new UI like the ATV3?

     

    I did and now I'm experiencing the same bug. HS to my Mac or PC doesn't work, and the Remote app can't connect to the ATV2. AirPlay does work (but not for mirroring, although that might be another issue).

     

    Restarting the ATV2 doesn't work. Disabling/Enabling HS or doing a factory reset/restore does, but it is a pain to have to re-enter my wifi and Apple ID, only to have to stop working within a day.

  • infosebca Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 9, 2012 10:31 AM (in response to wwebers)

    A quick follow-up on this, I’ve switch to the WIFI instead of the wired network connection of my aTV3 and everything is solved.

     

    There is no pending connection in “netstat“ and the WIFI sync and Home Sharing are running flawlessly since 2 days.

     

    Apple need to work on this to correct the situation.

  • sjogreen Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 11, 2012 10:44 PM (in response to wwebers)

    FWIW, switching to Wifi fixed this for me as well, thanks a lot for the tip, this has been extremely annoying.  I know some folks at Apple, will try to get this on someones radar.

  • G.-A. Calculating status...
    Currently Being Moderated
    May 13, 2012 8:02 AM (in response to wwebers)

    This is to lend my support to wwebers findings.

     

    My set up:

     

    IMac running 10.7.4

    iTunes 10.6.1(7)

    Apple TV 3rd generation running iOS 5.0.1, hard wired to TimeCapsule via CAT5e house wiring

    iPad2 running iOS 5.1.1

    IPhone 4 (Verizon) running iOS 5.1.1

    Time capsule running 7.6.1

    Airport Express running 7.6.1, extending the reach of the 802.11n network near the Apple TV

    Home Sharing enabled on all devices with the same Apple ID.

     

    The symptoms are consistent: the library of music/videos is visible when iTunes is first started and eventually becomes unavailable (accessing it shows the "loading _____ library...." for some time then returns to the main menu).  Restarting iTunes restores service, but the problem reoccurs within a couple of hours (estimation).  When the AppleTV is able to access the library, playback is rock solid for the duration of the medium viewed (75-120 minutes usually).

     

    When the problem manifests itself, netstat | Grep daap reveals over a hundred established connections between the iMac and the AppleTV.  These disappear when restarting iTunes, but they build up again over time.

     

    Switching to WiFii resolves all the symptoms, netstat | grep daap returns no results, and AppleTV sees the library through HomeSharing reliably after two days.  So the problem appears to be interface specific on the AppleTV.  Though WiFi solves the problem for me, I prefer a hardwired connection and will pursue this problem through AppleCare.

     

    It should be noted that until recently I operated an AppleTV (2nd generation) with the new UI (IOS version 5.0), but don't recall having this problem.

  • G.-A. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 6, 2012 10:49 AM (in response to wwebers)

    I have been working diligently with a very helpful support engineer at Apple since my last post.  We were able to reproduce all of the symptoms we are familiar with on two independent set ups.  All the fingers now point towards the Apple TV.

     

    We were about to RMA my Apple TV when a software upgrade was released (IOS 5.1.1).  After running this version for 4+ hours, none of the symptoms have returned.  I am hopeful this addresses the issue.

     

    Mr. Webers, have you had a chance to load that version of software on your AppleTV?  If so, has it addressed the problem from your point of view?

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.