Skip navigation

iPhone 4s data issues

1626 Views 11 Replies Latest reply: Apr 26, 2012 8:44 AM by randroid RSS
brett143 Calculating status...
Currently Being Moderated
Jan 5, 2012 6:44 PM

I've been having a problem with data on my iphone 4s.  More often than not, when i have at least three bars, the data speed is extremely slow.  Safari, facebook, foursquare, etc run very slow and sometimes time out because it can't find a connection.  Does anyone else have this issue, or should I be taking it into the apple store?

iPhone 4S, iOS 5.0.1
  • kelseyaudrey Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jan 5, 2012 6:54 PM (in response to brett143)

    First try resetting your network settings by going "Settings>General>Reset>Reset Network Settings. Possibly take out the SIM card and ensure that it is properly sitting in the tray, wipe it off, and put it back in.

  • Lyssa Level 6 Level 6 (14,780 points)
    Currently Being Moderated
    Jan 5, 2012 6:54 PM (in response to brett143)

    Hey brett143 - could you tell us where you live and which cell phone company you're with?

     

    ~Lyssa

  • kelseyaudrey Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jan 5, 2012 7:07 PM (in response to brett143)

    As a reply to your conditions with carrier and location, typically AT&T's network is pretty fast, so if you follow the troubleshooting I previously stated, you might have some luck.

  • Lyssa Level 6 Level 6 (14,780 points)
    Currently Being Moderated
    Jan 5, 2012 7:20 PM (in response to brett143)

    I'll be very interested to hear about your experience - the few times I've visited Chicago, I've had a terrible time getting a data connection in the areas that are densely populated. Suburbs were OK, but downtown I couldn't use my phone for anything but making calls and maybe sending texts. I had full signal, and that didn't help.

     

    I'm currently in Wauwatosa, WI, and my iPhone struggles if I'm traveling during rush hour.

     

    I have an iPhone 4 with AT&T, for reference.

     

    ~Lyssa

  • Duffs543 Calculating status...
    Currently Being Moderated
    Feb 2, 2012 2:37 PM (in response to brett143)

    Are you still having this issue? I noticed this same thing starting about 4-6 weeks ago. It is actually to the point where if my phone is not on wifi, I can't use any data (which would include sending iMessages or checking e-mail). It has basically turned my phone into a computer that needs wifi at all times, so thats how i have been using it this past month. The odd part is I just got a text from ATT saying i am in the top 5% of data users this past month, which doesn't make any sense to me since i have been using wifi more than ever. and basically unable to use data. It makes me think there is a problem with the phone, continually searching for data and not able to connect? I am in Chicago, using a 4S on ATT.

  • s166 Calculating status...
    Currently Being Moderated
    Feb 2, 2012 3:08 PM (in response to brett143)

    I am also having this problem, I find that at home on wifi everything is great.  The minute I leave home and it goes to 3g regardless of how many bars I cannot connect at all, it times out and tells me to check network.  The only thing I have found so far is that when I turn the phone off and back on as long as 3g hooks up first it will then work fine and fast.  It seems like an issue switching from one to the other.  I'm getting tired of turning my phone on and off to fix this!

  • GregNis Calculating status...
    Currently Being Moderated
    Feb 17, 2012 10:49 AM (in response to brett143)

    I'm in South Florida and have the same exact issues! I have called ATT a million times to question why such slow data and they can't figure out why.  So now every month my data is horrible, I make them give me a discount because I am not paying full price for data that doesn't work...especially when they don't know why it soesn't work.  My sverage download speed is between 1 and 2.5Mbps and on a few rare occations have seen it go up to 5Mbps

  • randroid Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 26, 2012 8:44 AM (in response to brett143)

    I added a potential fix to another thread recently. So far people seem to be having success with it, I'd love to see more people test it out:

     

    https://discussions.apple.com/message/18204844#18204844

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.