8 Replies Latest reply: Apr 26, 2012 3:45 PM by EZ Jim
ig.costa Level 1 Level 1 (0 points)

My iMac model is the last one released (mid 2011, 21.5). The problem started about a month ago. I was using skype, tried to use the webcam and then I realised I could not make it work. Tried to open photo booth, as well as iChat, and I had no sucess using the cam on neither of them. Both software oppened, but on both there was the message no cam connected. So I started to google about the problem. Tried restarting holding command + alt + p + r and I downloaded the combo version of Lion OS X 10.7.3. Still had the problem. Then I restarted SMC, and it came to work again, on skype, iChat, and photo booth. I thought the problem was solved, but then 2 days later it came to bother me again. The problem happens all the time, if I reset SMC it works again, but if I turn off the mac, 70% of the time it doesn't work again next time I turn it on. So I took it to the authorized apple service, they DIDN'T find anything wrong, although I sent some links about the problem to the guy working on my computer. So I got it back and it was working fine. Next day "There is no camera connected" appeared again. What's left for me? I bought it in July 8 2011.


iMac (21.5-inch Mid 2011), Mac OS X (10.7.2), OS 10.7.3
  • 1. Re: "There is no camera connected" shows up on an intel based iMac
    EZ Jim Level 7 Level 7 (21,390 points)

    Gather your receipts and politely discuss your problem with your retailer or Apple Authorized Service Provider.

     

    If not available locally, contact AppleCare.  You have the choice of personal visit at an Store, phone, or on-line "Express Lane" service.

     

    I do not see your location.  If you need it,  worldwide contact info is here: Contacting Apple for support and service

     

     

     

    Message was edited by: EZ Jim

  • 2. Re: "There is no camera connected" shows up on an intel based iMac
    aaron mac attack Level 1 Level 1 (0 points)

    i'm pretty sure it's a firmaware problem

    i did the second solution from this site and it worked for my 1.83 core 2 duo imac with lion

    i was having the same problem

     

    check these solutions out

    like i said i used solution number two ( for snow leopard )

    but it worked

     

    http://www.codium.co.nz/isight_fix/

  • 3. Re: "There is no camera connected" shows up on an intel based iMac
    EZ Jim Level 7 Level 7 (21,390 points)

    (1) The fact that your Mac works after reset but fails at another use means that

         firmware is NOT your problem.

     

    (2) Your Mac is running  Mac OS X 10.7 Lion, so a hack from a third-party

         is NOT a solution to your problem, especially one from years ago that was

         originally offered for Snow Leopard (10.6) or Leopard (10.5) Macs.

     

    (3) Although problems with new Macs like yours are uncommon, Apple provides its

         warranty for those unusual cases.  To be certain that your problem is resolved

         for the long-term, have your new Mac checked while warranty is still in effect.

     

     

    Message was edited by: EZ Jim

     

     

    Mac OSX 10.7.3

  • 4. Re: "There is no camera connected" shows up on an intel based iMac
    aaron mac attack Level 1 Level 1 (0 points)

    if it's under warranty ofcourse have apple look at it

    there are really only 3 or 4 things it could be.

     

    software, firmware, hardware, or a the unlikely combintation of all of them.

    and yes the symptoms his computer has sound exactly like firmware corruption.

    not firmware failure.

    if you go to your system profiler and look under USB for your isight / factime camera

    my bet is that it will show up , but only as a " vendor specific usb device "

    if thats the case then it's firmware

     

    macs are great i've owned like 20 of them.

    and apple is usually really great about taking care of problems.

     

    third party "hacks" are what led to the development of the app store and most rad and awesome features that apple adds later .... so whats the point of knocking that stuff.

    honestly there is no way apple would have fixed the firmware problem ( which it was ) for my 6 year old imac.

    the solution i posted is a real working solution for people trying to fix it diy style.

  • 5. Re: "There is no camera connected" shows up on an intel based iMac
    Carlston Level 1 Level 1 (0 points)

    I've had the same problem with my mid-2010 iMac 21.5". It's worked fine until today, when my camera wouldn't show up in Skype or Photobooth. I went to try a conversation in Google Hangouts and it made me install a plugin for my computer.

     

    As if I'd predicted the first piece of any computer advice, I then "turned it off and then on again", and the camera works fine. I'm not sure if it was the plugin or the restart, but I'm confident I'll get this problem again some time soon.

     

    I'm reluctant to use the third party "hack"/solution, as to be honest, I haven't a clue what I'm doing and I don't really want to be messing in Terminal any more than I have to.

     

    I'd be really grateful if anyone could post a known solution to the problem other than 'give 'em a call', as in the past this has not really helped me, and kept me on the phone for half the day.

  • 6. Re: "There is no camera connected" shows up on an intel based iMac
    EZ Jim Level 7 Level 7 (21,390 points)

    Restarting the Mac was a good idea and seems to have corrected your problem, at least for the present time.

     

    If the trouble returns, you are wise not to use any terminal "hack" solution.  The hack is not necessary, and it may complicate finding and correcting the real cause of the problem more difficult for you.  If the problem returns, I would suggest following the developer's directions on how to uninstall the plug-in you added.  Then restart Mac and see if the problem goes away.  If your camera works now, repeat the install/test, uninstall/test process at least one more time.  If the trouble appears when the plug-in is installed and goes away after you have uninstalled, it seems to me that the plug-in is causing a conflict with something in your system.  I would look for a reliable alternative to the conflicting plug-in rather than attempting to correct a plug-in conflict with a non-Apple hack.

     

    For camera problems other than those caused by user installed software conflicts, the first thing you should do is try Apple's http://support.apple.com/kb/HT2090 troubleshooting suggestions.  Be sure to test more than one Apple app in more than one user account.  However, don't use the "Guest" account for testing.  If your Mac has only one account, create a new user account for testing.  The proper SMC/PMU "reset" for your model of Mac often restores normal function.

     

    You don't say which Mac OS you use, but you might also find it helpful to apply the latest Combo Update for your Mac OS X version.  Properly applying the Combo version of OS X updates can sometimes correct software problems not caused by third-party add-ons.  However, if your trouble is caused by a hardware problem, there are no user serviceable parts of iSight.  For hardware help, contact an Apple-Authorized Service Provider for service.

     

     

    Message was edited by: EZ Jim

     

     

    Mac OSX 10.7.3

  • 7. Re: "There is no camera connected" shows up on an intel based iMac
    Carlston Level 1 Level 1 (0 points)

    Hi, I'm using Lion, but my mac originally came with Snow Leopard. tbh since I upgraded to Lion, I've had nothing but problems with the mac, lots of little, annoying problems, but still infuriating.

     

    Anyways...

    My issue was that I was trying to make an urgent call that I didn't have much time to make, so that's why I quickly thought of using Google Hangouts. It was the first time I've tried it, and thats why I thought it wanted to install the plugin, rather than as a solution for me having difficulty with the camera. Although its a third party, I trust Google to give me something that isn't going to break the computer, rather than something like where aaron mac attack linked to.

     

    The problem doesnt seem to have occurred again yet, but if it does I'll just turn it off and on again.

     

    Thanks.

  • 8. Re: "There is no camera connected" shows up on an intel based iMac
    EZ Jim Level 7 Level 7 (21,390 points)

    Carlston wrote: ... The problem doesnt seem to have occurred again yet, but if it does I'll just turn it off and on again.

     

    Thanks.

     

    You're welcome.

     

    Yours is a good plan.  Restarting is the first thing I always try when a sporadic problem occurs.  Unless the problem repeats frequently or continuously, restarting can be the quickest and easiest remedy for issue similar to the one you have experienced.

     

    Carlston wrote: ... I trust Google to give me something that isn't going to break the computer...

     

    Don't be too trusting.  While it won't actually breaks the computer, Google is aware that their software, like that of any developer, can have known issues that they work to resolve.  Here is the current Google Known Issues list.

     

     

    Message was edited by: EZ Jim

     

     

    Mac OSX 10.7.3