Skip navigation

Degraded RAID 1 Help

404 Views 3 Replies Latest reply: Apr 27, 2012 11:05 AM by Camelot RSS
WhiskeyTangoLabs Calculating status...
Currently Being Moderated
Apr 26, 2012 4:15 PM

BACKGROUND:

 

I have a software RAID 1 set up with 2 drives via Disk Utility. The RAID was plugged into another machine and fresh data was added. We did not build a software RAID on the second machine.

 

PROBLEMS:

 

1) The new data from the second machine is only present on the first slice, leading me to believe that since we did not build a RAID with the 2 drives on the second machine, they were recognized independently. Does that sound right?

 

2) When plugged into the original machine, the RAID is degraded which I'm assuming is a function of the 2 drives no longer being perfectly mirrored. I believe that both drives are fine (i.e. no physical failures), however I failed to name them before I RAIDed them, so they both show the same "1TB LaCie" ID in Disk Utility. Even though I'm about 99% sure what the problem is (the lack of data on Slice 2), I would like to confirm that in Disk Utility by identifying the failed drive by name.

 

BIG QUESTION:

 

If I plug in each drive individually and rename them, will they still be recognized in Disk Utility as the respective RAID slices that they are intended to be, or I will I have royally screwed myself?

 

This may be a very convoluted description of my situation, so please feel free to ask clarifying questions, and many thanks in advance to anyone willing to chime in!!

Mac Pro, Mac OS X (10.6.8)
  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    Apr 26, 2012 5:21 PM (in response to WhiskeyTangoLabs)

    1) The new data from the second machine is only present on the first slice, leading me to believe that since we did not build a RAID with the 2 drives on the second machine, they were recognized independently. Does that sound right?

     

    Yes, but it doesn't answer the question as to why - it should be possible to move a RAID set to a new machine. My guess here is that you plugged the drives in independently and that one drive was recognized by the OS before the other was attached (easy to do if the host system is booted at the time). In this case it sees the first drive as a degraded RAID and won't auto-attach the second one.

    To avoid this problem, both drives need to be attached simultaneously, preferably by attaching them to the host before powering-up the system, so that they're both always available.

     

    If I plug in each drive individually and rename them, will they still be recognized in Disk Utility as the respective RAID slices that they are intended to be, or I will I have royally screwed myself?

     

    Irrelevant question. For one, the RAID is based on the UUID of the drives, not their names so renaming these drives isn't going to make much difference - it's just one more delta between the drives.

    You're not particular screwed, though - you can rebuild your mirror using disk utility. It will merge all the data from the first (good) slice to the second, though - it won't just copy the differences.

  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    Apr 27, 2012 11:05 AM (in response to WhiskeyTangoLabs)

    Does Disk Utility automatically target the failed disk for a rebuild?

     

    No, and certainly not with the same drive. If it thinks a drive has failed it will not auto-reinsert it into the RAID set. You have to do that yourself. Don't forget, Disk Utility doesn't know why the RAID failed - for all it knows you have a flaky disk, and you wouldn't want to rebuild back onto the same flaky disk, would you?

     

    Also, one other idea I had this morning was to simply break up the RAID, and essentially start fresh. Thoughts on these approaches?

     

    That's a fine approach, too, as long as you have a backup of your data to restore once you've recreated your RAID.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.